Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Установка Ubuntu 14.04 LTS c проблемным UEFI. [Insyde H2O BIOS]  (Прочитано 2510 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MaminSibiriak

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Доброго времени суток!
Прошу помощи завести Ubuntu на HP Pavilion 15-b052sr. Данный агрегат обладает UEFI Insyde H2O BIOS, собственно, из-за которого после установки системы и перезагрузки выдает сообщение об её отсутствии. Переключение в Legasy режим результата не дает :-[ . Наткнулся в сети на статьи в англ. сообществах, но языками владею плохо, а так как я нуб мне мало что понятно(
Если кто-то сталкивался с такой проблемой и знает как ее решить прошу отозваться.
Вот материал англоязычный: forums.linuxmint.com/viewtopic.php?p=595639&sid=2e914246959571192aa4e8de5ee85626, askubuntu.com/questions/150174/sony-vaio-with-insyde-h2o-efi-bios-will-not-boot-into-grub-efi

Krjd

  • Гость
osvod,
вот тут похоже обсуждается похожая тема

Оффлайн MaminSibiriak

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
osvod,
вот тут похоже обсуждается похожая тема
Там система хотя бы запускается после установки. 

Krjd

  • Гость
osvod,
какая задача? поставить только Ubuntu или Ubuntu & Windows?

Оффлайн MaminSibiriak

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
osvod,
какая задача? поставить только Ubuntu или Ubuntu & Windows?
Установить только Ubuntu.

Krjd

  • Гость
osvod,
образ брали с ubuntu.ru/ubuntu.com ?
как создавали флешку?
грузились при установке в UEFI Mod? (без Secure)
как размечали разделы?

Оффлайн MaminSibiriak

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
osvod,
образ брали с ubuntu.ru/ubuntu.com ?
как создавали флешку?
грузились при установке в UEFI Mod? (без Secure)
как размечали разделы?
Да, именно оттуда.
UltraISO, Unetbootin.
Грузился и в UEFI и в Legaсy, и с отключенным и с включенным Secure Boot.
       200mb - EFI
       20Gb  - /
       1024mb - Swap
       остальное хоум.(загрузчик ставил на sda, потом решил проверить и поставил на sda1(EFI) - не грузит)

Krjd

  • Гость
osvod,
грузитесь в UEFI
Цитировать
загрузчик ставил на sda
если грузится с флешки не мала вероятность того что sda - флешка, sdb - диск, т.е. попробуйте поставить на sdb

если не помогло попробуйте увеличить EFI до 512mb

Оффлайн MaminSibiriak

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Нет, я проверял. Загрузчик ставил на sda как жесткий диск.
Увеличивал до гигабайта.
Я дал ссылки, где как я понял делают подмену efi файлов, биос хавал и спокойно грузил.

Krjd

  • Гость
osvod,
не, там обсуждается как подружить ubuntu и windows, по отдельности все работает...

Пользователь решил продолжить мысль 16 Июнь 2014, 00:30:20:
osvod,
а если попробовать Boot repair после установки? м.б. он там разберется что к чему..
« Последнее редактирование: 16 Июнь 2014, 00:30:20 от D101101 »

Оффлайн MaminSibiriak

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Ситуация такая, что Grub просто не стартует( Перепроверял разные варианты, не хочет запускаться.

Пользователь решил продолжить мысль 16 Июнь 2014, 00:35:12:
а если попробовать Boot repair после установки? м.б. он там разберется что к чему..
А как? я могу примонтировать и с лайв системы работать в установленной? или программа сама все определит?
« Последнее редактирование: 16 Июнь 2014, 00:35:12 от osvod »

Krjd

  • Гость
osvod,
да я понимаю, он просто должен вам поставить grub
сделайте флешку с Boot repair и загрузитесь с нее, образ брать здесь

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 4997
  • Все по палатам!
    • Просмотр профиля
Здесь же вроде получилось у человека
http://forums.linuxmint.com/viewtopic.php?p=595639&sid=2e914246959571192aa4e8de5ee85626
только требуется дистр Вин7. Преведите страницу и попробуйте
Извините, я все еще учусь

Оффлайн MaminSibiriak

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Ребята, спасибо что уделили мне время!
Проблема решилась так:
Выставил в биосе режим Legacy, перед загрузкой с флешки появилось два варианта: Ubuntu USB и Ubuntu UEFI.
Выбрал именно UEFI, установил, выставил в биосе режим UEFI и все завелось.
Странно то, что если не переключить в Legacy, UEFI не заводится. Хотя я нуб, прошу прощения что отнял ваше время.

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 4997
  • Все по палатам!
    • Просмотр профиля
osvod, нам то за что, скажи "спасибо" авторам биоса (судя по гуглу, с ним у многих проблемы)
Извините, я все еще учусь

 

Страница сгенерирована за 0.131 секунд. Запросов: 24.