Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: VirtualBox: Ubuntu Server (гость) «видит» только один сетевой адаптер  (Прочитано 1993 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн milton14

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Имеется ноутбук с Ubuntu 14.04 (amd64), на котором установлен VirtualBox 4.3.12 из Оракловского репозитария. Поставил Ubuntu Server 14.04, установил дополнения гостевой ОС, однако при настройке сети возникла проблема: система видит только один сетевой адаптер.
В настройках виртуальной машины указываю две сети: NAT — для выхода в Интренет и установки пакетов и виртуальный адаптер хоста — для работы с гостем на хосте. Если сетевой адаптер № 1  - NAT, а сетевой адаптер № 2 — виртуальный адаптер хоста, то через ifconfig вижу только NAT, если же наоборот — то только виртуальный адаптер хоста.
Пробовал вручную добавить новый сетевой интерфейс в /etc/network/interfaces, однако все мои телодвижения успехом не увенчались. Посоветуйте, please, как решить эту проблему.

Оффлайн Tokuan

  • Старожил
  • *
  • Сообщений: 1246
    • Просмотр профиля
    • В поисках здравого смысла
milton14,
виртуальные сетевые адаптеры вы назначаете одному или разным сетевым адаптерам хоста?
"— Милая, - сказал он, - у вас в голове пять тысяч маркетологов срали десять лет, а вы хотите, чтобы я там убрал за пять минут…"
Пелевин В.О "Empire V"

Оффлайн milton14

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
milton14,
виртуальные сетевые адаптеры вы назначаете одному или разным сетевым адаптерам хоста?
Одному (по умолчанию).
Поставил десктоп в качестве гостя — никаких проблем нет, все работает из коробки, а с серверным вариантом вот такие проблемы. Никак не пойму в чем причина.
P.S. Дополнения гостевой ОС устанавливал как написано тут.
« Последнее редактирование: 16 Июнь 2014, 22:39:13 от milton14 »

Оффлайн Tokuan

  • Старожил
  • *
  • Сообщений: 1246
    • Просмотр профиля
    • В поисках здравого смысла
milton14,
в десктопе network manager, а в сервере нет. Может в этом дело? Надо ручками в системе второй адаптер прописать?
"— Милая, - сказал он, - у вас в голове пять тысяч маркетологов срали десять лет, а вы хотите, чтобы я там убрал за пять минут…"
Пелевин В.О "Empire V"

Оффлайн milton14

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Сегодня добавил в /etc/network/interfaces второй адаптер с именем, указанным в выводе lshw — заработало, но после перезагрузки. Оказывается, стандартные средства перегрузки сети (/etc/init.d/networking и service networking) в Ubuntu Server не работают, но есть другой способ.
Этот момент и сбил с толку в прошлый раз, когда добавлял сетевой интерфейс, перезагружал сеть и не видел никакого результата.
В любом случае, спасибо за помощь.
« Последнее редактирование: 17 Июнь 2014, 07:56:43 от milton14 »

 

Страница сгенерирована за 0.055 секунд. Запросов: 24.