Форум русскоязычного сообщества Ubuntu


Автор Тема: Проблема при обновлении Ubuntu 11.10  (Прочитано 518 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nickdaniua

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Все привет. У меня случилась большая беда, на работе необходимо было обновить мою стареньку Ubuntu.
Обновил пакеты, начал обновлять систему через do-release-upgrade и вылезла ошибка.

dpkg: error: parsing file '/var/lib/dpkg/status' near line 28553 package 'flashplugin-installer':
 mixed non-coinstallable and coinstallable package instances present

при попытки удалить apt-get autoremove --purge \ remove flashplugin-installer

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libapparmor-perl : Depends: perlapi-5.14.2
 libc6-dev : Depends: libc6 (= 2.15-0ubuntu20.2) but 2.15-0ubuntu10.5 is to be installed
 libcrypt-openssl-rsa-perl : Depends: perlapi-5.14.2
 libgconf-2-4:i386 : Depends: libdbus-glib-1-2:i386 (>= 0.78) but it is not going to be installed
 libgnome2-vfs-perl : Depends: perlapi-5.14.2
 libgtk2-appindicator-perl : Depends: perlapi-5.14.2
 libgtk2-perl : Depends: perlapi-5.14.2
 libperl5.14 : Depends: perl-base (= 5.14.2-13ubuntu0.3) but 5.12.4-4ubuntu0.2 is to be installed
 libpurple0 : Depends: perl-base (>= 5.14.2-13ubuntu0.3) but 5.12.4-4ubuntu0.2 is to be installed
              Depends: perlapi-5.14.2
 librsvg2-2:i386 : Depends: libcroco3:i386 (>= 0.6.2) but it is not going to be installed
 perl : Depends: perl-base (= 5.14.2-13ubuntu0.3) but 5.12.4-4ubuntu0.2 is to be installed
        Depends: perl-modules (>= 5.14.2-13ubuntu0.3) but 5.12.4-4ubuntu0.2 is to be installed
 perlmagick : Depends: perlapi-5.14.2
 texlive-base : Depends: texlive-doc-base (>= 2012.20120516) but 2009-2 is to be installed
                Depends: texlive-common (>= 2012.20120516) but 2009-15 is to be installed
                Depends: tex-common (>= 3) but 2.10 is to be installed
 texlive-binaries : Depends: texlive-common (>= 2011) but 2009-15 is to be installed
                    Depends: tex-common (>= 3) but 2.10 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


пытался полностью удалить пакеты flashplugin-installer, но при апдейте заново ту же ошибку выдает, как я понял с репозитория выкачивает кривой фшел. Не знаю, что делать, может у кого то есть идеи ?

pupnix

  • Гость
Re: Проблема при обновлении Ubuntu 11.10
« Ответ #1 : 16 Июнь 2014, 17:04:03 »
nickdaniua,
sudo apt-get install -f?

Оффлайн nickdaniua

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Проблема при обновлении Ubuntu 11.10
« Ответ #2 : 16 Июнь 2014, 17:19:58 »
nickdaniua,
sudo apt-get install -f?
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1932 not upgraded.


при apt-get upgrade

dpkg: error: parsing file '/var/lib/dpkg/status' near line 27103 package 'flashplugin-installer':
 mixed non-coinstallable and coinstallable package instances present
E: Sub-process /usr/bin/dpkg returned an error code (2)


и все, флеш не дает ничего делать

pupnix

  • Гость
Re: Проблема при обновлении Ubuntu 11.10
« Ответ #3 : 16 Июнь 2014, 17:26:03 »
sudo apt-get purge flashplugin* ubuntu-restricted-extras*
sudo apt-get --purge autoremove
sudo apt-get update
sudo do-release-upgrade

Оффлайн omni64

  • Активист
  • *
  • Сообщений: 693
    • Просмотр профиля
Re: Проблема при обновлении Ubuntu 11.10
« Ответ #4 : 16 Июнь 2014, 20:50:03 »
может проще будет поставить с 0 актуальный релиз?

Оффлайн vicmic

  • Участник
  • *
  • Сообщений: 183
  • Scientia potentia est (Знание - сила)
    • Просмотр профиля
Re: Проблема при обновлении Ubuntu 11.10
« Ответ #5 : 16 Июнь 2014, 21:37:19 »
nickdaniua, какое у Вас железо, что Вам только 11.10 подходит?
Ubuntu 14.04 LTS 64-bit / Intel® Core™ i7 CPU Q 740 @ 1.73GHz × 8 / 7.7 GiB
Ubuntu 16.04 LTS 32-bit / Intel® Core™2 CPU 6400 @ 2.13GHz × 2 / 3.8 GiB / Intel® 965G I
Mint 18 32-bit /DELL Latitude D820

 

Страница сгенерирована за 0.059 секунд. Запросов: 24.