Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: vbox\Не получается подключить образ дополнения гостевой ОС  (Прочитано 17771 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн HAIRY

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Здравствуйте! В общем такая проблема. Поставил linux(первый раз), пытаюсь поставить дополнения, выскакивает ошибка «не удалось подключить виртуальный оптический диск». вот нашел пару решешний, но они не помогли

ubuntu@ubuntu:/> sudo mkdir /mnt/cdrom
ubuntu@ubuntu:/> ls /dev/sr*
sr0
ubuntu@ubuntu:/> sudo mount -t iso9660 /dev/sr0 /mnt/1

ввожу последнюю строчку пишет что mnt/1 не существует полистал дальше

sudo mkdir /vbox
sudo mount -t iso9660 /dev/sr0 /vbox
cd /vbox
ls
sudo sh VBox*.sh

ввожу sudo mount -t iso9660 /dev/sr0 /vbox пишет блочное устройство защищено от записи. Помогите пожалуйста разобраться.
« Последнее редактирование: 17 Февраль 2016, 21:23:25 от it0r »

Оффлайн hon

  • Старожил
  • *
  • Сообщений: 1044
  • Ubuntu 12.04 LTS
    • Просмотр профиля
Как VirtualBox должен дать возможность записи в образ iso? Поэтому монтирование происходит в режиме только-чтение.

Krjd

  • Гость
HAIRY,
Как VirtualBox должен дать возможность записи в образ iso? Поэтому монтирование происходит в режиме только-чтение.
это значит попробуйте так
sudo mount -r -t iso9660 /dev/sr0 /vbox

Оффлайн HAIRY

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Подскажите пожалуйста как проверить установилась ли дополнения для гостевой ОС. вроде linux не тормозит, а общие папки, копирование файлов сделать не получается

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1471
  • ubuntu 18.04
    • Просмотр профиля
HAIRY,
lsmod | grep -i vbox

Оффлайн pupinizator

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Проблема похожая. Подскажите пожалуйста какие могут быть решения? Столько уже всего перепробовал что голова кругом.


Просьба ознакомиться с Правилами форума.
Цитата:
Правила форума
1. Основные положения
1.5. Для добавления графических изображений в сообщения требуется использовать внешние сервисы. Подробную инструкцию, а так же список рекомендованных и запрещенных сервисов можно посмотреть в «Руководстве по добавлению изображений на форум».
Графику подправил.
-- it0r

« Последнее редактирование: 17 Февраль 2016, 22:09:13 от it0r »

Krjd

  • Гость
pupinizator,

для начала Руководство по добавлению изображений на форум

по поводу проблемы

попробуй сделать так:
1. выключить эту виртуальную машину
2. выбрать ее и зайти в настройки виртуальной машины ("свойства" у тебя на скриншоте)
3. перейти на вкладку с носителями и выбрать привод с образом дополнений
4. нажать на иконку диска с права и выбрать "Изъять диск из привода"(фраза может отличатся, суть та же)

у меня это выглядит так


после этого заного примонтируй дополнения, должно заработать нормально
« Последнее редактирование: 27 Январь 2015, 00:40:28 от D101101 »

Оффлайн megstas

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
pupinizator,

для начала Руководство по добавлению изображений на форум

по поводу проблемы

попробуй сделать так:
1. выключить эту виртуальную машину
2. выбрать ее и зайти в настройки виртуальной машины ("свойства" у тебя на скриншоте)
3. перейти на вкладку с носителями и выбрать привод с образом дополнений
4. нажать на иконку диска с права и выбрать "Изъять диск из привода"(фраза может отличатся, суть та же)

у меня это выглядит так


после этого заного примонтируй дополнения, должно заработать нормально


Не помогают все рекомендации пробовал, все равно не подключается диск с образом
Помогите пожалуйста что еще может быть?
http://prntscr.com/5ycidp

Krjd

  • Гость
megstas,
хм...
попробуйте удалить привод и добавить другой



а версия VirtualBox актуальная?

Оффлайн megstas

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
да я пробовал удалять приводы, тоже не помогло

версия VirtualBox актуальная

Оффлайн ElizabethII

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Аналогичная беда. При чём, ранее дополнения работали и вдруг перестали не пойму из-за чего

Оффлайн Виктор Перестукин

  • Старожил
  • *
  • Сообщений: 2153
    • Просмотр профиля
Тогда аналогичный вопрос. Что показывает команда:
lsmod | grep -i vbox

Оффлайн Петрович

  • Любитель
  • *
  • Сообщений: 91
  • Проблема - когда нет проблем
    • Просмотр профиля
HAIRY и другие. Проверьте - являитесь ли вы членами группы 'vboxusers' (через Свойства Пользователя).
Asus H170M-PLUS; Core i5-6500 3.2GHz; 16GB DDR4-2133; Intel HD Graphics 530 1536MB; InteI i219-V + TL-WDN4800; 2xSSD + HDD; VX2453 23,5"
OS x64: Runtu XFCE 16.04.3; Win 10 Ent; OS X El Capitan 10.11.6

Оффлайн asaelecti

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Тоже столкнулся с подобной проблемой.
Изначально ставил на virtualbox 4.1.4-74291 ubuntu 14.4 (32) (на ПК установлена Win 8.1 - 64);
Ничего из выше сказанного не помогало;
Помогло: переустановил virtualbox (поменял на версию 5.0.20-106931), поставил на нее ubuntu-14.04.4-desktop-i386 (32)
После чего дополнения для гостевой ОС установились успешно.

Причем: сразу после успешной установки дополнений для гостевой ОС сделал снимок системы (что и всем рекомендую). После чего обновил ubuntu. После установки обновлений такое благо, как нормальное (настраиваемое) разрешение окна перестало существовать. Попытка установить дополнения для гостевой ОС стало вызывать (снова) вышеупомянутую ошибку. Пришлось восстанавливать систему со снимка  :-\
« Последнее редактирование: 02 Июнь 2016, 14:39:44 от asaelecti »

 

Страница сгенерирована за 0.058 секунд. Запросов: 24.