Форум русскоязычного сообщества Ubuntu


Автор Тема: Принтер Canon PIXMA iP2840  (Прочитано 6084 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kolapsec

  • Автор темы
  • Новичок
  • *
  • Сообщений: 36
  • Linux mint 17.3
    • Просмотр профиля
Принтер Canon PIXMA iP2840
« : 02 Июль 2014, 11:50:20 »
Привет всем.

Народ у кого есть принтер Canon PIXMA iP2840?
Как установить дрова на него? Мучаюсь уже неделю, если выбирать дрова от iP2000 или iP2800 не хочет печатать хоть убей...

В Линуксе я не долго, но кой чего умею, когда качаю дрова с офф сайта - диспечер приложений не может их открыть (да-да-да, файл делал исполняемым)...

Может кто опишет мне, как установить и настроить этот принтер?

Заранее спасибо за ответы и советы :)

+ у меня Xubuntu 14.04
« Последнее редактирование: 02 Июль 2014, 11:51:52 от Kolapsec »
"А я при Советской власти отлично жил. Лежишь, жрёшь от пуза, пелёнки меняют..."

chemtech

  • Гость
Re: Принтер Canon PIXMA iP2840
« Ответ #1 : 02 Июль 2014, 12:42:24 »
Зачем одинаковую тему создавать?
Принтер Canon PIXMA iP2840

Оффлайн Kolapsec

  • Автор темы
  • Новичок
  • *
  • Сообщений: 36
  • Linux mint 17.3
    • Просмотр профиля
Re: Принтер Canon PIXMA iP2840
« Ответ #2 : 02 Июль 2014, 13:11:29 »
Зачем одинаковую тему создавать?
Принтер Canon PIXMA iP2840

Один хрен никто не отписывает там...
+ на XFCE перешел.

Пользователь решил продолжить мысль 02 Июль 2014, 15:01:06:
http://www.canon.ru/Support/Consumer_Products/products/printers/InkJet/PIXMA_iP_series/PIXMA_iP2840.aspx?type=download&softwaredetailid=tcm:203-1144290&os=&language=

Ну вот здесь исходники дров.

Что с ними делать? Как правильно установить?
« Последнее редактирование: 02 Июль 2014, 15:01:06 от Kolapsec »
"А я при Советской власти отлично жил. Лежишь, жрёшь от пуза, пелёнки меняют..."

Оффлайн igor822605

  • Участник
  • *
  • Сообщений: 229
    • Просмотр профиля
Re: Принтер Canon PIXMA iP2840
« Ответ #3 : 02 Июль 2014, 15:07:17 »
 Можно собрать rpm-пакет следуя readme, а затем крнвертнуть его в deb-пакет.

Оффлайн Kolapsec

  • Автор темы
  • Новичок
  • *
  • Сообщений: 36
  • Linux mint 17.3
    • Просмотр профиля
Re: Принтер Canon PIXMA iP2840
« Ответ #4 : 02 Июль 2014, 15:16:49 »
Можно собрать rpm-пакет следуя readme, а затем крнвертнуть его в deb-пакет.

А можно подробнее?
 

(Нажмите, чтобы показать/скрыть)
   

Вот такое я увидел в "Ридми"...
Но это мне ничего не говорит?

Вы мне сможете объяснить что надо делать?
Ну хоть на пальцах :)


Пользователь решил продолжить мысль 02 Июль 2014, 15:18:48:
igor822605,
+ может лучше сразу этот качать?

http://www.canon.ru/Support/Consumer_Products/products/printers/InkJet/PIXMA_iP_series/PIXMA_iP2840.aspx?type=download&softwaredetailid=tcm:203-1144298&os=Linux&language=EN


Только как его установить?
Я его делал исполняемым, центр приложений Ubuntu выдавал ошибку...
« Последнее редактирование: 02 Июль 2014, 15:18:48 от Kolapsec »
"А я при Советской власти отлично жил. Лежишь, жрёшь от пуза, пелёнки меняют..."

chemtech

  • Гость
Re: Принтер Canon PIXMA iP2840
« Ответ #5 : 02 Июль 2014, 15:23:08 »
Какие файлы скачали?

Оффлайн Kolapsec

  • Автор темы
  • Новичок
  • *
  • Сообщений: 36
  • Linux mint 17.3
    • Просмотр профиля
Re: Принтер Canon PIXMA iP2840
« Ответ #6 : 02 Июль 2014, 15:25:47 »
Какие файлы скачали?

Драйвер принтера IJ серии iP2800, версия 4.10 для Linux (debian Packagearchive)

Центр приложений Ubuntu выдает ошибку.

+ пробовал установить через "Принтеры" в настройках, выбирал тоже 2800, после установки - тестовую страницу не печатал, совсем не реагировал принтер.
"А я при Советской власти отлично жил. Лежишь, жрёшь от пуза, пелёнки меняют..."

Оффлайн igor822605

  • Участник
  • *
  • Сообщений: 229
    • Просмотр профиля
Re: Принтер Canon PIXMA iP2840
« Ответ #7 : 02 Июль 2014, 15:30:31 »
Поиск по форуму выдал такую ссылку Сам не собирал. Но действовал б согласно статье "Вариант 2: Когда в репозитории есть пакет предыдущей версии".

Пользователь решил продолжить мысль 02 Июль 2014, 15:32:39:
Не устанавливается из-за системных требований, а именно Ubuntu 13.10 (32-/64-разрядная)
« Последнее редактирование: 02 Июль 2014, 15:32:39 от igor822605 »

Оффлайн Kolapsec

  • Автор темы
  • Новичок
  • *
  • Сообщений: 36
  • Linux mint 17.3
    • Просмотр профиля
Re: Принтер Canon PIXMA iP2840
« Ответ #8 : 02 Июль 2014, 15:39:28 »
Поиск по форуму выдал такую ссылку Сам не собирал. Но действовал б согласно статье "Вариант 2: Когда в репозитории есть пакет предыдущей версии".

Пользователь решил продолжить мысль 02 Июль 2014, 15:32:39:
Не устанавливается из-за системных требований, а именно Ubuntu 13.10 (32-/64-разрядная)

А если из исходников создать деб-пакет, будет работать?
Или тоже не пойдет? Если у меня не 13.10, а 14.04?
"А я при Советской власти отлично жил. Лежишь, жрёшь от пуза, пелёнки меняют..."

chemtech

  • Гость
Re: Принтер Canon PIXMA iP2840
« Ответ #9 : 02 Июль 2014, 16:51:15 »
Название файлов, которые скачали сюда

Оффлайн Kolapsec

  • Автор темы
  • Новичок
  • *
  • Сообщений: 36
  • Linux mint 17.3
    • Просмотр профиля
Re: Принтер Canon PIXMA iP2840
« Ответ #10 : 09 Июль 2014, 17:32:32 »
Спросил у тех. поддержки.
Драйверов на этот принтер для Ubuntu 14.04 пока нету.
И не известно будут или нет...
"А я при Советской власти отлично жил. Лежишь, жрёшь от пуза, пелёнки меняют..."

fly-R

  • Гость
Re: Принтер Canon PIXMA iP2840
« Ответ #11 : 14 Июль 2014, 03:48:58 »
может там проще все и не нужны никакие дрова, через cups не пробовал?
http://127.0.0.1:631/

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2471
    • Просмотр профиля
Re: Принтер Canon PIXMA iP2840
« Ответ #12 : 14 Июль 2014, 06:11:35 »
+ на XFCE перешел.

Да, это принципиальная разница!

Можно собрать rpm-пакет следуя readme, а затем крнвертнуть его в deb-пакет.
В deb-системе? Rpm-пакет? Ну-ну. Давно так делал?
К конвертации тоже относится.

Драйвер принтера IJ серии iP2800, версия 4.10 для Linux (debian Packagearchive)

Центр приложений Ubuntu выдает ошибку.

Какую именно? Почему из вас, "кой чего" умеющих, все клещами тянуть приходится?
Подозреваю, что ты просто "забыл" распаковать свой deb-пакет.
Я никого не сторожил!

Оффлайн koshev

  • Старожил
  • *
  • Сообщений: 1671
  • חתול המדען
    • Просмотр профиля
Re: Принтер Canon PIXMA iP2840
« Ответ #13 : 14 Июль 2014, 07:15:09 »
Можно собрать rpm-пакет следуя readme, а затем крнвертнуть его в deb-пакет.
А что бы сразу deb не собрать?
Ну и кроме того, по ссылке deb'ки уже есть.
Debian GNU\Linux 7.11; ICH7; r8169; Linux 4.14.32-atomd525mv-imq-ja1 (i686)
Ubuntu GNU\Linux 18.04; MCP61; forcedeth; 4.15.0-20-generic (x86_64)

Оффлайн Kolapsec

  • Автор темы
  • Новичок
  • *
  • Сообщений: 36
  • Linux mint 17.3
    • Просмотр профиля
Re: Принтер Canon PIXMA iP2840
« Ответ #14 : 19 Июль 2014, 21:21:45 »

Драйвер принтера IJ серии iP2800, версия 4.10 для Linux (debian Packagearchive)

Центр приложений Ubuntu выдает ошибку.

Какую именно? Почему из вас, "кой чего" умеющих, все клещами тянуть приходится?
Подозреваю, что ты просто "забыл" распаковать свой deb-пакет.


Ошибку выдает, потому что дрова на 13.10, к 14.04 не подходят.
Об этом говорилось выше, + на сайте кенона подтвердили что, пока, дров на принтер для 14.04 нету.


Пользователь решил продолжить мысль 19 Июль 2014, 21:23:43:
может там проще все и не нужны никакие дрова, через cups не пробовал?
http://127.0.0.1:631/

Пишет - нет такого файла...

Всем спасибо за советы.
Тему закрываю.
Жду когда будут дрова подходящие для хUbuntu 14.04.
Пока установил жене на шиндовс, что б краска не засохла :)
« Последнее редактирование: 19 Июль 2014, 21:23:43 от Kolapsec »
"А я при Советской власти отлично жил. Лежишь, жрёшь от пуза, пелёнки меняют..."

 

Страница сгенерирована за 0.065 секунд. Запросов: 24.