Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Не определяется вентилятор на ноутбуке MSI GE60-2OD  (Прочитано 1312 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн @rch1tect0r

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
В общем я счастливый обладатель вышеобозначенного ноута. Родную Win8 снёс на 2й день, какое-то время был на Win7, но винда мне надоела своими глюками и прожорливостью(винда теперь живёт в виртуальной машине, т.к. нужна только для работы). Решил переехать на линукс. Перебрал кучу дистрибутивов, с UEFI на этом ноутбуке удалось подружить только Ubuntu 14.04

В этом ноутбуке есть хитрая опция принудительного продува всей СО по кнопке, она то меня и спасает, а вот сам по себе вентиль не запускается. При попытке использовать sensors-detect у меня не определяется никакой контроллер и соответственно вентилятор не видится.

Вентилятор точно работает, потому что если запустить какой-нибудь чистый uefi shell(скажем простой загрузчик для прошивки биоса UEFI), то как только проц прогреется, то вентиль раскручивается, а вот в ОС не хочет ни в какую.

Итак, может ли быть такая проблема из-за того что у меня биос в режиме UEFI?
И как вообще можно попытаться иначе определить вентилятор в системе и пнуть его?

P.S. производитель заявляет как всегда поддержку только винды, но у меня всё взлетело, кроме выше обозначенной проблемы.

chemtech

  • Гость
Как зарегистрировать ошибку Ubuntu
Регистрируйтесь на https://launchpad.net/
Откроете браузер, войдите в него.
Потом запустите

apport-bug linux
Появляется окно "Сбор информации о неполадке", а затем "Отправить отчёт об ошибке разработчикам".
Откроется новая вкладка на https://launchpad.net/
В описании ошибки укажите

Fan is not running on MSI GE60-2OD
apport-bug соберет всю необходимую информацию и отправит на https://launchpad.net/

Оффлайн @rch1tect0r

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
chemtech, отправил, надеюсь помогут в решении проблемы.

chemtech

  • Гость
Напиши еще в баге:
 - в винде оно работало или нет
 - включен или отключен uefi
 - другие настройки, которые изменяли в BIOS

Оффлайн @rch1tect0r

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Думаю надо отписаться. В связи с тем, что я ноутом очень активно пользуюсь, то на эксперименты не всегда остаётся время.
Если коротко то, что было сделано.
1) Обновление биоса до последней версии
2) Установка ядра версии mainline(сейчас это 3.17-rc6)
3) уставновка пакета thermald и ручная активация intel pstate и intel rapl

Не знаю сыграл ли биос, но последние два пункта однозначно снимают вопрос. Кстати в текущей версии ядра(3.14) intel rapl ни в какую у меня не заводился.

Вентилятор у меня так и не находится как pwm, но он точно замедляется и ускоряется, а также сам ноут стал гораздо холоднее и дело не в погоде за окном(это точно, потому что когда активно работал, то вентиль всегда на максимуме, а сейчас можно временами включать принудительный продув)

 

Страница сгенерирована за 0.158 секунд. Запросов: 24.