Форум русскоязычного сообщества Ubuntu


Автор Тема: Сбой при установке обновления Hardware  (Прочитано 2598 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Asok177

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Следующие пакеты имеют неудовлетворённые зависимости:

libgl1-mesa-glx-lts-trusty: Depends: libglapi-mesa-lts-trusty (= 10.1.3-0ubuntu0.1~precise1) но 10.1.3-0ubuntu0.1~precise1 должен быть установлен
                            Depends: libx11-6 (>= 2:1.4.99.1) но 2:1.4.99.1-0ubuntu2.2 должен быть установлен
                            Depends: libxdamage1 (>= 1:1.1) но 1:1.1.3-2build1 должен быть установлен
xserver-xorg-input-all-lts-trusty: xserver-xorg-lts-trusty: Depends: xserver-xorg-core-lts-trusty (>= 2:1.11) но 2:1.15.1-0ubuntu2~precise1 должен быть установлен

apt-get update, .....upgrade .....-f install  .....autoremove всё делал, не помогает

Спасибо

Пользователь решил продолжить мысль [time]20 Июль 2014, 09:54:21[/time]:
Короче, попытался сделать вручную:
sudo apt-get install libglapi-mesa libx11-6 libxdamage1
после этого ошибка уменьшилась:
Следующие пакеты имеют неудовлетворённые зависимости:

xserver-xorg-lts-trusty: Depends: xserver-xorg-core-lts-trusty (>= 2:1.11) но 2:1.15.1-0ubuntu2~precise1 должен быть установлен

но этот xserver ни в какую не желает ставиться:
~$ sudo apt-get install xserver-xorg-core-lts-trusty

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 xserver-xorg-core-lts-trusty : Конфликтует: xserver-xorg-core
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

~$ sudo apt-get install xserver-xorg-core

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия xserver-xorg-core.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

Совсем удалил этот xserver-xorg-core, всё равно конфликтует

Помогите!
« Последнее редактирование: 20 Июля 2014, 10:00:27 от Asok177 »

chemtech

  • Гость
Re: Сбой при установке обновления Hardware
« Ответ #1 : 20 Июля 2014, 11:32:37 »
PPA какие-нибудь подключали?

Пользователь решил продолжить мысль 20 Июля 2014, 11:32:55:
lsb_release -a

Оффлайн Asok177

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Сбой при установке обновления Hardware
« Ответ #2 : 20 Июля 2014, 15:05:07 »
PPA какие-нибудь подключали?

Пользователь решил продолжить мысль [time]20 Июль 2014, 11:32:55[/time]:
lsb_release -a
Да, подключал, много разных

~$ lsb_release -a
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.4 LTS
Release: 12.04
Codename: precise

Вообщем, мучил-мучил я установщик пакетов и доигрался. ГУИ совсем перестал грузиться..
Тогда я зашёл через safe-mode, и выполнил несколько команд, которые были на чёрном экране приветствия. Одна из них была
sudo apt-get install linux-generic-lts-trusty linux-image-generic-lts-trusty
После этого, слава тебе Господи, и ГУИ пошёл, и HW-обновления больше не показываются

fuss

  • Гость
Re: Сбой при установке обновления Hardware
« Ответ #3 : 20 Июля 2014, 15:07:19 »
Я специально сегодня написал! https://forum.ubuntu.ru/index.php?topic=247224.0

Пользователь решил продолжить мысль 20 Июля 2014, 15:13:47:
Если есть проблема с этим, до добавить ключ --install-recommends
Если проблема с дровами из ppa, sudo ppa-purge название и удалить их
« Последнее редактирование: 20 Июля 2014, 15:13:47 от hello.internutz »

Оффлайн Asok177

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Сбой при установке обновления Hardware
« Ответ #4 : 20 Июля 2014, 18:48:46 »
Я специально сегодня написал! https://forum.ubuntu.ru/index.php?topic=247224.0

Пользователь решил продолжить мысль [time]20 Июль 2014, 15:13:47[/time]:
Если есть проблема с этим, до добавить ключ --install-recommends
Решил проверить:
$ sudo apt-get install --install-recommends linux-generic-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty linux-image-generic-lts-trusty

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия linux-generic-lts-trusty.
Уже установлена самая новая версия linux-image-generic-lts-trusty.
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 xserver-xorg-lts-trusty : Зависит: xserver-xorg-core-lts-trusty (>= 2:1.11) но он не будет установлен
                           Зависит: xserver-xorg-input-all-lts-trusty но он не будет установлен или
                                           xorg-driver-input
                           Зависит: xserver-xorg-input-evdev-lts-trusty но он не будет установлен
                           Рекомендует: libgl1-mesa-dri-lts-trusty но он не будет установлен
                           Рекомендует: xserver-xorg-input-all-lts-trusty но он не будет установлен
                           Рекомендует: xserver-xorg-video-all-lts-trusty но он не будет установлен
                           Рекомендует: x11-xserver-utils-lts-trusty но он не будет установлен
                           Конфликтует: xserver-xorg-core (>= 0~)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

chemtech

  • Гость
Re: Сбой при установке обновления Hardware
« Ответ #5 : 20 Июля 2014, 18:58:43 »
ls /etc/apt/sources.list.dppa-purgeppa-purge - запустите, что-нибудь выдает?

Оффлайн Asok177

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Сбой при установке обновления Hardware
« Ответ #6 : 20 Июля 2014, 19:02:35 »
ls /etc/apt/sources.list.dppa-purgeppa-purge - запустите, что-нибудь выдает?

$ ls /etc/apt/sources.list.d
bitcoin-bitcoin-precise.list       cgminer-ppa-precise.list       google-earth.list
bitcoin-bitcoin-precise.list.save  cgminer-ppa-precise.list.save  libreoffice-ppa-precise.list

$ ppa-purge
Warning:  Required ppa-name argument was not specified
Usage: sudo ppa-purge [options] <ppa:ppaowner>[/ppaname]

ppa-purge will reset all packages from a PPA to the standard
versions released for your distribution.

Options:
-p [ppaname] PPA name to be disabled (default: ppa)
-s [host] Repository server (default: ppa.launchpad.net)
-d [distribution] Override the default distribution choice.
-y Pass -y --force-yes to apt-get or -y to aptitude
-i Reverse preference of apt-get upon aptitude.
-h Display this help text

Example usage commands:
sudo ppa-purge xorg-edgers
will remove https://launchpad.net/~xorg-edgers/+archive/ppa

sudo ppa-purge -p xorg-testing sarvatt
will remove https://launchpad.net/~sarvatt/+archive/xorg-testing

sudo ppa-purge ppa:ubuntu-x-swat/x-updates
will remove https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

Notice: If ppa-purge fails for some reason and you wish to try again,
(For example: you left synaptic open while attempting to run it) simply
uncomment the PPA from your sources, run apt-get update and try again.


fuss

  • Гость
Re: Сбой при установке обновления Hardware
« Ответ #7 : 20 Июля 2014, 19:08:24 »
ls /etc/apt/sources.list.dppa-purgeppa-purge - запустите, что-нибудь выдает?
Выдаст Warning:  Required ppa-name argument was not specifiedДрайвера устанавливал отдельно из ppa?

Пользователь решил продолжить мысль 20 Июля 2014, 19:09:56:
sudo apt-get purge xserver-xorg-core
и что напишет сюда
« Последнее редактирование: 20 Июля 2014, 19:09:56 от hello.internutz »

chemtech

  • Гость
Re: Сбой при установке обновления Hardware
« Ответ #8 : 20 Июля 2014, 19:11:02 »
Придется удались программы, которые вы устанавливали через PPA
history | grep ppaв спойлер
попробуйте удалить google-earth
sudo ppa-purge google-earth

Оффлайн Asok177

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Сбой при установке обновления Hardware
« Ответ #9 : 20 Июля 2014, 19:17:24 »
sudo apt-get purge xserver-xorg-core
и что напишет сюда

(Нажмите, чтобы показать/скрыть)

Пользователь решил продолжить мысль 20 Июля 2014, 19:19:12:
Придется удались программы, которые вы устанавливали через PPA
history | grep ppaв спойлер
попробуйте удалить google-earth
sudo ppa-purge google-earth
$ history | grep ppa
 1750  ppa-purge
 1751  sudo apt-get install ppa-purge
 1752  ppa-purge
 1753  history | grep ppa
« Последнее редактирование: 20 Июля 2014, 19:19:12 от Asok177 »

fuss

  • Гость
Re: Сбой при установке обновления Hardware
« Ответ #10 : 20 Июля 2014, 19:25:04 »
Ты жмешь "Y" и возникает проблема? Если не жмешь, то нажми)

Оффлайн Asok177

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Сбой при установке обновления Hardware
« Ответ #11 : 20 Июля 2014, 19:56:13 »
Ты жмешь "Y" и возникает проблема? Если не жмешь, то нажми)
ссыкатно))
опять ГУИ слетит

fuss

  • Гость
Re: Сбой при установке обновления Hardware
« Ответ #12 : 20 Июля 2014, 20:01:50 »
Ты жмешь "Y" и возникает проблема? Если не жмешь, то нажми)
ссыкатно))
опять ГУИ слетит
Ты видишь название пакетов?
Цитировать
Будут установлены следующие дополнительные пакеты:
  xserver-common-lts-quantal xserver-xorg-core-lts-quantal
У тебя изначально не правильное обновление, данное действие позволит снести старое, и поставить от версии 13.10

Пользователь решил продолжить мысль [time]20 Июль 2014, 20:03:58[/time]:
В общем, делай вначале
sudo apt-get install --install-recommends linux-generic-lts-saucy xserver-xorg-lts-saucy libgl1-mesa-glx-lts-saucy
Пользователь решил продолжить мысль 20 Июля 2014, 20:05:48:
Жмешь Y ставишь, делаешь ребут, делаешь sudo apt-get install linux-generic-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty linux-image-generic-lts-trusty
« Последнее редактирование: 20 Июля 2014, 20:05:48 от hello.internutz »

Оффлайн Asok177

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Сбой при установке обновления Hardware
« Ответ #13 : 21 Июля 2014, 06:44:40 »
В общем, делай вначале
sudo apt-get install --install-recommends linux-generic-lts-saucy xserver-xorg-lts-saucy libgl1-mesa-glx-lts-saucyЖмешь Y ставишь, делаешь ребут, делаешь sudo apt-get install linux-generic-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty linux-image-generic-lts-trusty

Сделал:
$ sudo apt-get install --install-recommends linux-generic-lts-saucy xserver-xorg-lts-saucy libgl1-mesa-glx-lts-saucy
перезагрузился, делаю:
$ sudo apt-get install linux-generic-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty linux-image-generic-lts-trusty
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия linux-generic-lts-trusty.
Уже установлена самая новая версия linux-image-generic-lts-trusty.
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libgl1-mesa-glx-lts-trusty : Зависит: libglapi-mesa-lts-trusty (= 10.1.3-0ubuntu0.1~precise1) но он не будет установлен
                              Рекомендует: libgl1-mesa-dri-lts-trusty (>= 7.2) но он не будет установлен
                              Конфликтует: xorg-renamed-package-lts-saucy
 xserver-xorg-lts-trusty : Зависит: xserver-xorg-core-lts-trusty (>= 2:1.11) но он не будет установлен
                           Зависит: xserver-xorg-input-all-lts-trusty но он не будет установлен или
                                           xorg-driver-input
                           Зависит: xserver-xorg-input-evdev-lts-trusty но он не будет установлен
                           Рекомендует: libgl1-mesa-dri-lts-trusty но он не будет установлен
                           Рекомендует: xserver-xorg-input-all-lts-trusty но он не будет установлен
                           Рекомендует: xserver-xorg-video-all-lts-trusty но он не будет установлен
                           Рекомендует: x11-xserver-utils-lts-trusty но он не будет установлен
                           Конфликтует: xorg-renamed-package-lts-saucy
                           Конфликтует: xserver-xorg-core (>= 0~)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Вот..

Оффлайн Влад1951

  • Активист
  • *
  • Сообщений: 314
  • Win XP_32bit + Xubuntu 22.04_64bit
    • Просмотр профиля
Re: Сбой при установке обновления Hardware
« Ответ #14 : 22 Июля 2014, 16:49:57 »
У меня сегодня появилось обновление на ubuntu 12.04.
Все сделал, обновился.
Потом вижу, предлагается еще какой-то HARDWARE обновить.
Посмотрел в примечаниях.
Пишут про ядро UBUNTU 14.03.
Обновился, на всякий случай.
И тут началась заварушка. Все зависло.
Перешел на предыдущий уровень и все заработало как надо



Могу мышкой кликать, Enter клацать

 

Страница сгенерирована за 0.037 секунд. Запросов: 26.