Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Не работает apt-get install -f  (Прочитано 3089 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kezman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Не работает apt-get install -f
« : 04 Август 2014, 16:12:27 »
Ubuntu - 13.04
в `/etc/apt/sources.list` закоментированы "security.ubuntu.com" и заменены "ru.archive." на "old-releases". Хотя и до замены пробовал apt-get install -f - никаких успехов.

$ sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
  openjdk-7-jre-lib
Для его удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
  libmysqlclient18
Пакеты, которые будут обновлены:
  libmysqlclient18
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 7 пакетов не обновлено.
не установлено до конца или удалено 138 пакетов.
Необходимо скачать 0 B/1 015 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 86,0 kB.
Хотите продолжить [Д/н]? Y
ВНИМАНИЕ: Следующие пакеты невозможно аутентифицировать!
  libmysqlclient18
Установить эти пакеты без проверки [y/N]? y
dpkg: ошибка при обработке параметра /var/cache/apt/archives/libmysqlclient18_5.5.38-1~dotdeb.0_amd64.deb (--unpack):
 libmysqlclient18:amd64 5.5.38-1~dotdeb.0 (Multi-Arch: no) не может быть установлен одновременно с libmysqlclient18, для которого имеется несколько установленных экземпляров
Отчёты apport не записаны, так достигнут MaxReports
                                                   При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libmysqlclient18_5.5.38-1~dotdeb.0_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Кто может подсказать - в чем проблема?

quatro

  • Гость
Re: Не работает apt-get install -f
« Ответ #1 : 04 Август 2014, 16:28:13 »
Следующий пакет устанавливался автоматически и больше не требуется:
  openjdk-7-jre-lib
Для его удаления используйте «apt-get autoremove».

Оффлайн kezman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: Не работает apt-get install -f
« Ответ #2 : 04 Август 2014, 16:34:56 »
Лучше не стало...

$ sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  libmysqlclient18
Пакеты, которые будут обновлены:
  libmysqlclient18
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 7 пакетов не обновлено.
не установлено до конца или удалено 137 пакетов.
Необходимо скачать 0 B/1 015 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 86,0 kB.
Хотите продолжить [Д/н]? Y
ВНИМАНИЕ: Следующие пакеты невозможно аутентифицировать!
  libmysqlclient18
Установить эти пакеты без проверки [y/N]? y
dpkg: ошибка при обработке параметра /var/cache/apt/archives/libmysqlclient18_5.5.38-1~dotdeb.0_amd64.deb (--unpack):
 libmysqlclient18:amd64 5.5.38-1~dotdeb.0 (Multi-Arch: no) не может быть установлен одновременно с libmysqlclient18, для которого имеется несколько установленных экземпляров
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libmysqlclient18_5.5.38-1~dotdeb.0_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Оффлайн Azure

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 5630
  • elementaryOS 0.4 Loki, i3wm on Debian9
    • Просмотр профиля
Re: Не работает apt-get install -f
« Ответ #3 : 04 Август 2014, 17:07:18 »
dpkg -l libmysqlclient18?
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн kezman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: Не работает apt-get install -f
« Ответ #4 : 04 Август 2014, 17:08:17 »
$ dpkg -l libmysqlclient18
Желаемый=неизвестно[u]/установить[i]/удалить[r]/вычистить[p]/зафиксировать[h]
| Состояние=не[n]/установлен[i]/настроен[c]/распакован[U]/частично настроен[F]/
            частично установлен[H]/trig-aWait/Trig-pend
|/ Ошибка?=(нет)/требуется переустановка[R] (верхний регистр
в полях состояния и ошибки указывает на ненормальную ситуацию)
||/ Имя                                   Версия              Архитектура    Описание
+++-========================================-=========================-=========================-=====================================================================================
ri  libmysqlclient18:amd64                   5.5.34-0ubuntu0.13.04.1   amd64                     MySQL database client library
rc  libmysqlclient18:i386                    5.5.32-0ubuntu0.13.04.1   i386                      MySQL database client library

Оффлайн Azure

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 5630
  • elementaryOS 0.4 Loki, i3wm on Debian9
    • Просмотр профиля
Re: Не работает apt-get install -f
« Ответ #5 : 04 Август 2014, 17:12:32 »
uname -m?sudo dpkg -P libmysqlclient18
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн kezman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: Не работает apt-get install -f
« Ответ #6 : 04 Август 2014, 17:15:50 »
$ uname -m
x86_64

$ sudo dpkg -P libmysqlclient18
dpkg: проблемы с зависимостями не позволяют удалить пакет libmysqlclient18:amd64:
 php5-mysql зависит от libmysqlclient18 (>= 5.5.13-1).
 libdbd-mysql-perl зависит от libmysqlclient18 (>= 5.5.13-1).
 mysql-workbench зависит от libmysqlclient18 (>= 5.5.13-1).
 python-mysqldb зависит от libmysqlclient18 (>= 5.5.13-1).
 ruby-mysql зависит от libmysqlclient18 (>= 5.5.13-1).

dpkg: ошибка при обработке параметра libmysqlclient18:amd64 (--purge):
 проблемы с зависимостями — не удаляется
При обработке следующих пакетов произошли ошибки:
 libmysqlclient18:amd64

Оффлайн Azure

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 5630
  • elementaryOS 0.4 Loki, i3wm on Debian9
    • Просмотр профиля
Re: Не работает apt-get install -f
« Ответ #7 : 04 Август 2014, 17:30:55 »
sudo dpkg -P libmysqlclient18:i386
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн kezman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: Не работает apt-get install -f
« Ответ #8 : 05 Август 2014, 10:47:06 »
Спасибо большое! Все заработало! Пакет успешно удалил, затем apt-get install -f отработал норм и затем я благополучно поставил skype 4.3 - в чем собственно и была проблема.

Еще раз огромное спасибо!!!

 

Страница сгенерирована за 0.06 секунд. Запросов: 25.