Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Wine 1.6\ не устанавливается  (Прочитано 2542 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн just_a_noob

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Wine 1.6\ не устанавливается
« : 06 Августа 2014, 16:13:32 »
Добрый день, уважаемое сообщество!

Имеется проблема с установкой Wine на Ubuntu 14.04 на хромбуке Acer C720.

user@chrubuntu:~$ sudo apt-get install wine
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 wine : Зависит: wine1.6 но он не будет установлен или
                        wine1.7 но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Сие выдает терминал.
Вопрос, конечно, нубский, но очень прошу помощи с данным недоразумением.

Изменил название темы в соответствии с:
https://forum.ubuntu.ru/index.php?topic=269859.0
-maks05
« Последнее редактирование: 24 Марта 2016, 04:15:45 от maks05 »

Оффлайн SvMidi

  • Активист
  • *
  • Сообщений: 815
    • Просмотр профиля
Re: Проблемы с установкой Wine
« Ответ #1 : 06 Августа 2014, 16:56:21 »
не повредит для начала
sudo apt update
Я знаю только то, что ничего не знаю, остальные не знают и этого.

Оффлайн fuss

  • Старожил
  • *
  • Сообщений: 2074
    • Просмотр профиля
    • Screenshoter
Re: Проблемы с установкой Wine
« Ответ #2 : 06 Августа 2014, 17:13:41 »
sudo apt-get install wine1.7

Оффлайн just_a_noob

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Проблемы с установкой Wine
« Ответ #3 : 06 Августа 2014, 21:40:03 »
На команду update такая реакция
user@chrubuntu:~$ sudo apt-get update
[sudo] password for user:
Игн http://archive.ubuntu.com trusty InRelease
Игн http://dl.google.com stable InRelease                                     
Игн http://ppa.launchpad.net trusty InRelease                                 
Игн http://archive.ubuntu.com trusty-updates InRelease                         
В кэше http://dl.google.com stable Release.gpg                                 
Игн http://ppa.launchpad.net trusty InRelease                                 
Игн http://archive.ubuntu.com trusty-security InRelease                       
В кэше http://dl.google.com stable Release                                     
В кэше http://ppa.launchpad.net trusty Release.gpg                             
Игн http://archive.ubuntu.com trusty-backports InRelease                       
В кэше http://ppa.launchpad.net trusty Release.gpg                             
В кэше http://archive.ubuntu.com trusty Release.gpg
В кэше http://ppa.launchpad.net trusty Release
Получено:1 http://archive.ubuntu.com trusty-updates Release.gpg [933 B]       
В кэше http://ppa.launchpad.net trusty Release                                 
Получено:2 http://archive.ubuntu.com trusty-security Release.gpg [933 B]       
В кэше http://ppa.launchpad.net trusty/main Sources                           
В кэше http://archive.ubuntu.com trusty-backports Release.gpg                 
В кэше http://ppa.launchpad.net trusty/main amd64 Packages
В кэше http://archive.ubuntu.com trusty Release
Получено:3 http://archive.ubuntu.com trusty-updates Release [59,7 kB]         
В кэше http://ppa.launchpad.net trusty/main Sources                           
Получено:4 http://archive.ubuntu.com trusty-security Release [59,7 kB]         
В кэше http://ppa.launchpad.net trusty/main amd64 Packages                 
В кэше http://archive.ubuntu.com trusty-backports Release                     
В кэше http://archive.ubuntu.com trusty/main Sources                           
В кэше http://archive.ubuntu.com trusty/restricted Sources                     
В кэше http://archive.ubuntu.com trusty/universe Sources
В кэше http://archive.ubuntu.com trusty/multiverse Sources
В кэше http://archive.ubuntu.com trusty/main amd64 Packages
В кэше http://archive.ubuntu.com trusty/restricted amd64 Packages
В кэше http://archive.ubuntu.com trusty/universe amd64 Packages
В кэше http://archive.ubuntu.com trusty/multiverse amd64 Packages
В кэше http://archive.ubuntu.com trusty/main Translation-ru
В кэше http://archive.ubuntu.com trusty/main Translation-en
В кэше http://archive.ubuntu.com trusty/multiverse Translation-ru
В кэше http://archive.ubuntu.com trusty/multiverse Translation-en
В кэше http://archive.ubuntu.com trusty/restricted Translation-ru
В кэше http://archive.ubuntu.com trusty/restricted Translation-en
В кэше http://archive.ubuntu.com trusty/universe Translation-ru
В кэше http://archive.ubuntu.com trusty/universe Translation-en
Получено:5 http://archive.ubuntu.com trusty-updates/main Sources [105 kB]
Получено:6 http://archive.ubuntu.com trusty-updates/restricted Sources [1 408 B]
Получено:7 http://archive.ubuntu.com trusty-updates/universe Sources [66,2 kB]
Игн http://ppa.launchpad.net trusty/main Translation-ru_RU                     
Игн http://ppa.launchpad.net trusty/main Translation-ru                       
Получено:8 http://archive.ubuntu.com trusty-updates/multiverse Sources [2 686 B]
Игн http://ppa.launchpad.net trusty/main Translation-en_US                     
Игн http://ppa.launchpad.net trusty/main Translation-en                       
Получено:9 http://archive.ubuntu.com trusty-updates/main amd64 Packages [281 kB]
Игн http://ppa.launchpad.net trusty/main Translation-ru_RU                 
Игн http://ppa.launchpad.net trusty/main Translation-ru                   
Игн http://ppa.launchpad.net trusty/main Translation-en_US
Игн http://ppa.launchpad.net trusty/main Translation-en
Получено:10 http://archive.ubuntu.com trusty-updates/restricted amd64 Packages [5 833 B]
Получено:11 http://archive.ubuntu.com trusty-updates/universe amd64 Packages [167 kB]
Получено:12 http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages [7 409 B]
Получено:13 http://archive.ubuntu.com trusty-updates/main Translation-en [121 kB]
В кэше http://archive.ubuntu.com trusty-updates/multiverse Translation-en
В кэше http://archive.ubuntu.com trusty-updates/restricted Translation-en
В кэше http://archive.ubuntu.com trusty-updates/universe Translation-en
Получено:14 http://archive.ubuntu.com trusty-security/main Sources [37,6 kB]
Получено:15 http://archive.ubuntu.com trusty-security/restricted Sources [14 B]
Получено:16 http://archive.ubuntu.com trusty-security/universe Sources [10,3 kB]
Получено:17 http://archive.ubuntu.com trusty-security/multiverse Sources [697 B]
Получено:18 http://archive.ubuntu.com trusty-security/main amd64 Packages [121 kB]
Получено:19 http://archive.ubuntu.com trusty-security/restricted amd64 Packages [14 B]
Получено:20 http://archive.ubuntu.com trusty-security/universe amd64 Packages [42,2 kB]
Получено:21 http://archive.ubuntu.com trusty-security/multiverse amd64 Packages [1 147 B]
Получено:22 http://archive.ubuntu.com trusty-security/main Translation-en [58,2 kB]
В кэше http://archive.ubuntu.com trusty-security/multiverse Translation-en     
В кэше http://archive.ubuntu.com trusty-security/restricted Translation-en     
В кэше http://archive.ubuntu.com trusty-security/universe Translation-en       
В кэше http://archive.ubuntu.com trusty-backports/universe amd64 Packages     
В кэше http://archive.ubuntu.com trusty-backports/main amd64 Packages         
В кэше http://archive.ubuntu.com trusty-backports/multiverse amd64 Packages   
В кэше http://archive.ubuntu.com trusty-backports/restricted amd64 Packages   
В кэше http://archive.ubuntu.com trusty-backports/main Translation-en         
В кэше http://archive.ubuntu.com trusty-backports/multiverse Translation-en   
В кэше http://archive.ubuntu.com trusty-backports/restricted Translation-en   
В кэше http://archive.ubuntu.com trusty-backports/universe Translation-en     
Игн http://archive.ubuntu.com trusty/main Translation-ru_RU                   
Игн http://archive.ubuntu.com trusty/main Translation-en_US                   
Игн http://archive.ubuntu.com trusty/multiverse Translation-ru_RU             
Игн http://archive.ubuntu.com trusty/multiverse Translation-en_US             
Игн http://archive.ubuntu.com trusty/restricted Translation-ru_RU             
Игн http://archive.ubuntu.com trusty/restricted Translation-en_US             
Игн http://archive.ubuntu.com trusty/universe Translation-ru_RU               
Игн http://archive.ubuntu.com trusty/universe Translation-en_US               
Получено 1 151 kБ за 10с (115 kБ/c)                                           
W: Не удалось получить http://dl.google.com/linux/chrome/deb/dists/stable/Release  Невозможно найти ожидаемый элемент «main/source/Sources» в файле Release (некорректная запись в sources.list или файл)

E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

На install wine1.7 такая
user@chrubuntu:~$ sudo apt-get install wine1.7
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 wine1.7 : Зависит: wine1.7-i386 (= 1:1.7.22-0ubuntu1) но он не может быть установлен
           Рекомендует: fonts-horai-umefont но он не будет установлен
           Рекомендует: fonts-unfonts-core но он не будет установлен
           Рекомендует: winetricks но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Оффлайн uri_ne_@

  • Любитель
  • *
  • Сообщений: 83
    • Просмотр профиля
Re: Проблемы с установкой Wine
« Ответ #4 : 06 Августа 2014, 23:31:56 »
Мне кажется, что нарушена система пакетов.
apt-get autoremove - удалить неиспользуемые пакеты.
apt-get -f install - восстановить поврежденные пакеты.
можно ещё
apt-get check - проверить целостность зависимостей.

Оффлайн altwazar

  • Активист
  • *
  • Сообщений: 430
    • Просмотр профиля
Re: Проблемы с установкой Wine
« Ответ #5 : 07 Августа 2014, 06:29:03 »
На команду update такая реакция

Странно, нет i386 источников. Они как раз нужны для wine1.7-i386 (= 1:1.7.22-0ubuntu1).
Команда:
dpkg --print-foreign-architectures
Должна выдать i386. Если нет, то возможно поможет:
sudo dpkg --add-architecture i386 && sudo apt-get update
« Последнее редактирование: 07 Августа 2014, 06:41:55 от altwazar »

Оффлайн blondinchik40

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Проблемы с установкой Wine
« Ответ #6 : 30 Августа 2014, 09:45:39 »
У меня таже проблема. Всё вышеперечисленное не помогает установить WINE.
OC 64 bit ubuntu UE4.0
sudo dpkg --add-architecture i386 && sudo apt-get update не помогает, так и пишет.
The following packages have unmet dependencies:
 wine1.7 : Depends: wine1.7-i386 (= 1:1.7.18-0ubuntu1~saucy1)
E: Unable to correct problems, you have held broken packages.


Пользователь решил продолжить мысль 31 Августа 2014, 04:09:42:
Разобрался, как и что делать написано тут: http://wiki.winehq.org/WineOn64bit#head-b62ae8f996e97e1df7258bb8eaec2e83e54ca799 и  тут http://wiki.winehq.org/BuildingBiarchWineOnUbuntu
« Последнее редактирование: 31 Августа 2014, 04:09:42 от blondinchik40 »

Оффлайн Deniske

  • Любитель
  • *
  • Сообщений: 96
    • Просмотр профиля
Re: Проблемы с установкой Wine
« Ответ #7 : 07 Сентября 2015, 11:06:32 »
blondinchik40, а что конкретно нужно сделать? Я не силён в английском.
dexp atlas h155; Intel Core i5-4210M; 6GB DDR3 1333MHz; NVIDIA GeForce 840M, NVIDIA 367.44;
Ubuntu 16.04 х64, 4.8.1-040801-generic; Unity 7.4.0;. (u)efi

 

Страница сгенерирована за 0.048 секунд. Запросов: 26.