Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Наутилус постоянно показывает скрытые файлы?  (Прочитано 5563 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sartacon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Ubuntu 14.04 - 64 бит. В наутилусе появилась такая проблема, он постоянно показывает скрытые файлы.
Пробовал нажимать Ctrl + H работает только до тех пор пока я не закрою наутилус, потом снова все скрытые файлы видны. В dconf  в преференциях для нау в поле "показывать скрытые файлы" галки  нет.
 Не смертельно конечно, но тем не менее... Кто нибудь сталкивался с таким?

Оффлайн andwer07

  • Участник
  • *
  • Сообщений: 233
    • Просмотр профиля
А в настройках самого наутилуса галка стоит?

Оффлайн sartacon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
А в настройках самого наутилуса галка стоит?
Да стоит. Её убираешь - скрытые исчезают. Однако после закрытия наутилуса и его повторного открытия всё повторяется снова: галка на месте и скрытые файлы тоже. То есть настройки не сохраняются.

Оффлайн altwazar

  • Активист
  • *
  • Сообщений: 413
    • Просмотр профиля
Попробуй в консоли:
dconf-editor
Там пройти по пути:
org -> gtk -> settings -> file-chooser и убрать галочку с show-hidden

Там хитрые гномо-настройки, показ скрытых файлов в двух местах. Может помочь.
« Последнее редактирование: 14 Август 2014, 05:53:21 от altwazar »

Оффлайн sartacon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Попробуй в консоли:
dconf-editor
Там пройти по пути:
org -> gtk -> settings -> file-chooser и убрать галочку с show-hidden

Если Вы читали внимательней, то я уже говорил изначально, что в преференциях в dconf для наутилуса галочка в опции "показать скрытые файлы" отсутствует.

Оффлайн altwazar

  • Активист
  • *
  • Сообщений: 413
    • Просмотр профиля
Если Вы читали внимательней, то я уже говорил изначально, что в преференциях в dconf для наутилуса галочка в опции "показать скрытые файлы" отсутствует.

Ты не написал, где конкретно. В dconf есть настройки наутилуса:
 org -> gnome -> nautilus -> preferences
и эти:
 org -> gtk -> settings -> file-chooser
И там, и там есть показ скрытых файлов. В настройках dconf наутилуса этот параметр уже не используется и только вносит путаницу, изменять нужно в file-chooser.
« Последнее редактирование: 14 Август 2014, 07:46:21 от altwazar »

Оффлайн sartacon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Ты не написал, где конкретно. В dconf есть настройки наутилуса:
 org -> gnome -> nautilus -> preferences
и эти:
 org -> gtk -> settings -> file-chooser
И там, и там есть показ скрытых файлов. В настройках dconf наутилуса этот параметр уже не используется и только вносит путаницу, изменять нужно в file-chooser

Да да да.. точно.. Мой косяк что не написал конкретно. А конкретно как раз имелся ввиду первый вариант! Спасибо! Совсем вылетел из бошки второй. Попробую вечерком когда доберусь до той машины с косячным наутилусом. Обязательно отпишусь по результату!

| toZen |

  • Гость
sartacon, снимите галку в:
Edit-Preferences-Show hidden files and backup files

Оффлайн altwazar

  • Активист
  • *
  • Сообщений: 413
    • Просмотр профиля
Edit-Preferences-Show hidden files and backup files

В ubuntu 14.04 не видел этой настройки на привычном месте.

| toZen |

  • Гость
altwazar, думаю, есть она там. У меня 14.10, отображается на привычном месте.

Оффлайн altwazar

  • Активист
  • *
  • Сообщений: 413
    • Просмотр профиля
τοΖεη,
Наверно у меня на той машине nemo стоит и я не заметил.

Пользователь решил продолжить мысль [time]14 Август 2014, 14:31:03[/time]:
Проверил, галочка действительно на месте и работает.

Но похоже есть интересный баг, связанный с диалогом открытия/сохранения файлов gtk или gnome (не разбираюсь в этом).
Если попытаться открыть или сохранить файл через него (gedit, rhythmbox, evince) и включить/выключить отображений скрытых файлов (ctrl+h), то в наутилусе так же переключиться их отображение по умолчанию. Сомневаюсь, что так и было задумано. Скорее всего это и есть изначальный источник проблемы.

В gedit, rhythmbox, evince диалог открытия файлов выглядит как новый nautilus (с черными иконами мест). Переключение отображения скрытых файлов в нем так же переключает отображение по умолчанию в наутилусе.

В firefox, libreoffice диалог с цветными иконками. Там такого эффекта нет.
« Последнее редактирование: 14 Август 2014, 11:46:09 от altwazar »

Оффлайн sartacon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
altwazar,приогромнейшее спасибо! Действительно, ларчик открывался очень просто и надо было пройти в dconfig org -> gtk -> settings -> file-chooser и снять галочку с соответствующего пункта show hidden files.. Только не понятно правда осталось откуда она там появилась)))) Но это уже другая история. Ещё раз спасибо!!!

Оффлайн altwazar

  • Активист
  • *
  • Сообщений: 413
    • Просмотр профиля
Только не понятно правда осталось откуда она там появилась)))) Но это уже другая история. Ещё раз спасибо!!!

np :)
Посмотри моё сообщение выше, я там как раз написал наиболее вероятную причину её появления. С этой неприятной особенностью она может появиться снова.

 

Страница сгенерирована за 0.115 секунд. Запросов: 24.