Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: МФУ Canon PIXMA MG4240 не подключается сканер  (Прочитано 4952 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AndreyChursin

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • «Я есть, потому-что мы есть»
    • Просмотр профиля
    • РА Гермес
Есть аппарат: Canon PIXMA MG4240 подключается по wi-fi
(http://www.canon.ru/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MG_series/PIXMA_MG4240.aspx?type=download&softwaredetailid=tcm:203-994553&os=Linux&language=RU)
И система: Ubuntu 14.04 x64

Устал искать варианты как запустить сканер! хоть на оф.сайте есть исходники драйверов, но при попытке выполнить сборку софта "scangearmp" по инструкции появляется ошибка:
[b][font=arial][size=2]checking for GIMP... no
configure: error: Package requirements (gimp-2.0 >= 2.0.0) were not met:

No package 'gimp-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GIMP_CFLAGS
and GIMP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.[/size][/font][/b]
[b][/b]
[font=arial][size=2]Перевести получилось, понять что делать - нет[/size][/font] :-[
[font=arial][size=small]
Помогите, кому не лень[/size][/font] :'(
« Последнее редактирование: 10 Май 2016, 18:46:27 от Пользователь »
Ubuntu — «человечность по отношению к другим»

Оффлайн M1ke

  • Участник
  • *
  • Сообщений: 227
  • ✎…
    • Просмотр профиля
    • IT блог
Re: Будут ворчать, но...сканер wifi Canon PIXMA
« Ответ #1 : 17 Август 2014, 00:00:39 »
Пока что не хватает libgimp2.0-dev

sudo apt-get install libgimp2.0-dev
define(TRUE, FALSE); //секс и наркотики

Оффлайн AndreyChursin

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • «Я есть, потому-что мы есть»
    • Просмотр профиля
    • РА Гермес
Re: Будут ворчать, но...сканер wifi Canon PIXMA
« Ответ #2 : 17 Август 2014, 14:58:17 »
make:
[b]make  all-recursive
make[1]: Вход в каталог `/home/andrey/Загрузки/scangearmp-source-2.00-1/scangearmp'
Making all in po
make[2]: Вход в каталог `/home/andrey/Загрузки/scangearmp-source-2.00-1/scangearmp/po'
make[2]: Цель `all' не требует выполнения команд.
make[2]: Выход из каталога `/home/andrey/Загрузки/scangearmp-source-2.00-1/scangearmp/po'
Making all in backend
make[2]: Вход в каталог `/home/andrey/Загрузки/scangearmp-source-2.00-1/scangearmp/backend'
/bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -I. -I./include   -DV_MAJOR=2 -DV_MINOR=0 -O2 -D__GIMP_PLUGIN_ENABLE__ -D_FILE_OFFSET_BITS=64 -MT libsane_canon_mfp_la-canon_mfp.lo -MD -MP -MF .deps/libsane_canon_mfp_la-canon_mfp.Tpo -c -o libsane_canon_mfp_la-canon_mfp.lo `test -f 'canon_mfp.c' || echo './'`canon_mfp.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -I. -I./include -DV_MAJOR=2 -DV_MINOR=0 -O2 -D__GIMP_PLUGIN_ENABLE__ -D_FILE_OFFSET_BITS=64 -MT libsane_canon_mfp_la-canon_mfp.lo -MD -MP -MF .deps/libsane_canon_mfp_la-canon_mfp.Tpo -c canon_mfp.c  -fPIC -DPIC -o .libs/libsane_canon_mfp_la-canon_mfp.o
canon_mfp.c:47:23: fatal error: sane/sane.h: No such file or directory
 #include <sane/sane.h>
                       ^
compilation terminated.
make[2]: *** [libsane_canon_mfp_la-canon_mfp.lo] Ошибка 1
make[2]: Выход из каталога `/home/andrey/Загрузки/scangearmp-source-2.00-1/scangearmp/backend'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Выход из каталога `/home/andrey/Загрузки/scangearmp-source-2.00-1/scangearmp'
make: *** [all] Ошибка 2
[/b]
и все,

[b]canon_mfp.c:47:23: fatal error: sane/sane.h: No such file or directory[/b]

как это исправить?
« Последнее редактирование: 09 Сентябрь 2014, 08:33:34 от AndreyChursin »
Ubuntu — «человечность по отношению к другим»

Оффлайн M1ke

  • Участник
  • *
  • Сообщений: 227
  • ✎…
    • Просмотр профиля
    • IT блог
Re: Будут ворчать, но...сканер wifi Canon PIXMA
« Ответ #3 : 18 Август 2014, 12:00:11 »
А ./configure после установки гимплиб нормально прошло?
define(TRUE, FALSE); //секс и наркотики

Оффлайн AndreyChursin

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • «Я есть, потому-что мы есть»
    • Просмотр профиля
    • РА Гермес
Re: Будут ворчать, но...сканер wifi Canon PIXMA
« Ответ #4 : 20 Август 2014, 20:36:50 »
ДА! (процесс в txt файле) :)
Ubuntu — «человечность по отношению к другим»

Оффлайн AndreyChursin

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • «Я есть, потому-что мы есть»
    • Просмотр профиля
    • РА Гермес
Re: Будут ворчать, но...сканер wifi Canon PIXMA
« Ответ #5 : 09 Сентябрь 2014, 08:32:55 »
Пока что не хватает libgimp2.0-dev

sudo apt-get install libgimp2.0-dev

А если нет -lcncpnet???(Google не показал что это за ...)

/usr/bin/ld: cannot find -lcncpnet

make  all-recursive
make[1]: Вход в каталог `/home/andrey/Загрузки/Программы/scangearmp-source-2.00-1/scangearmp'
Making all in po
make[2]: Вход в каталог `/home/andrey/Загрузки/Программы/scangearmp-source-2.00-1/scangearmp/po'
make[2]: Цель `all' не требует выполнения команд.
make[2]: Выход из каталога `/home/andrey/Загрузки/Программы/scangearmp-source-2.00-1/scangearmp/po'
Making all in backend
make[2]: Вход в каталог `/home/andrey/Загрузки/Программы/scangearmp-source-2.00-1/scangearmp/backend'
/bin/bash ../libtool  --tag=CC   --mode=link gcc -DV_MAJOR=2 -DV_MINOR=0 -O2 -D__GIMP_PLUGIN_ENABLE__ -D_FILE_OFFSET_BITS=64 -version-info 2:0:0  -o libsane-canon_mfp.la -rpath /usr/lib libsane_canon_mfp_la-canon_mfp.lo libsane_canon_mfp_la-canon_mfp_tools.lo  -lusb -ldl -lcncpnet -lpthread -lz
libtool: link: gcc -shared  -fPIC -DPIC  .libs/libsane_canon_mfp_la-canon_mfp.o .libs/libsane_canon_mfp_la-canon_mfp_tools.o   -lusb -ldl -lcncpnet -lpthread -lz  -O2   -Wl,-soname -Wl,libsane-canon_mfp.so.2 -o .libs/libsane-canon_mfp.so.2.0.0
/usr/bin/ld: cannot find -lcncpnet
collect2: error: ld returned 1 exit status
make[2]: *** [libsane-canon_mfp.la] Ошибка 1
make[2]: Выход из каталога `/home/andrey/Загрузки/Программы/scangearmp-source-2.00-1/scangearmp/backend'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Выход из каталога `/home/andrey/Загрузки/Программы/scangearmp-source-2.00-1/scangearmp'
make: *** [all] Ошибка 2

« Последнее редактирование: 09 Сентябрь 2014, 08:35:23 от AndreyChursin »
Ubuntu — «человечность по отношению к другим»

Оффлайн M1ke

  • Участник
  • *
  • Сообщений: 227
  • ✎…
    • Просмотр профиля
    • IT блог
Re: Будут ворчать, но...сканер wifi Canon PIXMA
« Ответ #6 : 09 Сентябрь 2014, 15:26:16 »
На офф сайте есть дрова в деб пакетах
http://www.canon.ru/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MG_series/PIXMA_MG4240.aspx?type=download&softwaredetailid=tcm:203-994525&os=Linux&language=
Скачай архив - в нем есть файл install.sh - chmod +x ему и запусти через терминал - он нужный деб установит.

P.S. Если с офф сайта не качает (не для всех стран доступно, для России мне не показывает, для европы показывает) -

http://maddot.ru/share/files/mg4240.zip - вот зазеркалил.
« Последнее редактирование: 09 Сентябрь 2014, 15:41:26 от M1ke »
define(TRUE, FALSE); //секс и наркотики

Оффлайн AndreyChursin

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • «Я есть, потому-что мы есть»
    • Просмотр профиля
    • РА Гермес
Re: Будут ворчать, но...сканер wifi Canon PIXMA
« Ответ #7 : 09 Сентябрь 2014, 22:39:57 »
На офф сайте есть дрова в деб пакетах
http://www.canon.ru/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MG_series/PIXMA_MG4240.aspx?type=download&softwaredetailid=tcm:203-994525&os=Linux&language=
Скачай архив - в нем есть файл install.sh - chmod +x ему и запусти через терминал - он нужный деб установит.

P.S. Если с офф сайта не качает (не для всех стран доступно, для России мне не показывает, для европы показывает) -

http://maddot.ru/share/files/mg4240.zip - вот зазеркалил.

Да что ж за беда :-(
Выдаёт:
install.sh: 662: install.sh: Syntax error: Bad for loop variable
и это для принтера, а у меня сканер не работает...

Попробовал драйвера из rpm пакетов ставить, ошибка зависимостей(запускал sudo bash install.sh):
andrey@VivoBook:~/scangearmp-mg4200series-2.00-1-rpm$ rpm -Uvh ./packages/scangearmp-common-2.00-1.x86_64.rpm
rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing...
ошибка: Неудовлетворенные зависимости:
/bin/sh нужен для scangearmp-common-2.00-1.x86_64
gtk2 нужен для scangearmp-common-2.00-1.x86_64
libatk-1.0.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libc.so.6()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libc.so.6(GLIBC_2.2.5)(64bit) нужен для scangearmp-common-2.00-1.x86_64
libc.so.6(GLIBC_2.3)(64bit) нужен для scangearmp-common-2.00-1.x86_64
libdl.so.2()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libdl.so.2(GLIBC_2.2.5)(64bit) нужен для scangearmp-common-2.00-1.x86_64
libgdk-x11-2.0.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libgdk_pixbuf-2.0.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libglib-2.0.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libgmodule-2.0.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libgobject-2.0.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libgtk-x11-2.0.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libm.so.6()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libm.so.6(GLIBC_2.2.5)(64bit) нужен для scangearmp-common-2.00-1.x86_64
libpango-1.0.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libpangox-1.0.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libpangoxft-1.0.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libpng нужен для scangearmp-common-2.00-1.x86_64
libpng12.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libpthread.so.0()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libpthread.so.0(GLIBC_2.2.5)(64bit) нужен для scangearmp-common-2.00-1.x86_64
libpthread.so.0(GLIBC_2.3.3)(64bit) нужен для scangearmp-common-2.00-1.x86_64
libstdc++.so.6()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) нужен для scangearmp-common-2.00-1.x86_64
libusb-0.1.so.4()(64bit) нужен для scangearmp-common-2.00-1.x86_64
libz.so.1()(64bit) нужен для scangearmp-common-2.00-1.x86_64
« Последнее редактирование: 09 Сентябрь 2014, 23:15:59 от AndreyChursin »
Ubuntu — «человечность по отношению к другим»

Оффлайн AndreyChursin

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • «Я есть, потому-что мы есть»
    • Просмотр профиля
    • РА Гермес
Ubuntu — «человечность по отношению к другим»

Оффлайн timber.do

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Будут ворчать, но...сканер wifi Canon PIXMA
« Ответ #9 : 15 Декабрь 2014, 21:26:05 »
У меня принтер Canon PIXMA MP190. Долго мучался, дрова на принтер  от michael-gruz установились успешно, а вот со сканером не получилось. Кстати у меня Линукс Минт 17.1 с репами от trusty.
Так вот, все разрешилось благополучно, при добавлении еще одного ppa.
ppa:kalon33/ppa
scangearmp-mp190series  и scangearmp-common установились успешно.
Надеюсь кому то пригодится, потому что сам обыскался. Сканирует 8)
я ломал стекло

Оффлайн Sir Antony

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Будут ворчать, но...сканер wifi Canon PIXMA
« Ответ #10 : 09 Ноябрь 2015, 11:44:23 »
Подниму тему из пепла, вдруг кому пригодится мой опыт:
Имеем: указанный выше Canon MG4240 и 2 ноутбука на 14.04 i686. Оба обновлены до упора перед манипуляциями, набор ПО различается.

Сначала на обе машины поставил драйверы сканера из ppa:kalon33/ppa, как написано тут, драйверы принтера как в этом сообщении.

Так вот на одном ноуте всё залетало сразу, а на втором отказывался печатать и ставил статус заданий в "Приостановлено", при этом в /var/log/cups/error_log писал "cannot specify model number".

Решилось установкой драйвера с оффсайта по ссылке из этого сообщения. Дополнительно пришлось поискать в интернетах и поставить libtiff4 отсюда: http://packages.ubuntu.com/precise/libtiff4

После этого всё заработало и на 2й машине.
« Последнее редактирование: 11 Ноябрь 2015, 20:59:18 от Sir Antony »

Оффлайн AndreyChursin

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • «Я есть, потому-что мы есть»
    • Просмотр профиля
    • РА Гермес
Re: Будут ворчать, но...сканер wifi Canon PIXMA
« Ответ #11 : 08 Май 2016, 17:13:08 »
Подниму тему из пепла, вдруг кому пригодится мой опыт:
Имеем: указанный выше Canon MG4240 и 2 ноутбука на 14.04 i686. Оба обновлены до упора перед манипуляциями, набор ПО различается.

Сначала на обе машины поставил драйверы сканера из ppa:kalon33/ppa, как написано тут, драйверы принтера как в этом сообщении.

Так вот на одном ноуте всё залетало сразу, а на втором отказывался печатать и ставил статус заданий в "Приостановлено", при этом в /var/log/cups/error_log писал "cannot specify model number".

Решилось установкой драйвера с оффсайта по ссылке из этого сообщения. Дополнительно пришлось поискать в интернетах и поставить libtiff4 отсюда: http://packages.ubuntu.com/precise/libtiff4

После этого всё заработало и на 2й машине.

А сканирование как работает?))
Ubuntu — «человечность по отношению к другим»

 

Страница сгенерирована за 0.066 секунд. Запросов: 24.