Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Не поднялась сеть после замены материнки  (Прочитано 1550 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Бормотун

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Уважаемые знатоки! Я в замешательстве. Подскажите, куда рыть вообще. Вводная: есть десктоп с Ubuntu 12.04, интернет раздает Zyxel Keenetic Gyga, который и смотрит наружу. Мать Gygabyte MA770 заменена на Gygabyte 970A-DS3P (c UEFI, все переключатели, что нашел, выставлены в режим Legacy). В PCI-слот переставлена со старой матери WiFi карта Asus PCI N10 на РаЛинковском чипе. Система стартует без проблем, но: не поднимается сеть ни на встроенном в материнку LAN, ни через WiFi. Симптоматика крайне странная: изначально Network Manager доложился, что WiFi подключение активно, однако ни внешние ресурсы, ни сам роутер не пингуются. При этом - NB! - какой-то доступ в интернет, видимо, все же был, т.к. системное время в BIOS/UEFI выставилось без моего участия. После перезагрузки попытки подцепиться как к проводному подключению, так и к WiFi останавливаются на статусе "Получение адреса в проводной/беспроводной сети для подключения ...".
Что пробовал: замену имени "eth1" на "eth0" в файле \etc\udev\rules.d\70-persistent-net.rules для новой LAN-сетевухи (то, что новая, определил по MAC-адресу), естественно, с перезапуском сервиса. Мимо кассы. (кстати, сначала заработала, а потом отвалилась USB-радиомышка, выдав на краткое время сообщение при уходе ОС в перезапуск о, кажется, отсутствии идентификатора где-то в rules.d)
Вывод ifconfig, на мой непросвещенный взгляд, никакого поверхностного криминала не дает
(Нажмите, чтобы показать/скрыть)
Ладно, думаю. Окай. Закружаюсь с лайвСД и вижу ровно ту же самую картину. Но там-то старых правил нет! Поведение Network Manager один в один - "Получение адреса...". То есть, похоже, тупая переустановка системы тут может и не помочь... Да и не хотелось бы. Сам роутер динамически раздает IP и DNS адреса, рядом с десктопом стоит древний ноут eMachines с Mint 10 на борту, у которого WiFi пашет распрекрасно, не чихает и не кашляет, исправно поднимается сам после перезагрузки роутера. Ну WiFi хрен с ним, на эту асусовскую карточку драйвер собирать надо из исходников, может, с этой материнкой он и не работает толком (хотя ядро linux без изменений, камень и чипсет AMD-шные остались, только поколением поновее). Но на старой материнке, опять же, все работало, да и вообще, в моей небогатой практике чтобы встроенный LAN интерфейс не завелся под Linux из коробки - ни разу такого не видел.
Вот куда тут еще смотреть можно? Заранее спасибо.

Оффлайн satch

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1561
  • Kubuntu 15.10 amd64
    • Просмотр профиля
Re: Не поднялась сеть после замены материнки
« Ответ #1 : 21 Август 2014, 06:20:37 »
lspci в студию
Наше желание помочь прямопропорционально вашему желанию решить проблему

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Не поднялась сеть после замены материнки
« Ответ #2 : 21 Август 2014, 08:41:56 »
Потестите LAN-подключение со статическим IP.

Оффлайн Бормотун

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Не поднялась сеть после замены материнки
« Ответ #3 : 21 Август 2014, 13:06:05 »
Спасибо, вопрос решен. По поводу гипотез:
lspci в студию
Был в порядке, это было первое, что я смотрел. Не отписал просто в стартовом посте - час ночи, ничего не соображал уже.
Потестите LAN-подключение со статическим IP.
Тоже тестил еще ночью. Мимо кассы.

В любом случае спасибо. Решение нашлось случайно и для меня выглядит какой-то черной магией - настолько глубоко в железе я не разбираюсь. Достаточно было выставить параметр "IOMMU" в свойствах материнки на Enabled (по умолчанию Disabled) - и сеть заработала. Вообще, это было решением проблемы с USB-мышкой, которое я искал параллельно. Но, как оказалось, на сетевые интерфейсы оно тоже влияет.

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Не поднялась сеть после замены материнки
« Ответ #4 : 21 Август 2014, 13:11:59 »
Не исключено, что подобная фигня лечится обновлением прошивки BIOS.

 

Страница сгенерирована за 0.238 секунд. Запросов: 24.