Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Не работает драйвер nvidia в Ubuntu, установленной на ssd  (Прочитано 644 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lurpa_sv

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Купил ssd-накопитель ocz vertex 460 и установил на него Ubuntu 14.04. Система, ясное дело, стала летать, но появилась проблема. В left4dead 2 появились подергивания (проприетарный драйвер 331 на nvidia gtx650 из официального репозитория), которые со временем усиливаются и появляется большая задержка ввода-вывода, падает fps. Системный монитор показывает загрузку некоторых ядер на 100%(2-ядерный core i3, хотя монитор почему то показывает, что у меня 4 ядра). В htop тоже самое - самый ресурсоемкий процесс - left4dead. Чуть позже скину скрины. Если продолжить играть дальше с тормозами, то через несколько минут игры экран гаснет(видимо отключается видеокарта, потому что на дисплее появляется сообщение no signal detected). Также сразу после установки заметил эффекты черного окна при разворачивании. До этого стояла та же система, но на жестком диске и все работало отлично. Left4dead 2 шла на максимальных настройках с тем же драйвером. Ничего больше не менял, в настройки compiz не лез, но в новой системе не создавал swap(у меня 10Гб оперативной памяти, так что в этот раз не стал создавать раздел подкачки). С другими версиями драйверов та же история, ни с 304, ни с 340-ым драйвером работать не хочет. Подскажите, пожалуйста, в чем может быть проблема?

Оффлайн vasyl

  • Старожил
  • *
  • Сообщений: 1724
    • Просмотр профиля
SSD + 340-е дрова + 3.13.0-24 ядро + prime норм (L4D2 тож) .
Ubuntu Mate 16.04 + Windows 10

Оффлайн serega3907

  • Активист
  • *
  • Сообщений: 661
    • Просмотр профиля
Это не из-за SSD. У меня точно такой же (клевый винт), все остальное в подписи. Работает без подобных проблем.

Оффлайн lurpa_sv

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Обязательно ли ставить prime? На старой системе его не было, все работало. Делаю все по инструкции:
(Нажмите, чтобы показать/скрыть)
bbswitch-dkms установлен, последняя версия
Устанавливаю prime, но в NVIDIA X server Settings пункт PRIME отсутствует

Пользователь решил продолжить мысль [time]01 Сентябрь 2014, 01:43:53[/time]:
Вот, что происходит через несколько минут игры:
(Нажмите, чтобы показать/скрыть)
Версия драйвера 340.32
Процессор Intel® Core™ i3-3220 CPU @ 3.30GHz × 4 двухядерный, но в сведениях о системе указано, что четырех-(может 4 потока?)


Пользователь решил продолжить мысль 01 Сентябрь 2014, 10:27:34:
Хочу спросить, может ли отсутствие swap как-то влиять на производительность (смотри скриншот выше) с 10 Гб оперативной памяти? Насколько мне известно для left4dead 2 рекомендовано 1 Гб, но у меня она жрет почти 2
« Последнее редактирование: 01 Сентябрь 2014, 10:27:35 от lurpa_sv »

Оффлайн lurpa_sv

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Короче, дело было не в дровах, а в железе. Не работал кулер видеокарты. Всем спасибо за советы

 

Страница сгенерирована за 0.152 секунд. Запросов: 25.