Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Совместимость Gnome Shell-приложений и тем Ambiance\Radiance  (Прочитано 414 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн hardkorova

  • Автор темы
  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
    • Блог с полезными статьями по Ubuntu
Ладно, когда я видел подобное только на специфической утилите, типа gnome-tweak-tool. Но тут прилетело обновление, которое превратило file-roller в такую штуковину:



Мне нравится дефолтная тема убунты, я не хочу копаться в архивах на gnome-look.org и выбирать среди ужасных и просто плохих тем что-нибудь подходящее. Поэтому, внимание, вопрос: есть ли версия светлой темы Radiance с совместимостью Gnome Shell, или что-то очень похожее? Понятно, что сам софт не переделать.
Может, эта проблема уже запощена на багтрекере и рано или поздно канониклы допилят свои темки?


З.Ы.
Хм... полез искать и обнаружил, что пару недель назад оно появилось: http://gnome-look.org/content/show.php/Radiance-Gnome?content=166631

Но. Как её установить? Копирование в ~/.themes и /usr/share/themes не даёт никакого результата. Ubuntu Tweak говорит, что файл темы повреждён.  :'(
« Последнее редактирование: 07 Сентябрь 2014, 14:25:42 от hardkorova »

Оффлайн RingOV

  • Активист
  • *
  • Сообщений: 724
    • Просмотр профиля
Какая версия?
file-roller --versionи
lsb_release -a

Оффлайн hardkorova

  • Автор темы
  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
    • Блог с полезными статьями по Ubuntu
LSB вот:
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:core-4.1-ia32:core-4.1-noarch:security-4.0-ia32:security-4.0-noarch:security-4.1-ia32:security-4.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty
а файл-роллер таким путём версию не выдаёт, но в синаптике у нас 3.12.1

Оффлайн RingOV

  • Активист
  • *
  • Сообщений: 724
    • Просмотр профиля
file-roller 3.10.2.1 вот такой у меня

Темы в Ubuntu 14.04 для GTK 3.10, поэтому приложения GTK 3.12 отображаются не так как задумано. Это потому, что GTK активно развивается, добавляются новые виджеты, другие устаревают и т.п.

Выход прост - откатиться в синаптике до file-roller 3.10. А также отключить репозиторий из которого он установился или зафиксировать версию.

Оффлайн hardkorova

  • Автор темы
  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
    • Блог с полезными статьями по Ubuntu
Я б не сказал, что это выход, но откат придётся сделать.
Реальный выход - совместимая тема. Из тех, что успел перепробовать, работают Moka, Orchis, Xenlism и т.д., но не у всех есть своя рамка окна. На самом деле канониклам всего-то надо допилить свои темы. Вообще не пойму, как они могут держать в репах приложения с криво отображающимся интерфейсом, как gnome-tweak-tool, например.  :idiot2:

 

Страница сгенерирована за 0.069 секунд. Запросов: 24.