Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Выключение Ubuntu 12.04 LTS кнопкой, без диалога выключения?!  (Прочитано 822 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tvsm22

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Уже не первый день ковыряю систему, никак не могу добиться того, чтобы при нажатии на кнопку выключения компьютер сразу выключался, без появления диалогового окна (выключить, перезагрузить и т.д.)

Установил dconf editor, галочку где apps - indicator session - suppress-logout-restart-shutdown поставил, теперь, если мышкой выбирать пункт меню "shut down" выключает без диалога. Но если кнопку выключения нажимать - все равно диалог показывает.
Подскажите, пожалуйста, как таки добиться того, чтобы при нажатии на кнопку выключения диалог не возникал?
« Последнее редактирование: 11 Сентябрь 2014, 17:08:52 от tvsm22 »

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8602
    • Просмотр профиля
tvsm22,
dconf-editororg-->>gnome-->>settings-daemon-->>plugins-->>power
button-power меняете значение interactive на shutdown.
или:
gsettings set org.gnome.settings-daemon.plugins.power button-power 'shutdown'
« Последнее редактирование: 11 Сентябрь 2014, 17:03:27 от τοΖεη »
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн tvsm22

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
tvsm22,
dconf-editororg-->>gnome-->>settings-daemon-->>plugins-->>power
button-power меняете значение interactive на shutdown.
или:
gsettings set org.gnome.settings-daemon.plugins.power button-power 'shutdown'

не помогло, по прежнему выдает диалоговое окно

Пользователь решил продолжить мысль 11 Сентябрь 2014, 17:18:36:
фух, нашел таки ответ:
1.- sudo gedit /etc/acpi/events/powerbtn
2.- Add # to comment line: #action=/etc/acpi/powerbtn.sh
3.- Add a new line: action=/sbin/poweroff
4.- Save file
5.- Open a console and type: sudo acpid restart

"That works for me AND the prompt has gone, just like in ubuntu 11.04. Wish this helps."
« Последнее редактирование: 11 Сентябрь 2014, 17:18:36 от tvsm22 »

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14863
  • Я не слышу.
    • Просмотр профиля
tvsm22,
нет, у меня.
ZL~# cat /etc/acpi/powerbtn.sh
#!/bin/sh
/sbin/shutdown -h 0
~.o

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.