Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Ошибки при установке ffmpeg  (Прочитано 2047 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Adriano

  • Автор темы
  • Участник
  • *
  • Сообщений: 185
  • Че
    • Просмотр профиля
Ошибки при установке ffmpeg
« : 22 Сентября 2014, 21:49:53 »
Я в конце этого обсуждения начал писать об ошибках при установке ffmpeg. Но думаю, что это отдельная тема для обсуждения.

Вот на сайте ffmpeg.org -- Руководство по компиляции. Я попробовал установить ffmpeg на старую, с некоторыми глюками, Ubuntu 12.04. На этапе установки libvpx начало выдавать ошибки.

Попробовал установить на недавно установленную Ubuntu 14.04. На том же месте, при установке libvpx, опять появились ошибки. В этот раз я их записал.
(Нажмите, чтобы показать/скрыть)

Я попробовал перейти к следующему этапу, к последнему, к установке собственно ffmpeg. Может быть этот libvpx -- это что-то необязательное? Но похоже что нет!

Вот что выдало на экран:
(Нажмите, чтобы показать/скрыть)

P.S. Не знаю, может быть с этим исходником, указанным на сайте ffmpeg.org, (по ссылке выше на "Руководство по компиляции"), что-то не так? http://webm.googlecode.com/files/libvpx-v1.3.0.tar.bz2
Но официальный сайт же... И где другой исходник взять, ЕСЛИ действительно указанный не работает (в чём я не уверен).
« Последнее редактирование: 22 Сентября 2014, 22:01:15 от Adriano »

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7203
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: Ошибки при установке ffmpeg
« Ответ #1 : 23 Сентября 2014, 03:02:44 »
Adriano, я в субботу компилил, всё было нормально.
Зависимости установили?

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1850
  • ubuntu 20.04
    • Просмотр профиля
Re: Ошибки при установке ffmpeg
« Ответ #2 : 23 Сентября 2014, 07:02:55 »
Ну судя по ошибкам с asm, не выполнено это (нужен yasm 1.3.0, а в ubuntu 14.04 в репах версия 1.2.0)
Цитировать
If your repository offers a yasm package ≥ 1.3.0 then you can install that instead of compiling:

sudo apt-get install yasm
Otherwise you can compile:

cd ~/ffmpeg_sources
wget http://www.tortall.net/projects/yasm/releases/yasm-1.3.0.tar.gz
tar xzvf yasm-1.3.0.tar.gz
cd yasm-1.3.0
./configure --prefix="$HOME/ffmpeg_build" --bindir="$HOME/bin"
make
make install
make distclean
« Последнее редактирование: 23 Сентября 2014, 07:07:58 от soarin »

Оффлайн arch!ver

  • Старожил
  • *
  • Сообщений: 1260
    • Просмотр профиля
Re: Ошибки при установке ffmpeg
« Ответ #3 : 23 Сентября 2014, 08:01:28 »
Я попробовал установить ffmpeg на старую, с некоторыми глюками, Ubuntu 12.04. На этапе установки libvpx начало выдавать ошибки.

Ubuntu 12.04 - стоит FFmpeg с родного Git - https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu ... Ставился без проблем... Работает тоже без проблем...

На этапе установки libvpx начало выдавать ошибки.
Он может выдавать некоторые сообщения об ошибках при установке и что? Главное что бы он при этом ставился, а после этого - работал  ;)
« Последнее редактирование: 23 Сентября 2014, 08:05:06 от archiver »

 

Страница сгенерирована за 0.041 секунд. Запросов: 25.