Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Не звука ubuntu 14.04  (Прочитано 4002 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн СӃӒ꙰ꙢИ

  • Автор темы
  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
Не звука ubuntu 14.04
« : 28 Сентября 2014, 18:55:46 »
Поставил линукс и понял что звука на ней нету, скажите это нормально?

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7203
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #1 : 28 Сентября 2014, 19:00:57 »
СӃӒ꙰ꙢИ, нет, это не нормально.
lspci -k|grep Audio -A2?
uname -r?

Оффлайн СӃӒ꙰ꙢИ

  • Автор темы
  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #2 : 28 Сентября 2014, 21:29:30 »
peregrine  :coolsmiley: хватит это терпеть
root@harly-P5KC:~# lspci -k|grep Audio -A2
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
root@harly-P5KC:~# uname -r
3.13.0-24-generic
root@harly-P5KC:~#

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 14037
  • Xubuntu 18.04
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #3 : 28 Сентября 2014, 21:30:36 »
Видимо совсем новый контроллер. Ядро его не узнает. Надо гуглить.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн СӃӒ꙰ꙢИ

  • Автор темы
  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #4 : 28 Сентября 2014, 21:33:18 »
не, компу года 4  :2funny:

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 14037
  • Xubuntu 18.04
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #5 : 28 Сентября 2014, 21:35:31 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн СӃӒ꙰ꙢИ

  • Автор темы
  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #6 : 28 Сентября 2014, 21:51:12 »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 14037
  • Xubuntu 18.04
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #7 : 28 Сентября 2014, 22:08:03 »
СӃӒ꙰ꙢИ,
Там есть решение.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн СӃӒ꙰ꙢИ

  • Автор темы
  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #8 : 28 Сентября 2014, 23:53:25 »
Pilot6, как скачать 3 снизу? https://bugs.launchpad.net/ubuntu/+source/alsa-driver
« Последнее редактирование: 28 Сентября 2014, 23:55:11 от СӃӒ꙰ꙢИ »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 14037
  • Xubuntu 18.04
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #9 : 29 Сентября 2014, 12:32:27 »
СӃӒ꙰ꙢИ,
Я же дал ссылку с решением. Что не устраивает? А скачать баг нельзя.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн СӃӒ꙰ꙢИ

  • Автор темы
  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #10 : 29 Сентября 2014, 13:46:37 »
 ??? будем копать

| toZen |

  • Гость
Re: Не звука ubuntu 14.04
« Ответ #11 : 29 Сентября 2014, 14:02:13 »
??? будем копать
Я бы попробовал поставить более новое ядро:
sudo apt-get update && sudo apt-get install synapticgksudo synapticВбейте в строке поиска linux-kernel. Установка через ПКМ <Mark for install>
Попробуйте версю 3.16 или 3.17.

Оффлайн altwazar

  • Активист
  • *
  • Сообщений: 430
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #12 : 29 Сентября 2014, 15:15:48 »
Поставил линукс и понял что звука на ней нету, скажите это нормально?

Да, обычная ситуация для встроенной карточки под линуксом.

Что можно сделать:
1. Поставить pavucontrol. На вкладке "Конфигурация" выбрать нужную, обычно это "аналоговое стерео дуплекс". Затем во вкладке "Устройства вывода" проверить, что бы стоял нужный порт (Наушники/Колонки).
2. В консоли запустить alsamixer. Проверить, что бы каналы стояли на макс громкости и не были замьючены. Отключить опцию "Auto-mute". Если есть переключатель для цифрового входа, то попробовать переключить его. Проверить, везде ли нет звука? Может на колонках есть?

Это из простого, когда карточка определилась и не правильно сконфигурирован pulseaudio или auto-mute. Если ничего не вышло, то вероятнее всего не правильно определись разъемы для твоей модели карточки (очень распространенная проблема).
В этом случае можно попробовать какой-нибудь параметр отсюда (дописать в /etc/modprobe.d/alsa-base.conf например snd-hda-intel model=asus-mode4):
https://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio-Models.txt
Или взять в руки hdajackretask и hda-jack-sense-test (ppa:ppa:diwic/hda) и проверять разъемы в ручную. Это тот еще геморрой с непредсказуемым результатом, проще купить какую-нибудь поддерживаемую линуксом карточку.

Оффлайн СӃӒ꙰ꙢИ

  • Автор темы
  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #13 : 30 Сентября 2014, 15:45:21 »
Помогите понять, прописать где надо  ??? прямо для моей карточки

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 30 Сентября 2014, 15:46:56 от СӃӒ꙰ꙢИ »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 14037
  • Xubuntu 18.04
    • Просмотр профиля
Re: Не звука ubuntu 14.04
« Ответ #14 : 30 Сентября 2014, 15:49:25 »
sudo gedit /etc/modprobe.d/alsa-base.conf
Прописать надо только это

options snd slots=snd-hda-intel
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

Если вы не поняли, то там написано, что это надо прописать вместо того что там есть. Только лучше старый файл тоже сохранить на случай, если работать не будет.

Сохранить можно предварительно так.

sudo cp /etc/modprobe.d/alsa-base.conf /etc/modprobe.d/alsa-base.conf.bak
« Последнее редактирование: 30 Сентября 2014, 15:58:26 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

 

Страница сгенерирована за 0.033 секунд. Запросов: 25.