Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: проблема с лазарусом  (Прочитано 2142 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alecs983

  • Автор темы
  • Забанен
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
проблема с лазарусом
« : 06 Октябрь 2014, 20:41:15 »
после устоновки, а затем при запуске лазарус вот такое выходит

Without the proper FPC sources code browsing and completion will be very limited.

и лазарус не запускается. помогите решить проблему! заранее спасибо

Оффлайн SvMidi

  • Активист
  • *
  • Сообщений: 815
    • Просмотр профиля
Re: проблема с лазарусом
« Ответ #1 : 06 Октябрь 2014, 22:02:19 »
Насколько я помню к лазарусу надо подключать free pascal о чём он и сообщает.
sudo apt install fpcкажется до него ещё путь надо было указывать, но точно не скажу, ставил давно.
Я знаю только то, что ничего не знаю, остальные не знают и этого.

Оффлайн alsoijw

  • Старожил
  • *
  • Сообщений: 4073
  • Fedora 25 GNOME 3 amd64
    • Просмотр профиля
Re: проблема с лазарусом
« Ответ #2 : 06 Октябрь 2014, 22:10:21 »
Ставить надо из чужого репа.
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?

Оффлайн rayanAyar

  • Старожил
  • *
  • Сообщений: 1027
  • Да пребудет с вами совпавшая контрольная сумма
    • Просмотр профиля
Re: проблема с лазарусом
« Ответ #3 : 07 Октябрь 2014, 09:21:19 »
Рекомендую ставить с офсайта:
http://lazarus.freepascal.org/index.php?page=downloads

Оффлайн Alecs983

  • Автор темы
  • Забанен
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: проблема с лазарусом
« Ответ #4 : 07 Октябрь 2014, 18:11:35 »
выпонлил sudo apt ..... вроде помогло. но теперь при открытии пишет

The package "FCL" is installed, but no valid package file (.lpk) was found.
A broken dummy package was created.

Оффлайн Adriano

  • Участник
  • *
  • Сообщений: 174
  • Че
    • Просмотр профиля
Re: проблема с лазарусом
« Ответ #5 : 08 Октябрь 2014, 14:26:44 »
Ставил я в прошлом году Лазарус, надо было кое-какой код для Делфи посмотреть. Остались у меня в закромах заметки как его устанавливать, могу поделиться.

Прежде всего: не ставьте Лазарус через "Центр приложений Ubuntu"!! С вероятностью в 99% он поставится с ошибками.

-----------------------------------------------------------

Итак:

1. Идём на сайт с дистрибутивами Lazarus. Сюда.
Выбираем в списке:
Lazarus Linux amd64 DEB
или, если нужна не 64-разрядная версия, а 32-х, то выбираем
Lazarus Linux i386 DEB

2. Выбрали нужный дистрибутив. На экране список файлов. Что скачивать? Всё! Попросту говоря.
Если подробнее.
Создаём папку с соответственным именем (например Lazarus).
Скачиваем туда все 4 файла, которые видим на соответствующей страничке сайта. Можно и 3, без readme.txt, если угодно. Т.е. скачиваем туда ВСЕ файлы с расширением .deb
Например, для 64-разрядной версии:

lazarus_1.2.4-0_amd64.deb    
fpc-src_2.6.4-140420_amd64.deb    
fpc_2.6.4-140420_amd64.deb    
README.txt

3. Если на компьютере был уже установлен Lazarus – удаляем:
(Тут ниже форум умничает с автозаменой небезопасного кода. Заменяет rm -Rf на эрэм эрэф.)
sudo apt-get purge fpc lazarus
sudo эрэм эрэф /usr/lib/fpc
sudo эрэм эрэф /usr/lib/lazarus
sudo эрэм эрэф /usr/share/fpcsrc
sudo rm -f ~/.fpc
sudo rm -Rf ~/.lazarus

Скорее всего у вас не установлен пакет libgtk2.0-dev. А без него Лазарус не установится.
Если не установлен пакет libgtk2.0-dev , то устанавливаем:
sudo apt-get install libgtk2.0-dev(а если уже установлен, то команда, находящаяся выше, не помешает).

4. В Терминале (или в Midnight Commander'e, или как-то ещё) переходим в папку с дистрибутивом. Например так:
cd 'Путь к этому каталогу'И запускаем установку программы:
sudo dpkg -i *.deb
-------------------------------------------------------------------------------------------

P.S. Для проверки установил на Ubuntu 14.04 последнюю версию Лазаруса. До этого успешно ставил на Ubuntu 12.04 версию Lazarus 1.0.8. Проверил - работает! "Hallo, world!" написал, во как!  :) Поомнят руки!
(Нажмите, чтобы показать/скрыть)
Вот такой я молодец!  ;D Написал большой пост. Говорите мне спасибо!
« Последнее редактирование: 08 Октябрь 2014, 14:57:38 от Adriano »

Оффлайн alsoijw

  • Старожил
  • *
  • Сообщений: 4073
  • Fedora 25 GNOME 3 amd64
    • Просмотр профиля
Re: проблема с лазарусом
« Ответ #6 : 08 Октябрь 2014, 14:44:23 »
Adriano, а что такое sudo эрэм эрэф /usr/share/fpcsrc?
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?

Оффлайн Adriano

  • Участник
  • *
  • Сообщений: 174
  • Че
    • Просмотр профиля
Re: проблема с лазарусом
« Ответ #7 : 08 Октябрь 2014, 14:48:52 »
(Тут ниже форум умничает с автозаменой небезопасного кода. Заменяет rm -Rf на эрэм эрэф.)
Я там выше над кодом написал в скобках, вы не заметили. Может быть надо ярче выделить?

 

Страница сгенерирована за 0.253 секунд. Запросов: 24.