Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: VirtualBox\Не поднимается интерфейс в ubuntu на VM  (Прочитано 1481 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн blank_river

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Всем привет, прошу помощи.

На хост машине Win 7, на virtualbox установлена Ubuntu и пока ничего с ней не делал (все дефолтное). Начал попытки поднять сеть, перечитал соседнии темы, но так и не решил проблему. В убунте видна только петля - lo loopback, все! интерфейс не поднимается.

ubuntu 14.04, VBox - 4.3.16

- в настройках VB выставлен сетевой мост, на вай-фай адаптер (т.к. интернет через него)
- доп гост системы поставлены
- при установке VB поставлены все дополнения
- в файле /etc/network/interfaces -> auto lo   iface lo inet loopback
- если в граф режиме (KDE) зайти в настр сети пишет сходу - "Системные сетевые службы не совместимы с этой версией"

ковыряюсь уже час, и не пойму из за чего вообще так? Что копать - вин7, виртуалку или Ubuntu?


НА хост машине кстати, вин7, на вай-фай адаптер - настройки - доступ - тут пытаюсь дать "разрешить другим польз сети исп данное подкл к интернету" и выходит ошибка - "ошибка подкл общего доступа к интернету. (null)". Но вообще-то интерфейс то на линуксе подняться должен и без этой галочки..

« Последнее редактирование: 04 Февраль 2016, 09:39:26 от it0r »

Оффлайн blank_river

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #1 : 16 Октябрь 2014, 17:09:56 »
UP
 :-[

Оффлайн vboxer

  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #2 : 16 Октябрь 2014, 17:22:10 »
а почему в VB просто NAT не поставить?
Адаптер выбран?
галочка включить соединение стоит? (а то может просто "кабель" отключен)

Оффлайн blank_river

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #3 : 16 Октябрь 2014, 22:04:36 »
Да адаптер выбран Atheros AR9285 Wireless Network Adapter, галочки вкл адаптер, и "кабель подключен"

NAT не подходит, для целей установки убунты на вирт вообще (учусь сетевым настройкам в убунте)

Оффлайн vboxer

  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #4 : 16 Октябрь 2014, 22:11:21 »
навскидку не помню, но когда то давненько какие то проблемы в создании моста наблюдал, помню ковырялся долго, только вот уже не помню что. :(  кажется в винде надо расшаривать доступ для сетевой карты типа мост.

Оффлайн blank_river

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #5 : 16 Октябрь 2014, 22:22:42 »
вот есть такая проблема с расшариванием, да:

Цитировать
НА хост машине кстати, вин7, на вай-фай адаптер - настройки - доступ - тут пытаюсь дать "разрешить другим польз сети исп данное подкл к интернету" и выходит ошибка - "ошибка подкл общего доступа к интернету. (null)". Но вообще-то интерфейс то на линуксе подняться должен и без этой галочки..

Только что делать не знаю ((

Оффлайн vboxer

  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #6 : 16 Октябрь 2014, 22:29:02 »
не, этож винда на хосте, в случае моста, лучше уж выбрать локальная сеть, ну а если нужен инет на виртуалке, то NAT.

Оффлайн blank_river

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #7 : 19 Октябрь 2014, 11:53:41 »
svcunion, для моих целей не подходит NAT, что непонятного то.

Цитировать
После инсталла VB, в сетевых настройках адаптера должен появиться ещё сетевой интерфейс. Можно сделать мост Atheros AR9285 Wireless Network Adapter <> VB Net Work.

дак вот тема о том, что он не появился..

В целом, поразительно полезный пост от вас получился.

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1474
  • ubuntu 18.04
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #8 : 21 Октябрь 2014, 18:19:23 »
После инсталла VB, в сетевых настройках адаптера должен появиться ещё сетевой интерфейс
дак вот тема о том, что он не появился..
Сетевый драйвера под виндовс от Virtualbox имеют кучу не совместимостей со сторонними драйверами. Частые проблемы возникают из-за всяких там антивирусов
https://forums.virtualbox.org/viewtopic.php?f=6&t=48044

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14922
  • Я не слышу.
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #9 : 21 Октябрь 2014, 19:02:08 »
which dnsmasq
~.o

Оффлайн blank_river

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #10 : 23 Октябрь 2014, 14:04:34 »
спасибо всем кто отписался в теме.

Проблема решилась. Я снес вирт машину и переставил заново, после чего поднял на вирт с др дистриба линукс и все ок стало. В чем причина была до этого так и не понял.

Оффлайн vboxer

  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #11 : 23 Октябрь 2014, 14:07:19 »
спасибо всем кто отписался в теме.

Проблема решилась. Я снес вирт машину и переставил заново, после чего поднял на вирт с др дистриба линукс и все ок стало. В чем причина была до этого так и не понял.
уже и не понять будет :) закройте тему, раз хоть какое то решение найдено :)

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14922
  • Я не слышу.
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #12 : 23 Октябрь 2014, 14:32:16 »
blank_river,
(Нажмите, чтобы показать/скрыть)
~.o

Оффлайн andrey465

  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Re: Не поднимается интерфейс в ubuntu на VM virtualbox
« Ответ #13 : 03 Февраль 2016, 10:46:07 »
была примерно такая же ситуация - хост win 7 x64 pro, гость ubuntu server 14.04 x86, сетевой мост
сеть поднималась, все показатели как обычно, но пакеты ходят только через петлю
делаем ifconfig eth0 down / up и все работает до след перезагрузки гостя
переустанавливал virtualbox, дополнения, менял драйвера виртуальной сетевухи, отключал лишние интерфейсы и много чего еще
не уверен, но мне кажется помогла смена mac адреса виртуальной сетевухи (после этого все нормально заработало), хотя может просто стечение обстоятельств

 

Страница сгенерирована за 0.063 секунд. Запросов: 24.