Форум русскоязычного сообщества Ubuntu


Автор Тема: Проблема с монтированием Shared Folder из /etc/fstab  (Прочитано 474 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн valer_1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Ubuntu Server, запущен в VirtualBox-е. Установлены дополнения VirtualBox. Создана общая папка. При монтировании её в ручную всё в порядке:

sudo mount -t vboxsf venus /var/node
расшаренная папка доступна, но только до перезагрузки.
Хочу сделать чтобы она монтировалась автоматом при запуске, для этого добавляю в файл
/etc/fstab такую строку:
venus /var/node vboxsf defaults 0 0

При запуске системы получаю сообщение: An error ocured while mounting /var/node....
Подскажите пожалуйста в чём может быть проблема. На другой виртуалке делал всё примерно так же и всё работало...
« Последнее редактирование: 15 Октябрь 2014, 22:47:58 от valer_1 »

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5633
  • elementaryOS 0.4 Loki, i3wm on Debian9
    • Просмотр профиля
Re: Проблема с монтированием Shared Folder из /etc/fstab
« Ответ #1 : 15 Октябрь 2014, 22:40:54 »
А папка такая существует /etc/node (или всё-таки хотели /var/node ) ?
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн valer_1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Проблема с монтированием Shared Folder из /etc/fstab
« Ответ #2 : 15 Октябрь 2014, 22:49:37 »
да, пардон, опечатка, уже исправил. /var/node. папка существует, но при загрузке не маунтится...

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5633
  • elementaryOS 0.4 Loki, i3wm on Debian9
    • Просмотр профиля
Re: Проблема с монтированием Shared Folder из /etc/fstab
« Ответ #3 : 16 Октябрь 2014, 12:03:19 »
А если после старта выполнить sudo mount -aмонтируется?
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн valer_1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Проблема с монтированием Shared Folder из /etc/fstab
« Ответ #4 : 16 Октябрь 2014, 12:16:34 »
Монтируется.

Может что-то не успевает запуститься на тот момент когда происходит обработка /etc/fstab? Как сделать задержку перед обработкой этого файла?
« Последнее редактирование: 16 Октябрь 2014, 12:21:19 от valer_1 »

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5633
  • elementaryOS 0.4 Loki, i3wm on Debian9
    • Просмотр профиля
Re: Проблема с монтированием Shared Folder из /etc/fstab
« Ответ #5 : 16 Октябрь 2014, 12:39:34 »
Значит более слабая машина по сравнению с "другой виртуалкой" — не успевает запустится сервис до монтирования по fstab. Попробуйте поиграть с различными параметрами, например bootwait, _netdev, но скорее всего надо будет прописывать монтирование в автостарт (например через скрипт в /etc/network/if-up.d/)
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

 

Страница сгенерирована за 0.079 секунд. Запросов: 24.