Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Как выпилить ibus и использовать вместо него xkb?  (Прочитано 1617 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Komorebi

  • Автор темы
  • Активист
  • *
  • Сообщений: 477
    • Просмотр профиля
Собственно ibus вызывает ряд проблем в некоторых приложениях. Предлагаю обсудить, как можно с этим покончить раз и навсегда - выключить его и использовать что-то более легкое и менее глючное. На просторах интернета так и не нашел адекватного способа как это сделать именно в юнити. Отключение ibus в настройках и переконфигурирование методов ввода стандартной утилитой не дают никакого результата. Пакет же нельзя удалить, т.к. его удаление выпилит ряд других пакетов, например, юнити-контрол-центер.
« Последнее редактирование: 24 Октябрь 2014, 22:46:34 от Ацетон »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11165
    • Просмотр профиля
Ацетон,
Думаю, что никак это не сделаешь. Это неправильный путь.
Можно использовать другой DE.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Komorebi

  • Автор темы
  • Активист
  • *
  • Сообщений: 477
    • Просмотр профиля
Ацетон,
Думаю, что никак это не сделаешь. Это неправильный путь.
Можно использовать другой DE.
К сожалению, другие ДЕ даже близко не подобрались к понятию "удобство" (по моему мнению), поэтому этот вариант не рассматривается.

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14862
  • Я не слышу.
    • Просмотр профиля
Ацетон,
папробуй
sudo apt-get install xbindkeysнастройка
nano ~/.xbindkeysrcвстав
"zenity --warning --text='Выключить не работает'"
XF86PowerOff
сохр. и ребут, клав кнопка выключить.
~.o

alex_ander

  • Гость
Ацетон,
я чегой то не понял: какие проблемы с тем, чтобы просто отключить его в "Локализации" и все?

я так делаю даже не помню с каких времен - и никаких проблем с раскладками и хоткеями после этого.

Оффлайн Komorebi

  • Автор темы
  • Активист
  • *
  • Сообщений: 477
    • Просмотр профиля
Пока вроде сделал вот что:
gsettings set org.gnome.settings-daemon.plugins.keyboard active falseи после релогина
setxkbmap -layout  "us,ru(winkeys)" -model "pc105" -option "grp:ctrl_shift_toggle,grp_led:scroll"Вроде бы сработало, но интерес в том, что часть проблем по-прежнему остается (например, если в окне сохранения файла наутилуса нажать "создать папку", затем написать часть имени и нажать альт+шифт, создание папки отменится. Я проверял, если использовать awesome и переключение раскладок врубить через xkb - все отлично работает). Либо проблема еще в чем-то, либо ibus все же по-прежнему не хочет выключаться.

Пользователь решил продолжить мысль [time]24 Октябрь 2014, 23:07:50[/time]:
Ацетон,
я чегой то не понял: какие проблемы с тем, чтобы просто отключить его в "Локализации" и все?

я так делаю даже не помню с каких времен - и никаких проблем с раскладками и хоткеями после этого.
Если отключить его в локализации, то раскладка не перестает переключаться, индикатор работает, а баги остаются. Вообщем, не работает это отключение. Пробовал на свежеустановленной 14.04.
« Последнее редактирование: 24 Октябрь 2014, 23:15:34 от Ацетон »

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14862
  • Я не слышу.
    • Просмотр профиля
ещё
nano ~/.xbindkeysrc
добав
"zenity --warning --text='Нет правила.'"
F1
снова ребут, нажми F1
~.o

alex_ander

  • Гость
...
Ацетон,
я чегой то не понял: какие проблемы с тем, чтобы просто отключить его в "Локализации" и все?

я так делаю даже не помню с каких времен - и никаких проблем с раскладками и хоткеями после этого.
Если отключить его в локализации, то раскладка не перестает переключаться, индикатор работает, а баги остаются. Вообщем, не работает это отключение. Пробовал на свежеустановленной 14.04.
странно это, я использую отдельные раскладки для каждого окна, для новых окон "по умолчанию" - УМВР :(

 

Страница сгенерирована за 0.056 секунд. Запросов: 25.