Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Помогите с Quake 4  (Прочитано 3016 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vladimir.1913

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Помогите с Quake 4
« : 27 Октябрь 2014, 04:31:57 »
Решил в игры поиграть, нашел на просторах сети quake4 якобы нативный, скачал, распаковал, запустил, а он библы запросил, установил библы, начинаю запускать, получаю вот такую ошибку:

------------ Game Map Shutdown --------------
---------------------------------------------
********************
ERROR: Couldn't load scripts/main.script

********************
Sys_Error: Error during initialization

Думал может сборка кривая, скачал еще две, но и они выдают такую же ошибку.

как это решить?

вот полый вывод:

(Нажмите, чтобы показать/скрыть)

Оффлайн lin_user

  • Старожил
  • *
  • Сообщений: 1292
    • Просмотр профиля
Re: Помогите с Quake 4
« Ответ #1 : 27 Октябрь 2014, 11:39:59 »
Может, прав не хватает. Почему игра установлена в /usr/local/games?

Пользователь решил продолжить мысль 27 Октябрь 2014, 11:53:54:
Вот такое решение есть в интернете. А ещё рекомендую посмотреть в теме с раздачей.

Только что проверил. Поставил версию с рутрекера от Маламута. Ставил в пределах домашнего окружения. Всё взлетело тут же. Ubuntu 14.04 x86-64.
« Последнее редактирование: 27 Октябрь 2014, 11:53:54 от liuser »

Оффлайн Vladimir.1913

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Помогите с Quake 4
« Ответ #2 : 27 Октябрь 2014, 12:43:21 »
Насчет прав, я ее пытался и от рута запустить, так что не вариант. Расположение дефолтное, которое предлагает установщик кваки.
А так говорит, что не может найти файлы:
(Нажмите, чтобы показать/скрыть)

Ставил три разные сборки, с трех разных источников. Так что думаю вине не в сборки.

Погуглив на запрос недостающих файлов, нашел кучу тем, с аналогичной проблемой, но только игра Doom3, но решений не нашел.

Оффлайн lin_user

  • Старожил
  • *
  • Сообщений: 1292
    • Просмотр профиля
Re: Помогите с Quake 4
« Ответ #3 : 27 Октябрь 2014, 13:57:25 »
Не может найти ресурсы. Перечисленные файлы должны быть в pak001.pk4. Этот архив есть в q4base?

Пользователь решил продолжить мысль [time]27 Октябрь 2014, 15:16:13[/time]:

Попробуйте установить от своего имени в домашний каталог.
« Последнее редактирование: 27 Октябрь 2014, 14:16:35 от lin_user »

Оффлайн Vladimir.1913

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Помогите с Quake 4
« Ответ #4 : 27 Октябрь 2014, 14:51:15 »
(Нажмите, чтобы показать/скрыть)

Оффлайн lin_user

  • Старожил
  • *
  • Сообщений: 1292
    • Просмотр профиля
Re: Помогите с Quake 4
« Ответ #5 : 27 Октябрь 2014, 14:55:09 »
У меня вот такое содержимое:
(Нажмите, чтобы показать/скрыть)
Весит папка q4base 2.6 GiB. У меня чистая английская версия 1.4.2.

Похоже, у вас не хватает файлов.
« Последнее редактирование: 27 Октябрь 2014, 14:57:23 от lin_user »

Оффлайн www777

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2730
    • Просмотр профиля
Re: Помогите с Quake 4
« Ответ #6 : 28 Октябрь 2014, 03:18:46 »
А x64 Quake 4 есть? Неохота в систему тянуть библиотеки х32. Или хотя бы эти библиотеки положить в архив с игрой...

Оффлайн Vladimir.1913

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Помогите с Quake 4
« Ответ #7 : 28 Октябрь 2014, 07:49:05 »
Нету, библы в любом случае придется ставить.

Пользователь решил продолжить мысль 28 Октябрь 2014, 07:50:19:
@lin_user, спасибо, нашел диск с лицухой, попробую с него архив вытащить.

 

Страница сгенерирована за 0.146 секунд. Запросов: 24.