Форум русскоязычного сообщества Ubuntu


Автор Тема: после установки фиолетовый экран  (Прочитано 5968 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн saifuddin

  • Автор темы
  • Активист
  • *
  • Сообщений: 917
    • Просмотр профиля
после установки фиолетовый экран
« : 01 Ноябрь 2014, 01:14:18 »
Доброго времени суток.
Поставил на ноут ubuntu 14.10 32bit
Хард GPT
Послу установки появляется фиолетовый экран.
Пробовал ставить и на ubuntu 14.10 64bit and 14.04 64bit
все одно и то же.


Ноутбук Lenovo G505s

у него стоит две видеокарты

дискретная: Radeon HD 8570M
встроенная: Radeon HD 8650G


В биосе ставил, как режим, только встроенная карта, так и авто.

Пользователь решил продолжить мысль 01 Ноябрь 2014, 09:26:56:
пробовал с грузиться с пар.
nomodeset noacpi

не работает.


Видимо вся проблема в видеокарте. Хотя винда работает.
И, до винды многократно ставил линукс все работало.

В чем может быть проблема?
до этого стояла 12.04 и 13.04 Ubuntu.
« Последнее редактирование: 01 Ноябрь 2014, 09:26:56 от saifuddin »
Ubuntu 14.04 64bit | Intel Core i5-2310 CPU @ 2.90GHz |
DIMM DDR3 CMX4GX3M1A1600C9 1333MHz 12GB |Radeon HD 6750 1GB |
WDC WD10EZEX-00R 1TB

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: после установки фиолетовый экран
« Ответ #1 : 01 Ноябрь 2014, 09:30:09 »
Заходим в меню Grub
нажимаем  e
затираем  quiet и splash и добавляем nomodeset
Ctrl+x и загружаемся, обнвляем по максимуму систему и повторяем процедуру.

Если всё ОК, то правим файл:
sudo gedit /etc/default/grub
К параметру GRUB_CMDLINE_LINUX_DEFAULT дописываем  nomodeset и убираем  quiet и splash
Обновляем загрузчик
sudo update-grub
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн saifuddin

  • Автор темы
  • Активист
  • *
  • Сообщений: 917
    • Просмотр профиля
Re: после установки фиолетовый экран
« Ответ #2 : 01 Ноябрь 2014, 09:54:18 »
попробовал с разными настройками биоса(VGA и Авто ставил на видеокарте) и все равно не работает.

может как-то получится загрузиться в консоли? Игнорируя графику.

Установил server ubuntu 14.04 то же не запускается.
Зависает на сплошном черном экране. Да же не доходит до ввода чего либо.

Главное в Livecd все работает отлично видит две дивеокарты, графика без тормозов. А, тут ни в какую. В чем может быть дело?

можно ли как-то зайдя через LiveCD подключиться к установленной ОС и обновить ее(поставить драйвера и обновить программы)?

пробовал поставить opensuse, тут та же беда. Не, пойму что случилось. Видеокарта рабочая, так как с лайв сиди заходит и винда работает. А, грузиться не хочет, не уже ли снова винду ставить?!

подключил свой ssd с ubuntu 14.04 обновленной системой и установленными драйверами, все точно так же не загружается. Значит проблема не в видеокарте.

Пользователь решил продолжить мысль 02 Ноябрь 2014, 05:38:12:
Столько просмотров и только один пост был? Народ ну помогите решить проблему. Я вижу, что она началась с ubuntu 10 и по сейдень продолжает выявляться. Не, уже ли нет способа ее решить?
« Последнее редактирование: 02 Ноябрь 2014, 05:38:12 от saifuddin »
Ubuntu 14.04 64bit | Intel Core i5-2310 CPU @ 2.90GHz |
DIMM DDR3 CMX4GX3M1A1600C9 1333MHz 12GB |Radeon HD 6750 1GB |
WDC WD10EZEX-00R 1TB

Оффлайн RonBarhash

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: после установки фиолетовый экран
« Ответ #3 : 04 Февраль 2015, 01:44:50 »
Доброй ночи всем!
Я счастливый обладатель Lenovo G505s, пишу вам из уже работающей Ubuntu 14.04.
Столкнулся с той же проблемой(Черный экран с фиолетовый рамкой)...бодался пробовал все что советовали и на забугорном форуме нашел решение( хотя это скорей не решение, а костыль) но всеже вдуг кому поможет сберечь нервы!
На форуме парень предложил странное решение(выбрать в БИОСе первым для загрузки "Сетевая карточка"), и действительно помогло.
Но скажу также, что я не стал так оставлять и просто выбрал вместо сетевой карточки, DVD-привод( это тоже работает)


Может это криво, что загрузка идет через DVD( ведь в нем может оказаться какой-то загрузочный диск) но всеже. Быть может кто-то найдет боле веселое решение.


На всякий случай оставлю краткое описание:
Систему ставил с загрузочной флешки.
В биосе видеокарточка в дуальном режиме.
Приоритет на загрузку с DVD

На заметку , при включении ноутбука : F2 = Вход в БИОС / F12 - меню выбора устройства с которого грузимся ;)
« Последнее редактирование: 04 Февраль 2015, 01:55:38 от RonBarhash »

buntuuser

  • Гость
Re: после установки фиолетовый экран
« Ответ #4 : 04 Февраль 2015, 02:14:26 »
saifuddin,
Если что, у меня похожие видеокарточки $ aticonfig --lsa
* 0. 00:01.0 AMD Radeon HD 8550G
  1. 01:00.0 AMD Radeon HD 8600M Series
И 14.10 и 14.04 в Лайв грузяться нормально, мне кажется дело не в видео.

Оффлайн jenno_etlerto

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: после установки фиолетовый экран
« Ответ #5 : 09 Февраль 2015, 15:42:02 »
     Сегодня столкнулся с такой же проблемой. У меня ноут  ASUS K52De (дискретная карточка Radeon HD5470), ставил ubuntu 14.04 на внешний жесткий. Обнаружил следующий нюанс. В меню груба нажал "е" и увидел, что прописана загрузка с диска hd2,1 (что вполне логично, ибо внешний жеский обычно нумеруется вторым по счету после внутреннего жесткого). Но, при вводе команды  "ls"  груб показывает, что внешний жесткий именуется как (hd0).
     Исправив в меню груба имя жесткого с hd2,1 на hd0,1 загрузка пошла.

     То есть, я так понимаю, при установке системы груб неправильно настраивается. Ведь загружаюсь с live-usb и в системе диски именуются в следующем порядке (вывод команд fdisk -l из-под live системы перед установкой на внешний жесткий):
hda - внутренный жесткий
hdb - live-usb
hdc - внешний жесткий

 А при попытки загрузки с внешнего жесткого, при отсутствии загрузочной флешки картина меняется (вывод команды ls  из командной строки груба):
hd0 - внешний жесткий диск
hd1 - внутренний жесткий диск

 Надеюсь сия информация будет полезна.

P.S. Только теперь другой сложный вопрос - как отредактировать груб? Ведь использование команды update-grub из-под установленной системы опять прописывает неадекватные значения, ибо внешний жесткий система видит как hdb или hdc, но никак не hda

Оффлайн moon2010

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: после установки фиолетовый экран
« Ответ #6 : 29 Март 2015, 22:33:29 »
Давно работаю под Ubuntu (с 8 версии) при переустановке 14.04 на ноут Асер 5742 возникла таже проблема - не грузится, что только не делал помогло только вытаскивание из юсби МЫШКИ !!! Глупо конечно, но помогает. На других компах (не ноутах) такого эффекта нет !!!

 

Страница сгенерирована за 0.129 секунд. Запросов: 25.