Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Проблема с драйверами ATI (fps)  (Прочитано 12830 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн F.l.i.p.i.X

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
  • Другие бы нашли смысл, а мы нашли причину...©
    • Просмотр профиля
Проблема с драйверами ATI (fps)
« : 18 Апрель 2008, 02:18:37 »
Драйвер стоит и вроде работает, компиз тоже работает
$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1950 Series
OpenGL version string: 2.1.7412 Release
Но тест fps показывает
$ glxgears
297 frames in 5.0 seconds = 59.263 FPS
295 frames in 5.0 seconds = 58.994 FPS
298 frames in 5.0 seconds = 59.460 FPS
296 frames in 5.0 seconds = 58.816 FPS
297 frames in 5.0 seconds = 58.822 FPS
Объясните кто-нибудь - почему?
Ubuntu 7.10/x86-32 2Гб

Оффлайн Fliker-09

  • Активист
  • *
  • Сообщений: 338
  • Linux rocks and KDE too!
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #1 : 18 Апрель 2008, 17:44:27 »
FPS-ы очень красноречиво говорят о том что дрова в пролёте и работает наверняка VESA. Как исправлять - без понятий.

Оффлайн Stiff

  • Активист
  • *
  • Сообщений: 677
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #2 : 18 Апрель 2008, 19:50:42 »
Неплохо было бы увидеть xorg.conf и вывод glxinfo

Оффлайн F.l.i.p.i.X

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
  • Другие бы нашли смысл, а мы нашли причину...©
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #3 : 19 Апрель 2008, 01:38:09 »
glxinfo объемный, поэтому тоже приаттачил. Удобнее)
Извиняйте, если что-то нубовское

Оффлайн masan

  • Любитель
  • *
  • Сообщений: 62
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #4 : 19 Апрель 2008, 10:48:47 »
попробуй использовать  мой файл, как шаблон. надо под свой комп сделать настройки монитора, Busid, убрать украинскую раскладку)))) разберешься в общем, там не сложно.

Оффлайн Stiff

  • Активист
  • *
  • Сообщений: 677
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #5 : 19 Апрель 2008, 16:34:35 »
Section "Device"
Identifier  "Failsafe Device"
Driver      "fglrx"
BoardName   "vesa"
Option     "VideoOverlay" "on"
Option     "OpenGLOverlay" "off"
BusID       "PCI:1:0:0"
EndSection

Section "Device"
 #
Identifier  "device1"
Driver      "vesa"
BoardName   "VESA driver (generic)"
BusID       "PCI:1:0:1"
EndSection
Всё-таки vesa осталась. Неплохо было бы вообще её убрать отсюда.

Оффлайн F.l.i.p.i.X

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
  • Другие бы нашли смысл, а мы нашли причину...©
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #6 : 24 Апрель 2008, 07:00:46 »
Vesa то осталась, но активен Failsafe Device! 2masan: твой xorg пробовал править - все равно не пошло..... А у тебя нормально работает? И сколько фпс?

Оффлайн Fliker-09

  • Активист
  • *
  • Сообщений: 338
  • Linux rocks and KDE too!
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #7 : 24 Апрель 2008, 17:42:54 »
Ну насчёт glxinfo могу сказать что хватит и glxinfo | grep direct . А сёдня вечером погляжу на ваш ксорг.

Оффлайн masan

  • Любитель
  • *
  • Сообщений: 62
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #8 : 25 Апрель 2008, 22:38:05 »
да работает у меня все, на редкость нормально, и кубик рабочего стола тоже вроде крутится........посмотри логи иксов, и потом, что значит фраза "не пошло"? давай конкретнее. сохрани свой файл конфига и попробуй поставь драйвера с репозитария, у меня после их установки включился компиз, чего он никак нехотел делать при драйверах, установленных вручную, хотя ускорение работало итд... итп.

Оффлайн F.l.i.p.i.X

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
  • Другие бы нашли смысл, а мы нашли причину...©
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #9 : 26 Апрель 2008, 02:29:24 »
Все эффекты, какие только есть в компизе - работают и без тормозов, с репозитария драйвер ставил - даже компиз не пошел, а фпс слабовато! Кстати при включенном компизе видео моргает, смотреть невозможно(((

Оффлайн Fliker-09

  • Активист
  • *
  • Сообщений: 338
  • Linux rocks and KDE too!
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #10 : 10 Май 2008, 21:47:16 »
Ну вот я наконец-то и добрался до вашего ксорга (нашёл данный топик в закладках наводя в них порядок) :). Подправленный мной ксорг прилагаю. Может с ним фпс-ы вырастут... Хотя никаких гарантий того что всё будет ок не даю так что сделайте резервную копию нынешнего ксорга!

Оффлайн F.l.i.p.i.X

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
  • Другие бы нашли смысл, а мы нашли причину...©
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #11 : 11 Май 2008, 01:30:49 »
Спасибо за помощ, ато все замолчали, посмотрю, отпишусь... Научился бороться с этим, правда куча новых проблем появилась, никак с этим не связанные

Оффлайн Abramzzz

  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #12 : 11 Май 2008, 02:42:10 »
Эх, что-то АТИшникам слигком хорошо зажилось :D. У меня 9 фпс на нвидиа и компиз глючит неимоверно (рисует частями)

Оффлайн Fliker-09

  • Активист
  • *
  • Сообщений: 338
  • Linux rocks and KDE too!
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #13 : 12 Май 2008, 16:50:37 »
Спасибо за помощ, ато все замолчали, посмотрю, отпишусь... Научился бороться с этим, правда куча новых проблем появилась, никак с этим не связанные
- так значит вы не попробовали мой ксорг? Если вы сами решили свою проблему то отпишитесь и для других :).

Оффлайн F.l.i.p.i.X

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
  • Другие бы нашли смысл, а мы нашли причину...©
    • Просмотр профиля
Re: Проблема с драйверами ATI (fps)
« Ответ #14 : 14 Май 2008, 23:59:31 »
Нет, не то и не другое. Пробовал - фпс дает столько же. Странный случай произошел! Случилась некая неожиданность с разделами, в итоге я потерял систему))) Я заметил 2 странных факта! С лайвСД веза работает с фпс ~900!!!! А с дровами из коробки ~280 фпс. Вот так вот :) Но компиз на них не идет... Незнаю что и делать, единственное, что раздражает - это дрожание видео и изображения в 3д играх, а на эти цыфры я даже и не смотрел бы)))
З.Ы. 2Fliker-09: Можете и не обращаться ко мне на вы, както даже неловко :)

 

Страница сгенерирована за 0.06 секунд. Запросов: 22.