Форум русскоязычного сообщества Ubuntu


Автор Тема: Wifi не выпускает в интернет  (Прочитано 1243 раз)

0 Пользователей и 1 Гость просматривают эту тему.

tufex

  • Автор темы
  • Гость
Wifi не выпускает в интернет
« : 08 Ноябрь 2014, 15:00:29 »
На компе есть два подключения: по проводу и по wifi. По проводам нормальный выход в интернет, а по wifi могу подключиться только к серверу.
При проверке пинга через wifi выдает ping 8.8.8.8
connect: Network is unreachable
.
На сервере
hostapd.conf
interface=wlan0
bridge=br0
ssid=test                                                                                                                                                                         
driver=nl80211                                                                                                                                                                     
channel=6                                                                                                                                                                         
hw_mode=g                                                                                                                                                                         
macaddr_acl=0                                                                                                                                                                     
auth_algs=1                                                                                                                                                                       
ignore_broadcast_ssid=0
logger_syslog=-1
logger_syslog_level=2

wpa=2
wpa_passphrase=******
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
/etc/network/interfaces
auto lo                                                                                                                                                                                                                                                                       
iface lo inet loopback                                                                                                                                                                                                                                                         
                                                                                                                                                                                                                                                                               
auto wlan0                                                                                                                                                                                                                                                                     
iface wlan0 inet manual                                                                                                                                                                                                                                                       
up ifconfig $IFACE 0.0.0.0 up                                                                                                                                                                                                                                                 
up ip link set $IFACE promisc on                                                                                                                                                                                                                                               
down ip link set $IFACE promisc off                                                                                                                                                                                                                                           
down ifconfig $IFACE down                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                               
auto eth0                                                                                                                                                                                                                                                                     
iface eth0 inet manual                                                                                                                                                                                                                                                         
up ifconfig $IFACE 0.0.0.0 up                                                                                                                                                                                                                                                 
up ip link set $IFACE promisc on                                                                                                                                                                                                                                               
down ip link set $IFACE promisc off                                                                                                                                                                                                                                           
down ifconfig $IFACE down                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                               
auto br0                                                                                                                                                                                                                                                                       
iface br0 inet static                                                                                                                                                                                                                                                         
    address 192.168.1.158                                                                                                                                                                                                                                                     
    network 192.168.1.0                                                                                                                                                                                                                                                       
    netmask 255.255.255.0                                                                                                                                                                                                                                                     
    broadcast 192.168.1.255                                                                                                                                                                                                                                                   
    bridge_ports wlan0 eth0                                                                                                                                                                                                                                                   
                                                                                                                                                                                                                                                                               


auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig br0 up # line maintained by pppoeconf
provider dsl-provider
brctl show
bridge name     bridge id               STP enabled     interfaces
br0             8000.002185c0868c       no              eth0
                                                        wlan0
в isc прописан интерфейс br0
в iptables интерфейс eth0 был заменен на br0.

Пользователь решил продолжить мысль 08 Ноябрь 2014, 15:02:50:
Забыл добавить wlan0 постоянно получает один и тот же ip.
« Последнее редактирование: 08 Ноябрь 2014, 15:02:50 от tufex »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27305
    • Просмотр профиля
Re: Wifi не выпускает в интернет
« Ответ #1 : 08 Ноябрь 2014, 18:46:54 »
Сами то понимаете, что делаете? Работать не будет!
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

tufex

  • Автор темы
  • Гость
Re: Wifi не выпускает в интернет
« Ответ #2 : 08 Ноябрь 2014, 18:53:54 »
ну все по мануалу. Если я тупой то мордой в грязь.  Я что-то пропустил?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27305
    • Просмотр профиля
Re: Wifi не выпускает в интернет
« Ответ #3 : 08 Ноябрь 2014, 18:56:34 »
В Бридже нет разницы, какой IP получает каждый интерфейс бриджа.
Бридж является одним интерфейсом с точки зрения системы.
Это самое очевидное.
Остальное расскажу, когда вы подробно опишете структуру сети. Можно с рисунками.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

tufex

  • Автор темы
  • Гость
Re: Wifi не выпускает в интернет
« Ответ #4 : 08 Ноябрь 2014, 19:04:44 »
сервер раздает интернет в локалку 192.168.1.0/24 (eth0 wlan0)  интернет получаю с ppp0. На сервере создан мост для объединения eth0 wlan0.

Пользователь решил продолжить мысль [time]08 Ноябрь 2014, 20:06:22[/time]:
wlan0 не получает ip моста. А почему?


Пользователь решил продолжить мысль [time]08 Ноябрь 2014, 20:08:11[/time]:
Я не понимаю принцып создания моста?


Пользователь решил продолжить мысль [time]08 Ноябрь 2014, 20:21:10[/time]:
ip получает шлюза 192.168.1.158

Пользователь решил продолжить мысль [time]08 Ноябрь 2014, 20:23:22[/time]:
проблема в маршрутизации?

Пользователь решил продолжить мысль 08 Ноябрь 2014, 19:36:19:
Я все не правильно объяснил. Есть сервер он получает интернет по ppp0,  в сеть (локалку) выходит на eth0 и wlan0. В сети по проводам интернет все получают по (eth0) , но с wlan0 можно подключиться только к серверу.
« Последнее редактирование: 08 Ноябрь 2014, 19:36:19 от tufex »

Оффлайн koshev

  • Старожил
  • *
  • Сообщений: 1705
  • חתול המדען
    • Просмотр профиля
Re: Wifi не выпускает в интернет
« Ответ #5 : 08 Ноябрь 2014, 19:42:16 »
Ещё раз. РАБОТАТЬ НЕ БУДЕТ. И это кроме правил в iptbles и непонятным IP-адресе на wlan0.
Не путайте свою шерсть с государственной разделяйте сеть провайдера и свою локальную сеть физически (дополнительная сетевая карточка) либо логически (vlan'ами на свитче)
« Последнее редактирование: 08 Ноябрь 2014, 19:44:56 от koshev »
Debian GNU\Linux 7.11; ICH7; r8169; Linux 4.14.32-atomd525mv-imq-ja1 (i686)
Ubuntu GNU\Linux 18.04; MCP61; forcedeth; 4.15.0-20-generic (x86_64)

tufex

  • Автор темы
  • Гость
Re: Wifi не выпускает в интернет
« Ответ #6 : 08 Ноябрь 2014, 19:46:15 »
а почему без wlan работает. интернет то по проводам раздается

Оффлайн koshev

  • Старожил
  • *
  • Сообщений: 1705
  • חתול המדען
    • Просмотр профиля
Re: Wifi не выпускает в интернет
« Ответ #7 : 08 Ноябрь 2014, 19:51:36 »
Понятия не имею.
Задайте этот вопрос себе.
Не можете ответить?
Потрудитесь нормально описать проблему, своё оборудование и его коммутацию.
Debian GNU\Linux 7.11; ICH7; r8169; Linux 4.14.32-atomd525mv-imq-ja1 (i686)
Ubuntu GNU\Linux 18.04; MCP61; forcedeth; 4.15.0-20-generic (x86_64)

tufex

  • Автор темы
  • Гость
Re: Wifi не выпускает в интернет
« Ответ #8 : 08 Ноябрь 2014, 20:03:16 »
сервер получает интернет по pppoe (это видно в intrefaces) в локальную сеть интернет раздается с eth0 , все все получают без проблем. На сервере настроена точка доступа (hostapd) . С локальной машины невозможно подключиться с wifi к интернету (по проводам проблем нет). По wifi можно подключться к серверу и все.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27305
    • Просмотр профиля
Re: Wifi не выпускает в интернет
« Ответ #9 : 08 Ноябрь 2014, 20:59:50 »
Ещё раз - НОРМАЛЬНО опишите построение сети.
pppoe телепатически у вас приходит что ли?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

tufex

  • Автор темы
  • Гость
Re: Wifi не выпускает в интернет
« Ответ #10 : 08 Ноябрь 2014, 21:06:25 »
в первом посте все написано рисунки не умею делать, но даю ip
diamond@server:~$ ip a s
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc htb master br0 state UP group default qlen 1000
    link/ether 00:21:85:c0:86:8c brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc mq master br0 state UP group default qlen 1000
    link/ether a0:f3:c1:ff:e7:25 brd ff:ff:ff:ff:ff:ff
4: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether 00:21:85:c0:86:8c brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.158/24 brd 192.168.1.255 scope global br0
       valid_lft forever preferred_lft forever
    inet6 fe80::221:85ff:fec0:868c/64 scope link
       valid_lft forever preferred_lft forever
5: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc pfifo_fast state UNKNOWN group default qlen 3
    link/ppp
    inet 194.54.101.13 peer 192.168.192.168/32 scope global ppp0
       valid_lft forever preferred_lft forever   
« Последнее редактирование: 15 Ноябрь 2014, 20:07:04 от tufex »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27305
    • Просмотр профиля
Re: Wifi не выпускает в интернет
« Ответ #11 : 08 Ноябрь 2014, 21:14:31 »
Работать не будет.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

tufex

  • Автор темы
  • Гость
Re: Wifi не выпускает в интернет
« Ответ #12 : 08 Ноябрь 2014, 21:18:16 »
Спасибо

Пользователь решил продолжить мысль 08 Ноябрь 2014, 21:19:07:
хоть куда смотреть?

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Wifi не выпускает в интернет
« Ответ #13 : 08 Ноябрь 2014, 21:43:14 »
wlan0 не получает ip моста. А почему?
В бридже на подчинённых интерфейсах не должно быть IP.

tufex

  • Автор темы
  • Гость
Re: Wifi не выпускает в интернет
« Ответ #14 : 08 Ноябрь 2014, 21:49:41 »
так их и нет

 

Страница сгенерирована за 0.149 секунд. Запросов: 24.