Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Ubuntu 14.10 // нет сетевых интерфейсов  (Прочитано 2599 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DoctorSad

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Ubuntu 14.10 // нет сетевых интерфейсов
« : 11 Ноябрь 2014, 23:29:42 »
Доброго времени суток.
Я новичок - поэтому просьба не пинать сильно.
Решил поставить на ноуте Ubuntu, т.к. говорят меньше ресурсов её надо (а ноут старый).
Во время запуска с образаа сетевое подключение автоматически настроилось и поднялось (eth0). Но к сожалению после установки на винт согласно инструкции по итогу оказалось "нет доступных сетевых устройств".
Т.е. система не в сети :(. ПОэтому выводы команд если понадобится буду выдавать как смогу.
ifconfig выдает только loopback интерфейс.
Также на ноуте хочется поднять Wireless, буду пробовать по итгу сделать как здесь.
До этого пытался минт поставить - все стало, проводной интерфейс поднялсо, а вот с вайфаем ну никак не получилось.... Решил перейти на Ubuntu - а тут такая оказия.
Буду признателен за помощь в решении проблемы.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13225
  • Xubuntu 18.04
    • Просмотр профиля
Re: Ubuntu 14.10 // нет сетевых интерфейсов
« Ответ #1 : 11 Ноябрь 2014, 23:43:24 »
DoctorSad,
Дайте вывод

lspci -knn | egrep 'Eth|Net' -A2

А вообще, раз вы новичок, то поставьте стабильную версию 14.04, а не тестовую.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн DoctorSad

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 14.10 // нет сетевых интерфейсов
« Ответ #2 : 11 Ноябрь 2014, 23:54:15 »
Её и пробовал сначала - то же самое.
Насчет выводов команд...буду выдавать через фото. Другого варианта не вижу.


Пользователь решил продолжить мысль [time]12 Ноябрь 2014, 01:11:26[/time]:
Дополнительно вот что у нас светится в NetworkManager:


Пользователь решил продолжить мысль [time]12 Ноябрь 2014, 01:38:29[/time]:
DoctorSad,
А вообще, раз вы новичок, то поставьте стабильную версию 14.04, а не тестовую.
Дабы избежать лишних идей по поводу неработающих соединений - перелез на  версию 14.04, стабильную!
Увы, без изменений.

Пользователь решил продолжить мысль [time]12 Ноябрь 2014, 01:44:08[/time]:
Для неработающего вайфая попробовал вот так - после перезагрузки вайфай не взлетел :(.


Пользователь решил продолжить мысль [time]12 Ноябрь 2014, 02:09:23[/time]:
попробовал добавить eth0 в файл interfaces согласно ссылки.
Без изменений, нет в системе интерфейса eth0.

Да, и кстати - почему нажатии на кнопку "выключение" комп не выключается? Продолжает висеть значок Ubuntu на экране  - пока питание не вырубишь кнопкой.
Пошел спать...
« Последнее редактирование: 12 Ноябрь 2014, 01:13:18 от DoctorSad »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13225
  • Xubuntu 18.04
    • Просмотр профиля
Re: Ubuntu 14.10 // нет сетевых интерфейсов
« Ответ #3 : 12 Ноябрь 2014, 01:38:46 »
DoctorSad,
Это конфликт драйверов. Попробуйте так сделать.

sudo apt-get purge bcmwl-kernel-source
sudo modprobe -r wl
sudo modprobe b44

Проводная сеть появилась?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн DoctorSad

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 14.10 // нет сетевых интерфейсов
« Ответ #4 : 12 Ноябрь 2014, 08:34:33 »
Вот что у нас по итогу в терминале было:

Сразу инета не было - но вот после перезагрузки проводная сетевая заработала!
Теперь у меня нет значка Network Manager на рабочем столе в трее. Спасибо огромное - помогло! Ура!
Как его "заработать"?

| toZen |

  • Гость
Re: Ubuntu 14.10 // нет сетевых интерфейсов
« Ответ #5 : 12 Ноябрь 2014, 09:37:26 »
Теперь у меня нет значка Network Manager на рабочем столе в трее.
Как его "заработать"?
sudo apt-get install --reinstall network-manager-gnome??

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13225
  • Xubuntu 18.04
    • Просмотр профиля
Re: Ubuntu 14.10 // нет сетевых интерфейсов
« Ответ #6 : 12 Ноябрь 2014, 09:39:18 »
DoctorSad,
Network Manager нет потому, что вы редактировали /etc/network/interfaces
Надо вернуть его к виду

auto lo
iface lo inet loopback

А вайфай заведется после

sudo apt-get install firmware-b43-installer

Пользователь решил продолжить мысль 12 Ноябрь 2014, 09:39:55:
τοΖεη,
Не надо переустанавливать. Там проблема очень проста.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн DoctorSad

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 14.10 // нет сетевых интерфейсов
« Ответ #7 : 12 Ноябрь 2014, 09:54:46 »
Network manager поднялся.
Вайфай не взлетел.
после попытки установить:
DoctorSad,

А вайфай заведется после

sudo apt-get install firmware-b43-installer

у меня получилось вот такое:
(Нажмите, чтобы показать/скрыть)
В Network manager появились сети вайфай - но написано что вайфай выключен аппаратно

Пользователь решил продолжить мысль 12 Ноябрь 2014, 09:56:12:
Но зато теперь нет проблемы с выключением: выключается комп, перезагружается нормально. Судя по всему также проблема с конфликтом драйверов была.
Остался у нас Wireless..

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13225
  • Xubuntu 18.04
    • Просмотр профиля
Re: Ubuntu 14.10 // нет сетевых интерфейсов
« Ответ #8 : 12 Ноябрь 2014, 10:46:11 »
sudo rfkill unblock all
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн DoctorSad

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 14.10 // нет сетевых интерфейсов
« Ответ #9 : 12 Ноябрь 2014, 23:21:26 »
sudo rfkill unblock all
Ура....Пишу при подключении с Wireless!!!
Офигеть просто. А еще вопрос: если необходимо после выполнения команды перезагрузиться - что необходимо ввести в терминале чтобы не перезагружаться?
Спасибо за внимание, полетели дальшее. Если что - я знаю что делать  :)

 

Страница сгенерирована за 0.109 секунд. Запросов: 24.