Форум русскоязычного сообщества Ubuntu


Автор Тема: Проблемы с подключением к интернету  (Прочитано 2039 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Script4u

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Доброго времени суток, возникла проблема которую не в силах решить уже вторые сутки, обрисую ситуацию
От провайдера имею подключение со статическим ip, примерно такого вида:
Ip адрес: YYY.XXX.77.113
Маска: 255.255.252.0
Шлюз: YYY.XXX.67.1
DNS: 8.8.8.8 8.8.4.4
До этого все прекрасно работало на обычной "домашнем" роутере, но потребовалось подключить сервак с Ubuntu Server к интеренету в роли шлюза(пока ограничимся задачей просто поднять подключение к интернету на серваке)
Подключил кабель от провайдера к сетевухе сервака, в "etc/network/interfaces" прописал следующие настройки:
Цитировать
iface p1p1 inet static
  address YYY.XXX.77.113
  netmask 255.255.252.0
  gateway YYY.XXX.67.1
  dns-nameservers 8.8.8.8 8.8.4.4
auto p1p1
В итоге при загрузке сервак долго ждет пока пройдет конфигурация сети, команда "ifconfig" выдает что все параметры сетевуха приняла, кабель подключен, но "ping 8.8.8.8" выдает "connect network is unreachable", соответственно соединения с интернетом нет:(
Привязки по mac у провайдера нет, ради эксперимента попробовал подключится с windows машины, прописал аналогичные настройки в сетевухе, на что винда ругнулась "Основной шлюз находится не в том сегменте сети(подсети), который определён IP-адресом и маской подсети. Сохранить настройки?", согласившись, подключение поднялось без проблем, инет стал доступен.
Что не так я прописал в Ubunt'е? Подозреваю что, что-то не так с полем broadcast которая сетевуха прописывает автоматом сама, но это лишь догадки(из-за сообщения винды), и какой точный адрес broadcast прописать я не знаю...
Подозреваю что проблема решается весьма тривиально, но сам не в силах ее решить:(
« Последнее редактирование: 15 Ноябрь 2014, 01:46:28 от Script4u »

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net
Re: Проблемы с подключением к интернету
« Ответ #1 : 15 Ноябрь 2014, 05:01:36 »
В венде:
ipconfig /all & route printВыхлоп под спойлер.

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13746
    • Просмотр профиля
Re: Проблемы с подключением к интернету
« Ответ #2 : 15 Ноябрь 2014, 10:43:02 »
прописал аналогичные настройки в сетевухе, на что винда ругнулась "Основной шлюз находится не в том сегменте сети(подсети), который определён IP-адресом и маской подсети. Сохранить настройки?", согласившись, подключение поднялось без проблем, инет стал доступен.
То есть Вы считаете, что венда Вас нагло обманула своим предупреждением.
На самом деле венда рассчитана на домашних пользоватлей, которые могут просто не знать зачем эти цифирки (адрес, маски, ШЛЮЗ) и в случае неправильной конфигурации предупреждает об ошибке, но при согласии сама пытается устранить ошибку.
А Ubuntu считает, что в её конфиги лезет адекватный человек и понимает назначение этих цифр и их взаимосвязь. И если что-то не сращивается, то она "выкидывает" неугодный параметр.
У Вас так и получилось. Для Вас видимо нет разницы ХХ.ХХ.67.1 или ХХ.ХХ.76.1, а вот системам - нет. Венда заработала, потому что посчитала, что шлюз, вероятнее всего, находится в начале выделенного диапазона адресов для сети, потому сеть и заработала, а ubuntu решила наказать нерадивого админа. Не сильно, но пару миллионов нервных клеток поди прибила.
Думаю вектор действий понятен: исправляйте настройки и хотя бы чуть-чуть почитайте про основы построения сетей (адресация, маршрутизация)
Удачи
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net
Re: Проблемы с подключением к интернету
« Ответ #3 : 15 Ноябрь 2014, 13:59:54 »
koshev, ТС утверждает, что маска 22 бита, но всё равно, получается лажа.

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 15 Ноябрь 2014, 14:02:20 от ArcFi »

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13746
    • Просмотр профиля
Re: Проблемы с подключением к интернету
« Ответ #4 : 15 Ноябрь 2014, 14:05:54 »
Я специально не стал давать раскладку по сети xx.xx.xy.0/255.255.252.0 оставив это ТС в качестве домашнего задания. ;)
Если ему будет интересно почему 76.1, а не 67.1, то он разберётся, а если нет.. то и незачем это показывать.
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн koshev

  • Старожил
  • *
  • Сообщений: 1671
  • חתול המדען
    • Просмотр профиля
Re: Проблемы с подключением к интернету
« Ответ #5 : 15 Ноябрь 2014, 14:54:16 »
koshev, ТС утверждает, что маска 22 бита, но всё равно, получается лажа.
Таки да, дал маху.
Debian GNU\Linux 7.11; ICH7; r8169; Linux 4.14.32-atomd525mv-imq-ja1 (i686)
Ubuntu GNU\Linux 18.04; MCP61; forcedeth; 4.15.0-20-generic (x86_64)

 

Страница сгенерирована за 0.06 секунд. Запросов: 24.