Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: нет возможности удалить/установить приложения из-за повреженных пакетов  (Прочитано 2583 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Arbitr

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
День добрый, есть два компа, на первом Ubuntu 14,04/32 на втором Ubuntu 14,04/64
одна и та же проблема, нет возможности что либо удалить или установить из за поврежденных пакетов
при попытке установки или удаления через центр приложений предлагает восстановить ПО но не получается
при выполнении команды из терминала sudo apt-get uninstall пакеты не установлены или не удалены пробуйте apt-get -f install что тоже не помогает

chemtech

  • Гость
Arbitr,
А так?

sudo apt-get -f install
sudo dpkg --configure -a
sudo apt-get update --fix-missing

Оффлайн Arbitr

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
sudo apt-get -f install
(Нажмите, чтобы показать/скрыть)
sudo dpkg --configure -a
(Нажмите, чтобы показать/скрыть)
sudo apt-get update --fix-missing
(Нажмите, чтобы показать/скрыть)

Пользователь решил продолжить мысль [time]08 Декабрь 2014, 14:49:19[/time]:


Пользователь решил продолжить мысль 08 Декабрь 2014, 13:53:25:
не все влезло.. ткстовый док прилагаю
« Последнее редактирование: 08 Декабрь 2014, 13:53:25 от Arbitr »

Оффлайн san-alex

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 7727
  • Ex-CNC programmer
    • Просмотр профиля
Либре оффис устанавливала из реп?

Оффлайн Arbitr

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Цитировать
Либре оффис устанавливала из реп?
нет он шел по умолчанию в  сборке.. он был удален и установлен опен офис

Оффлайн san-alex

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 7727
  • Ex-CNC programmer
    • Просмотр профиля
Вот эти репы надо отключить:
http://ppa.launchpad.net/libreoffice/libreoffice-4-0/ubuntu/dists/trusty/main/binary-i386/Packages
http://ppa.launchpad.net/lion-simba/hp2400/ubuntu/dists/trusty/main/binary-i386/Packages
http://ppa.launchpad.net/upubuntu-com/openoffice/ubuntu/dists/trusty/main/binary-i386/Packages
потом сделать:
sudo apt-get update
sudo apt-get update --fix-missing
О результатах доложить.

Оффлайн Arbitr

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
эмм кажется я неправильно пишу
sabina@sabina-G41T-M7:~$ sudo add-apt-repository --remove ppa:http://ppa.launchpad.net/libreoffice/libreoffice-4-0/ubuntu/dists/trusty/main/binary-i386/Packages
[sudo] password for sabina:
Cannot add PPA: 'ppa:http://ppa.launchpad.net/libreoffice/libreoffice-4-0/ubuntu/dists/trusty/main/binary-i386/Packages'.
Please check that the PPA name or format is correct.
sabina@sabina-G41T-M7:~$

chemtech

  • Гость
Arbitr,
А так?
sudo apt-get install ppa-purge
ppa-purge ppa:libreoffice/libreoffice-4-0

Оффлайн Arbitr

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Arbitr,
А так?
sudo apt-get install ppa-purge
ppa-purge ppa:libreoffice/libreoffice-4-0
sabina@sabina-G41T-M7:~$ sudo apt-get install ppa-purge
[sudo] password for sabina:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 libreoffice-core : Зависит: libreoffice-common (> 1:4.2.7) но он не будет установлен
 libreoffice-java-common : Зависит: libreoffice-common но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
sabina@sabina-G41T-M7:~$ ppa-purge ppa:libreoffice/libreoffice-4-0
Программа 'ppa-purge' на данный момент не установлена. Вы можете установить её, выполнив:
sudo apt-get install ppa-purge
sabina@sabina-G41T-M7:~$

Оффлайн san-alex

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 7727
  • Ex-CNC programmer
    • Просмотр профиля
chemtech, у нее зависимости поломаны, ничего установить не получится.

Arbitr, сделай так:
1. Открой центр приложений.
2. Меню "Изменения"- источники программного обеспечения, вкладка "другое программное обеспечение" сними "галочки" напротив нужных репозиториев.

chemtech

  • Гость
Arbitr,
Или так:
Закоментируйте строки похожие на

http://ppa.launchpad.net/libreoffice/libreoffice-4-0/ubuntu/dists/trusty/main/binary-i386/Packages
http://ppa.launchpad.net/lion-simba/hp2400/ubuntu/dists/trusty/main/binary-i386/Packages
http://ppa.launchpad.net/upubuntu-com/openoffice/ubuntu/dists/trusty/main/binary-i386/Packages

в файле

/etc/apt/source.list или в файлах в папке /etc/apt/source.list.d

Оффлайн Arbitr

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
chemtech, у нее зависимости поломаны, ничего установить не получится.

Arbitr, сделай так:
1. Открой центр приложений.
2. Меню "Изменения"- источники программного обеспечения, вкладка "другое программное обеспечение" сними "галочки" напротив нужных репозиториев.

простите не вижу в меню http://savepic.org/6587980.jpg

Цитировать
Arbitr,
Закоментируйте строки похожие на
так <!--  --> ??


Правила форума
Цитата: Правила форума
1.5. Для добавления графических изображений в сообщения требуется использовать внешние сервисы. Подробную инструкцию, а так же список рекомендованных и запрещенных сервисов можно посмотреть в «Руководстве по добавлению изображений на форум».

--chemtech

« Последнее редактирование: 08 Декабрь 2014, 14:42:03 от chemtech »

Оффлайн san-alex

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 7727
  • Ex-CNC programmer
    • Просмотр профиля
Arbitr, меню - это верхняя строчка в окне программы (у меня система на украинском, но думаю, поймешь):

откроется такое окно:

в нем снимаешь ненужные галочки

Оффлайн Arbitr

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Arbitr
в нем снимаешь ненужные галочки
сделано

Оффлайн san-alex

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 7727
  • Ex-CNC programmer
    • Просмотр профиля
А теперь:
sudo apt-get update
sudo apt-get upgrade -f

 

Страница сгенерирована за 0.109 секунд. Запросов: 24.