Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: lamp  (Прочитано 665 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 81
    • Просмотр профиля
lamp
« : 11 Декабрь 2014, 20:20:32 »
Недавно переустановил apache, php и mysql, apache почемуто версии 2.4.7, a PHP 5.5.9-lubuntu4.5, хотя уже давно существуют стабильные версии apache 2.4.10 и PHP 5.5.19, до переустановки именно они у меня и были, а теперь установились такие. Вопрос: почему так вышло и как их обновить? И ещё вопрос: в версии PHP указанно lubuntu4.5-Что это и при чём здесь lubuntu?

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: lamp
« Ответ #1 : 11 Декабрь 2014, 20:33:16 »
при том, что сборка была оптимизирована именно под этот дистрибутив.
А зачем переустанавливали? И какой релиз был до переустановки? И какой установили?
обновление системы делали?

Цитировать
Форум русскоязычного сообщества Ubuntu
это и при чём здесь lubuntu?
и правда, при чём тут Lubuntu
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 81
    • Просмотр профиля
Re: lamp
« Ответ #2 : 11 Декабрь 2014, 20:41:41 »
fisher74, если описывать более подробно, то я убил систему, потому полностью её переустанавливал, а затем устанавливал эти проги заново, ранее версия была 14.04, теперь 14.04.1, после установки системы сразу же сделал обновление системы update, upgrade и dist-upgrade
« Последнее редактирование: 11 Декабрь 2014, 20:43:37 от vvn »

chemtech

  • Гость
Re: lamp
« Ответ #3 : 11 Декабрь 2014, 21:10:58 »
vvn,
Какую версию Ubuntu вы используете?
lsb_release -a
« Последнее редактирование: 11 Декабрь 2014, 21:14:45 от chemtech »

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 81
    • Просмотр профиля
Re: lamp
« Ответ #4 : 11 Декабрь 2014, 21:13:28 »
chemtetc, спасибо пойду пробовать

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: lamp
« Ответ #5 : 11 Декабрь 2014, 21:27:13 »
Это не решение Вашей проблемы. Это уточняющий вопрос на Ваше описание.

сразу же сделал обновление системы update, upgrade и dist-upgrade
Жёстко... Вы правда не знаете назначение последней команды?
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 81
    • Просмотр профиля
Re: lamp
« Ответ #6 : 11 Декабрь 2014, 21:38:28 »
fisher74 теперь знаю, только вот не понял к чему он это? :)

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: lamp
« Ответ #7 : 11 Декабрь 2014, 21:41:10 »
Вас просили озвучить версию релиза, закрепив это выхлопом системной команды
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 81
    • Просмотр профиля
Re: lamp
« Ответ #8 : 11 Декабрь 2014, 21:48:41 »
No LSB modules are available.
Distributor ID:   Ubuntu
Description:   Ubuntu 14.04.1 LTS
Release:   14.04
Codename:   trusty

Вот он выхлоп, хотя у меня спрашивали какую версию Ubuntu я использую, парадокс в том, что в предидущем сообщении я написал 14.04.1 lts, а предидущая версия 14.04 lts

Пользователь решил продолжить мысль 11 Декабрь 2014, 21:54:16:
Кстати, я не очень внимательно прочитал ваше сообщение, потому не верно его истолковал, я знаю про dist-upgrade и были пакеты требовавшие обновление этой командой
« Последнее редактирование: 11 Декабрь 2014, 21:54:16 от vvn »

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: lamp
« Ответ #9 : 11 Декабрь 2014, 22:31:21 »
Теперь я понял Ваше недоумение про Lubuntu
:~$ apt-cache show php5-common | grep Version
Version: 5.5.9+dfsg-1ubuntu4.5
как видите, это не Lubuntu, а 1ubuntu (цифра 1 перед названием) Так что она действительно не при чём.

А по сути "проблемы"... что у Вас там было и, тем более, как Вы этого добились ни кто, кроме Вас не знает (может именно поэтому и рухнула???).

Какие версие включать в LTS-релиз - каноникал выбирает сам. Значит более современная стабильная версия ещё не отточена для ubuntu.
Если Вам эти дельты подверсий влияют на работоспособность проекта, то подключайте сторонние репы и используйте на свой страх и риск. Либо сами собирайте пакет и отслеживайте его баги/глюки/несовместимости(с данным конкретным дистром).
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 81
    • Просмотр профиля
Re: lamp
« Ответ #10 : 11 Декабрь 2014, 22:42:19 »
fisher74, на счёт lubuntu-эт я затупил, а на счёт версий то я их ставил вполне стандартным способом, с бубном не танцевал и оба раза ставил одинаково, потому и удивился разному результату, в данном случае на работоспособность не влияет, но как то уж больно интересно, хотелось бы понять как это получилось. А на счёт рухнуло, то там ни чего не рухнуло, я сам убил систему(не специально конечно же), а нормально восстановить не получилось вот и переустанавливал
« Последнее редактирование: 11 Декабрь 2014, 22:45:20 от vvn »

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: lamp
« Ответ #11 : 11 Декабрь 2014, 23:08:59 »
ну не знаю, что у Вас там получилось... в офф.репах самая новая версия релизов 14.10 и 15.04 - php5-common-5.5.12. Апача не смотрел - лень
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

 

Страница сгенерирована за 0.068 секунд. Запросов: 24.