Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Тормоза на Nvidia GeForce 8xxx предположительно из-за PowerMizer  (Прочитано 4764 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dmitriy.trt

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Система:
Ноутбук Acer Aspire 5290G
Процессор Core2 Duo T5550 1,83Ghz
Карточка GeForce 8600GS с 256Mb собственной памяти DDR3
Памяти 2Gb DDR2.
Ubuntu 8.04 Hardy

После установки проприетарных драйверов от Nvidia (169.12, релиз) графика работает не так, как ожидают от видеокарты такого класса. (Сразу замечу, я без эффектов Compiz уже жить не могу, поэтому они включены сразу после установки драйверов.) Как только система загрузилась, всё как будто хорошо: все эффекты шустро работают, прокрутка в программах типа Firefox работает вполне шустро и плавно.... Но это только первое время. Уже на вторую/третью минуту начинаются задержки в работе графики: прокрутка в Firefox и OpenOffice тормозит. Даже выделение текста в некоторых программах подтормаживает. Эффекты сворачивания/разворачивания/открытия/закрытия окон работают с заметной задержкой и иногда замирают ненадолго в середине анимации. Даже эффект подсвечивания кнопок окна при наведении на них мышью (которые свернуть, развернуть и закрыть) иногда работает с заметной задержкой! И это на современной игровой видеокарте! Как такое понимать? Где искать решение?

Установка более новых драйверов 173.08 только усугубляет ситуацию (по личным ощущениям).

С драйверами поставляется утилита nvidia-settings и в ней можно посмотреть состояние энергосберегающей технологии PowerMizer, которая снижает частоту графического процессора и памяти видеокарты, чтобы они соответствовали нагрузке на видеокарту.... Сразу после загрузки эта программа показывает уровень 2 (максимальные частоты), и затем плавно в течение пары минут переходит в режим 0 с минимальной производительностью. Вот тут и начинается самое веселье, описанное выше. Самое удивительное, что как не издевайся над окнами и эффектами Compiz от нуля режим так мне и не удалось оторвать. Т.е. при загрузке видим 2 и хорошую скорость, далее 1 и 0, и больше мы не видим производительности вообще, одни тормоза. У меня есть опыт запуска Ubuntu на еще одном ноутбуке и на стационарном компе.

На старом ноутбуке: видеокарта Ati Xpress 200M - тормознее еще поискать. Процессор Celeron 1,6 GHz одноядерный, памяти гиг. Ставим проприетарные дрова из репозиториев, ставим XGL и о чудо! Всё летает, эффекты скачут прыгают, очень комфортная работа!

На стационарном компе: интегрированна видеокарта от Intel (по-моему, чипсет 865 что-ли...) - тоже не сахар, как кажется. Чистая установка Ubuntu, вообще без усилий, по-умолчанию, включает Compiz и все эффекты летают!

Так вот вопрос. Почему мой ноутбук стоимостью как 2 старых, что с Ati, работает на порядок медленнее?? Как это решить? Как выключить эту чертову технологию PowerMizer?

P.S. Установка XGL тоже не решает проблему.

Оффлайн Dmitriy.trt

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Из пары скриптов спаял один. Он не дает частотам опускаться, PowerMizer просто не успевает понизить частоты за 20 секунд.
while true; do
    if on_ac_power; then
    nvidia-settings -q all > /dev/null
    fi
    sleep 20;
done
Прописываем его, например, в автозапуск в своей сессии и радуемся.
Решение хоть и уродливое, но на данный момент ничего другого нет. Если кто знает лучшее решение - отпишитесь, пожалуйста.

P.S. Всех проблем с графикой это не решает, но задержек анимации в Compiz нет, эффекты стали довольно шустрыми. :)
« Последнее редактирование: 25 Апрель 2008, 18:58:52 от Dmitriy.trt »

Оффлайн easy2002

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2786
  • Мурманск
    • Просмотр профиля
Цитировать
Если кто знает лучшее решение - отпишитесь
while true; do
    if on_ac_power; then
    nvidia-settings -q all > /dev/null
    fi
    sleep 200;
done
Tempora mutantur et nos mutantur in illis

Оффлайн stepanoff

  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
    • Unix Blog
у меня та же проблема на acer aspire 5520G nvidia 8600m 512mb.
Интересно, а можно как то вообще отключить эти динамические настройки видяхи?

Оффлайн su-root

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
А лучше сбросить чек бокс "PowerMizer Monitor" на вкладке "nvidia-settings Configuration", а уж потом заупустить один раз "nvidia-settings -q all"

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
я что то не страдаю с 8400 GS
дрова 169.12. hardy.
около 100 кадров в секунду добавил включением Loose binding. на Рабочем столе Compiz benchmark 530 кадров в секунду. PowerMizer работает.  Может что то не так?

Оффлайн nike_v1

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
У меня та же проблема! nvidia 8600gs на ноуте Acer 5520g. Нормального решения так и не нашлось?

Оффлайн satch

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1561
  • Kubuntu 15.10 amd64
    • Просмотр профиля
у меня тот же ноут, какая у тебя версия драйверов?
Наше желание помочь прямопропорционально вашему желанию решить проблему

Оффлайн subvados

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Я тоже учудил дома все работало чудно, стоял nv думаю поставлю ка я поновее драйвер, смотрю в списках есть, nvidia 8*ser. поставил на свою голову, сейчас вообще ничего не запускается, все черный квадрат малевича  :idiot2: зачем я это сделал , что теперь чинить, так хоть консоль бы запускалась, фиг, АБСТРАКЦИЯ. Полная....
Что делать? :D
Самое главное что такое впечетление что вроде все начинает запускаться, а потом бах,  и тихина , лампочка индикатора диска подмигивает, подмигивает, а толку никакого, так , grub do этого отредактировал думаю уберу от туда всю эту хрен... оставлю, ubunu, windows. Ну закон подлости.
теперь наверно только через life CD лезть,???????

 только что там редактировать?

Оффлайн nike_v1

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Пробовал дрова 169.12       173.02          173.14.12     все одна петрушка  2-3 минуты работает а потом тормозззааа, на сайте nvidia написано что в последней версии дров все хорошо держит 8600gs но как я понял это только надписи  :( :( :(





_____________________________________________________________________________________________________
Acer aspire 5520  nvidia 8600gs

Оффлайн nike_v1

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Еще заметил вот какую интересную вещь!  При запуске  glxgears  nvidia-power-mizer снова возращает 500 MHZ ,  но к сожалению опять не надолго  :(:(

Оффлайн Lonely_@ss

  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля
У меня Acer Aspire 6920G, дрова 173.14.09. Компиз работает нормально, PowerMizer тут же отображает повышение частоты при задействовании всей мощи видеокарты. Так что не стоит, мне кажется, скриптом держать частоту на высоте, она и так поднимается, если это нужно. В nvidia, поди, тоже не дураки работают.

amdlintuxos

  • Гость

Так вот вопрос. Почему мой ноутбук стоимостью как 2 старых, что с Ati, работает на порядок медленнее?? Как это решить? Как выключить эту чертову технологию PowerMizer?

Дрова кривые(а хорошие не знаю есть ли вообще)
На моей Джифорсе 7600 компиз раб медленее чем на радеон9200 (настройка компиза пару тройка плагинов).
Повер Мизер тут не причём, Видеокарты такого уровня даже в Повер Мизере должны показывать зтаоблачные результаты.
Как вариант в компизе
loose blinding активировать
indirect rendering активировать
Активацию проще зделать через прогу Compiz-fusion icon
и в настройках общих к компизу число фпс под 100-120 тогда должны быть плавность.
У меня компиз с коробки работает очень слащаво

Оффлайн nike_v1

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Поставил Ubuntu 8.10 проблема сама решилсь, теперь PowerMizer сам поднимает частоту))))

 

Страница сгенерирована за 0.064 секунд. Запросов: 22.