Форум русскоязычного сообщества Ubuntu


Автор Тема: не могу установить dev-пакет GTK+  (Прочитано 790 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн лис3

  • Автор темы
  • Участник
  • *
  • Сообщений: 165
    • Просмотр профиля
не могу установить dev-пакет GTK+
« : 25 Январь 2015, 22:15:21 »
Нашел статью "Создание приложений на GTK+ с использованием среды Glade"

В начале стати есть такое
Цитировать
Предполагается, что у Вас уже установлен dev-пакет GTK+, если нет, то это можно сделать через консоль:
sudo aptitude install libgtk2.0-dev

Конечно dev-пакет GTK+ не установлен.
Запускаю терминал. Ввожу нужную строчку. Вижу

Цитировать
a@a-X200MA:~$ sudo aptitude install libgtk2.0-dev
[sudo] password for a:
sudo: aptitude: command not found
a@a-X200MA:~$

А как установить dev-пакет GTK+?

Оффлайн alsoijw

  • Старожил
  • *
  • Сообщений: 4073
  • Fedora 25 GNOME 3 amd64
    • Просмотр профиля
Re: не могу установить dev-пакет GTK+
« Ответ #1 : 25 Январь 2015, 22:17:24 »
лис3,
sudo apt-get install libgtk2.0-dev
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?

Оффлайн Best beast

  • Участник
  • *
  • Сообщений: 103
  • Arch Linux
    • Просмотр профиля
Re: не могу установить dev-пакет GTK+
« Ответ #2 : 25 Январь 2015, 22:18:09 »
sudo apt-get install libgtk2.0-devчтобы использовать aptitude вместо apt, его нужно сначала установить
REISUB

Оффлайн лис3

  • Автор темы
  • Участник
  • *
  • Сообщений: 165
    • Просмотр профиля
Re: не могу установить dev-пакет GTK+
« Ответ #3 : 28 Январь 2015, 12:09:06 »
спасибо. Все удалось. Благодарю.
И еще одни вопрос:
В инструкции написано
Цитировать
После установки запускаем через Applications — Programming — Glade Interface Designer
Еще и скриншот дали
Но у меня 1. Все по русски (но это фигня)
2. Нет даже намека на "Applications — Programming — Glade Interface Designer"  или "Приложения - Программирование - конструктор Поляна Интерфейс".

Вообще статья какая - то не такая. Второй абзац, второй "затык"....

Оффлайн alsoijw

  • Старожил
  • *
  • Сообщений: 4073
  • Fedora 25 GNOME 3 amd64
    • Просмотр профиля
Re: не могу установить dev-пакет GTK+
« Ответ #4 : 28 Январь 2015, 17:52:46 »
лис3, ты его поставил?
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?

Оффлайн лис3

  • Автор темы
  • Участник
  • *
  • Сообщений: 165
    • Просмотр профиля
Re: не могу установить dev-пакет GTK+
« Ответ #5 : 30 Январь 2015, 12:26:06 »
да
(Нажмите, чтобы показать/скрыть)

Оффлайн alsoijw

  • Старожил
  • *
  • Сообщений: 4073
  • Fedora 25 GNOME 3 amd64
    • Просмотр профиля
Re: не могу установить dev-пакет GTK+
« Ответ #6 : 30 Январь 2015, 15:28:41 »
лис3, рискну предположить, что этому руководству около 4 лет. Статья рассматривает окружения на gtk-+2.0(ну можно ещё cinnamon отнести). Приложение ты нашёл. Почитай правила как картинки вставлять.
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?

 

Страница сгенерирована за 0.106 секунд. Запросов: 24.