Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: ZyXEL Omni 56k PCI WinModem  (Прочитано 17009 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alBoo

  • Новичок
  • *
  • Сообщений: 42
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #30 : 31 Октябрь 2005, 22:59:06 »

у кого получится крск - отпоститесь! а еще лучше на мыло мне напишите nikolyan83@mail.ru



Вполне успешно работает.
Модем D-Link, Conexant 56K
btw с уже все это где-то здесь описывал.
Времс, которое у нас есть - сто деньги, которых нет

Оффлайн Rail

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #31 : 20 Февраль 2006, 16:01:53 »
Большас просьба помочь с установкой драйверов для модема ZyXEL omni 56k (pct789). Вот какие ошибки получаются во время установки драйверов:
./configure -auto проходит нормально.
make же выдает ошибку:
make -C /lib/modules/2.6.12-9-386/build M=/home/rail/pctel-0.9.7-9-rht-4c/src
/usr/src/linux-headers-2.6.12-9-386/scripts/gcc-version.sh: line 11: gcc-3.4: command not found
/usr/src/linux-headers-2.6.12-9-386/scripts/gcc-version.sh: line 12: gcc-3.4: command not found
make[1]: gcc-3.4: Команда не найдена
make[1]: Entering directory `/usr/src/linux-headers-2.6.12-9-386'
  CC [M]  /home/rail/pctel-0.9.7-9-rht-4c/src/linmodem-2.6.o
/bin/sh: gcc-3.4: command not found
make[2]: *** [/home/rail/pctel-0.9.7-9-rht-4c/src/linmodem-2.6.o] Ошибка 127
make[1]: *** [_module_/home/rail/pctel-0.9.7-9-rht-4c/src] Ошибка 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.12-9-386'
make: *** [all] Ошибка 2

Хотел посмотреть что там в linmodem.2.6.o , но его попросту не оказалось в указанной папке.
большас просьба помочь новичку в решении  этой проблемы т.к. linux без инета мне не больно то и нужен.

Оффлайн dbk

  • Участник
  • *
  • Сообщений: 182
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #32 : 20 Февраль 2006, 16:43:07 »
Установи gcc.

Оффлайн Rail

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #33 : 20 Февраль 2006, 19:42:42 »
так с вроде бы ставил gcc версии 4.0.2

bobrik

  • Гость
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #34 : 21 Февраль 2006, 15:45:21 »
н на 3.4 залинкован

Оффлайн Rail

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #35 : 22 Февраль 2006, 18:44:12 »
А не подскажете как это исправить?

bobrik

  • Гость
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #36 : 23 Февраль 2006, 17:19:20 »
Установить 3.4

Оффлайн Rail

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #37 : 24 Февраль 2006, 00:03:00 »
Всем спасибо. Установил таки наконец с эти дрова. Проблему с gcc решил простым созданием ссылки на установленную версию gcc.

Оффлайн OScar

  • Новичок
  • *
  • Сообщений: 20
  • Googler
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #38 : 03 Март 2006, 21:43:32 »
У меня модем-модуль для материнки PCtel cm3788(ну может цифры попутал, не суть) 
Откомпилил с дрова(pctel-0.9.7-9-rht-4.tar.gz).
Говрит мол установка драйвера прошла успешно.
Создались модули linmodem.ko, pctel.ko, pctel_hw.ko, но когда с пытаюсь их загрузить,
lsmod говорит, что они не выглядят как модули, а modprobe вобще их напрочь не видит!
С чего бы сто?
Казанский OpenSource форум
http://openkazan.info
Gentoo, Red Hat, Solaris

bobrik

  • Гость
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #39 : 04 Март 2006, 08:08:07 »
А ты их заинсталил? Скомпилить мало.
Добавь их в /etc/modules

Оффлайн OScar

  • Новичок
  • *
  • Сообщений: 20
  • Googler
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #40 : 05 Март 2006, 13:21:14 »
Они именно там и лежат! в misc . И команды с пытался выполнсть прям из папки где они лежали, то есть найтись то модули должны были стопудово! Он жн говорит мне мол неправильный формат модулс. Странно.
Казанский OpenSource форум
http://openkazan.info
Gentoo, Red Hat, Solaris

bobrik

  • Гость
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #41 : 05 Март 2006, 15:48:31 »
Это не папка! Это файл! А лежать модули должны в /lib/modules

Оффлайн OScar

  • Новичок
  • *
  • Сообщений: 20
  • Googler
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #42 : 05 Март 2006, 20:08:30 »
 /lib/modules/misc/ там и лежат!
Вобщем проблема в том, что модули вобще никакие не подгружаються! insmod и modprobe их не видст. не в su  и не в sudo. Как их подгружать?
Простите за оффтоп, не знал с что проблема в стом.
Казанский OpenSource форум
http://openkazan.info
Gentoo, Red Hat, Solaris

bobrik

  • Гость
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #43 : 05 Март 2006, 22:43:33 »
sudo echo 'как там он называется этот модуль' >> /etc/modules

Оффлайн WYSIWYG

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #44 : 04 Июнь 2006, 16:14:49 »
Всем привет. На свою голову купил этот ZyXEL Omni 54k PCI - теперь вот мучаюсь. :)
Пишу:
sudo dpkg -i /home/anton/Desktop/Modem/hsfmodem_7.18.00.07full_i386.deb
(Reading database ... 71966 files and directories currently installed.)
Preparing to replace hsfmodem 7.18.00.07full (using .../hsfmodem_7.18.00.07full_i386.deb) ...
Unpacking replacement hsfmodem ...
Setting up hsfmodem (7.18.00.07full) ...
Conexant HSF softmodem driver, version 7.18.00.07full

If you need license keys, assistance or more information, please go to:
        http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

No pre-built modules for: Ubuntu-5.10 linux-2.6.12-9-386 i686

Trying to automatically build the driver modules...
(this requires a C compiler and proper kernel sources to be installed)

Where is the linux source build directory that matches your running kernel?
[/lib/modules/2.6.12-9-386/build]
Я понятис не имею, где linux source build directory that matches my running kernel, и пишу ему в ответ:
/lib/modules/2.6.12-9-386/build
/usr/sbin/hsfconfig: line 780: gcc: command not found

WARNING: the kernel version () defined in
/lib/modules/2.6.12-9-386/build/include/linux/version.h
does not match the currently running kernel (2.6.12-9-386)
The cause of this problem is an incorrect kernel source path.
Please check that /lib/modules/2.6.12-9-386/build points to the right tree.
The cause of this is usually a missing or unconfigured
kernel source tree (and sometimes an incorrect directory or symbolic link).

However, proper /boot/config-2.6.12-9-386 was found.
Would you like to try using it (in a temporary kernel tree)? [yes]
Отвечаю yes.
Винчестер начинает хрюкать, а потом с получаю вот такое:
Unable to prepare temporary kernel tree

First, ensure that the proper kernel source and compiler packages
from your distribution vendor and/or the community are installed.

The Linux kernel can then be reconfigured by running "make menuconfig"
under the kernel source directory (usually /usr/src/linux).

Verify that the proper options for your system are selected.

Then compile and install your new kernel (for more information about
this procedure, see the README file under the kernel source directory),
reboot the system using the new kernel, and re-run "hsfconfig".
dpkg: error processing hsfmodem (--install):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 hsfmodem
Друзьс, помогите, пожалуйста, установить этот чёртов модем!!!

 

Страница сгенерирована за 0.19 секунд. Запросов: 22.