Форум русскоязычного сообщества Ubuntu


Автор Тема: ZyXEL Omni 56k PCI WinModem  (Прочитано 17010 раз)

0 Пользователей и 1 Гость просматривают эту тему.

bobrik

  • Гость
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #45 : 04 Июнь 2006, 21:50:48 »
А gcc не стоит, заметил с после беглого просмотра.

Оффлайн WYSIWYG

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #46 : 06 Июнь 2006, 14:09:20 »
А как его установить? Что и откуда нужно скачать?
Я в линуксовых делах полный ламер. Ubuntu - первый линуск, который с пробую.

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #47 : 06 Июнь 2006, 14:16:26 »
А как его установить? Что и откуда нужно скачать?
Если есть инет:
$sudo apt-get install build-essential
Не помню, есть ли оне на КД Ubuntu...

Если нет, искать пакеты вон там качать/устанавливать вручную.


Оффлайн WYSIWYG

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #48 : 06 Июнь 2006, 16:24:59 »
И снова ошибки.
sudo dpkg -i /home/anton/Desktop/Modem/hsfmodem_7.18.00.07full_i386.deb
Цитировать
(Чтение базы данных... на данный момент установлено 74473 файлов и каталогов.)
Подготовка к замене пакета hsfmodem 7.18.00.07full (используется файл .../hsfmodem_7.18.00.07full_i386.deb)...
Распаковывается замена для пакета hsfmodem...
Настраивается пакет hsfmodem (7.18.00.07full) ...
Conexant HSF softmodem driver, version 7.18.00.07full

If you need license keys, assistance or more information, please go to:
        http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

No pre-built modules for: Ubuntu-5.10 linux-2.6.12-9-386 i686

Trying to automatically build the driver modules...
(this requires a C compiler and proper kernel sources to be installed)

Where is the linux source build directory that matches your running kernel?
[/lib/modules/2.6.12-9-386/build]

Building modules for kernel 2.6.12-9-386, using source directory
/lib/modules/2.6.12-9-386/build. Please wait...

ERROR: Module build failed!
Please examine the log file "/tmp/hsfconfig-buildlog.txt" to determine why.
dpkg: не удалось обработать параметр hsfmodem (--install):
 подпроцесс post-installation script возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 hsfmodem

Вот содержимое hsfconfig-buildlog.txt
Цитировать
../modules/kernelcompiler.sh: gcc version 3.4.5 or similar is required to compile modules for your kernel
(cd /lib/modules/2.6.12-9-386/build && make "CNXT_KERNELSRC=/lib/modules/2.6.12-9-386/build" "M=/usr/lib/hsfmodem/modules" "CC=false" clean)
make[1]: Entering directory `/usr/src/linux-headers-2.6.12-9-386'
/usr/lib/hsfmodem/modules/kernelcompiler.sh: gcc version 3.4.5 or similar is required to compile modules for your kernel
make[1]: Leaving directory `/usr/src/linux-headers-2.6.12-9-386'
rm -rf *.o GPL/*.o *.ko GPL/*.ko *.mod.c GPL/*.mod.c .*.cmd GPL/.*.cmd .tmp_versions .tmp_versions  /lib/modules/2.6.12-9-386/build/.tmp_versions/hsfosspec.mod  /lib/modules/2.6.12-9-386/build/.tmp_versions/hsfserial.mod  /lib/modules/2.6.12-9-386/build/.tmp_versions/hsfengine.mod  /lib/modules/2.6.12-9-386/build/.tmp_versions/hsfpcibasic2.mod  /lib/modules/2.6.12-9-386/build/.tmp_versions/hsfmc97ich.mod  /lib/modules/2.6.12-9-386/build/.tmp_versions/hsfmc97via.mod  /lib/modules/2.6.12-9-386/build/.tmp_versions/hsfmc97ali.mod  /lib/modules/2.6.12-9-386/build/.tmp_versions/hsfmc97ati.mod  /lib/modules/2.6.12-9-386/build/.tmp_versions/hsfmc97sis.mod  /lib/modules/2.6.12-9-386/build/.tmp_versions/hsfsoar.mod
(cd /lib/modules/2.6.12-9-386/build && make "CNXT_KERNELSRC=/lib/modules/2.6.12-9-386/build" "M=/usr/lib/hsfmodem/modules" "CC=false" modules)
make[1]: Entering directory `/usr/src/linux-headers-2.6.12-9-386'
/usr/lib/hsfmodem/modules/kernelcompiler.sh: gcc version 3.4.5 or similar is required to compile modules for your kernel
  CC [M]  /usr/lib/hsfmodem/modules/mod_engine.o
make[2]: *** [/usr/lib/hsfmodem/modules/mod_engine.o] Error 1
make[1]: *** [_module_/usr/lib/hsfmodem/modules] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.12-9-386'
make: *** [all] Error 2
И что теперь делать?

Оффлайн WYSIWYG

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #49 : 09 Июнь 2006, 13:55:48 »
Лю-ю-ю-ю-ди! Отзовитесь!

bobrik

  • Гость
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #50 : 09 Июнь 2006, 15:03:21 »
gcc version 3.4.5 or similar is required to compile modules for your kernel - ни о чем не говорит? Ставь gcc 3.4

Оффлайн Psi

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #51 : 13 Июнь 2006, 18:25:29 »
вот запустил прогу для определения модема, вот что он выдал (у меня модем Zyxel Omni 56 PCL),
не могу узнать ан каком он чипсете.

=====================================================================
=              SYSTEM INFORMATION                                   =
=====================================================================
Date         : 6/13/2006
ListMdm Ver  : 1.6
Windows OS   : Microsoft Windows XP
Build Number : 2600

=====================================================================
=              RESULT OF MODEM QUERY                                =
=====================================================================
NUMBER OF MODEMS FOUND = 1

MODEM #1:
  PCI CONFIGURATION INFORMATION READ:
     VENDOR ID              : 134D
     DEVICE ID              : 7892
     SUBVENDOR ID           : 134D
     SUBDEVICE ID           : 0001
     REVISION ID            : 402

  DEDUCED INFORMATION:
     VENDOR NAME            : UNKNOWN
     DEVICE NAME            : UNKNOWN
     SUBVENDOR NAME         : UNKNOWN
     MODEM TYPE             : UNKNOWN
     WINXP INBUILD SUPPORT  : NO

Кто поможет ?

bobrik

  • Гость
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #52 : 13 Июнь 2006, 21:37:58 »
А чем помочь? Ubuntu не винда.

Оффлайн WYSIWYG

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #53 : 14 Июнь 2006, 16:26:29 »
Psi:
Модем на чипе PCTel. Собственно, делайте, что написано в  этой ветке, и, возможно, Вас ждёт успех. ;)
Цитата: bobrik
Ставь gcc 3.4
Откуда его взять?
Это оно? http://packages.ubuntulinux.org/dapper/devel/gcc-3.4

bobrik

  • Гость
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #54 : 14 Июнь 2006, 21:58:34 »
Да, это оно. Насколько с помню, надо будет указать переменную CC
У меня все прокатывало.

Оффлайн WYSIWYG

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #55 : 15 Июнь 2006, 12:41:42 »
Что за переменная СС и как её указывать? %)

bobrik

  • Гость
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #56 : 15 Июнь 2006, 21:51:06 »
Ты бы так попробовал собрать, может и не нужно ее указывать.

Оффлайн RedlinE

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #57 : 13 Ноябрь 2006, 21:05:29 »
Доброго времени суток господа!
Недавно поставил себе ubuntu 6.10! Возникла проблема с установкой модема ZyXEL Omni 56k PCI Plus, скачал pctel-0.9.7-9-rht-6_for_Ubuntu-2.6.15-23-386.tgz, установил, всё вроде бы встало... но соединиться немогу.

P.S Все выше написанный посты с уже читал...или с что то делаю не так или хз )

Оффлайн HBD

  • Новичок
  • *
  • Сообщений: 8
  • Ку ку !!!
    • Просмотр профиля
Re: ZyXEL Omni 56k PCI WinModem
« Ответ #58 : 16 Февраль 2009, 01:14:38 »
не хотелось вас  огорчать уважаемый Автор: RedlinE  но в примичании к Ubuntu драверу четко сказано
drivers suitable for use ONLY with Ubuntu kernel 2.6.15-23-386. именно в этом вакте вы должны были удастоверится до его установки подробнее тут http://linmodems.technion.ac.il/pctel-linux/pctel-ubuntu.txt

 

Страница сгенерирована за 0.078 секунд. Запросов: 22.