Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Заменил видеокарту - система не стартует.  (Прочитано 5879 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн wed

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • я вас подозреваю...
    • Просмотр профиля
Ubuntu 8.04
Карта Geforce 7600GS заменена на 8500GT. Монитор Samtron 19" crt.

При работе с Gf7600 драйвера не устанавливал, даже из репозитария. Т.е. как установил систему, так и работало. Разрешение экрана использовал 1024х768х75.
После замены видеокарты загрузка доходит до момента когда должно появиться окно вводи логина и в этот момент изображение "портиться", т.е. куча артефактов, цветных полос и т.п. самого окна логона не видно вовсе.  На клавиатуру и кнопку питания комп не реагирует, но курсор мыши двигается нормально.
Если xorg.conf скопировать из xorg.conf.failsafe, то система загружается нормально в разрешении 800х600.
При попытке изменить видеодрайвер с vesa на пропиретарный nvidia - всё повторяется снова.

Я так понимаю, что система пытается поставить максимальное разрешение (или частоту?), а видяха (или монитор?) его не держат.

Если воткнуть обратно 7600, то система стартует нормально с очень высоким разрешением. (1280х1024 кажется)

В виндовс видяха работает на ура во всех заявленных частотах.

Что делать?

PS: я с линуксом всего месяц....
А счастье было так близко....

Оффлайн ceval

  • Активист
  • *
  • Сообщений: 778
  • Минск, Беларусь
    • Просмотр профиля
    • On-line журнал o Linux
Re: Заменил видеокарту - система не стартует.
« Ответ #1 : 29 Апрель 2008, 09:12:02 »
выложи свой xorg, хотя и так понятно у тебя в разделе  Device прописанна старая карточка, попробуй подправить там

Оффлайн bucker

  • Участник
  • *
  • Сообщений: 171
    • Просмотр профиля
Re: Заменил видеокарту - система не стартует.
« Ответ #2 : 29 Апрель 2008, 09:38:34 »
Загрузись в безопасном режиме и выбери "Try to fix X-server"

Оффлайн wed

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • я вас подозреваю...
    • Просмотр профиля
Re: Заменил видеокарту - система не стартует.
« Ответ #3 : 29 Апрель 2008, 10:15:31 »
выложи свой xorg, хотя и так понятно у тебя в разделе  Device прописанна старая карточка, попробуй подправить там

В ксорге не прописана старая карта. Потому что я после установки системы ничего там не менял и драйвера не ставил. В секции  Device указана "Configured device". Так же и в разделе Monitor - "Configured Monitor".

В данный момент ксорг является копией xorg.conf.failsafe

Загрузись в безопасном режиме и выбери "Try to fix X-server"
Пробовал. Не помогает. Ничего не меняется.

И еще:

В ксорге проприсывал Driver "Vesa", добавлял субсекцию "дисплей" и прописывал модес "800х600" - грузится нормально, но естественно в 800х600. Выбрать другие разрешения в настройках не дает - их там просто нет. Менял монитор на "стандартный монитор 1024х768 и после перезагрузки история с зависанием повторялась. (напомню что в винде всё работает нормально).

И dpkg-reconfigure -plow xserver-xorg дает выбрать буфер, клаву, но нет выбора драйвера и разрешений... т.е. после выбора типа раскладки всё заканчивается.



Добавлено позже:

Загрузился в безопасном режиме. В настройках gdm.config включил автологон. Теперь судя по звуку окно логона проскакивает и зависает после звука логона...
« Последнее редактирование: 29 Апрель 2008, 10:24:32 от wed »
А счастье было так близко....

Blаze

  • Гость
Re: Заменил видеокарту - система не стартует.
« Ответ #4 : 29 Апрель 2008, 10:29:13 »
При работе с Gf7600 драйвера не устанавливал, даже из репозитария.
Вот в этом то и дело, свободный драйвер не любит новые карты. Установи nvidia-glx или nvidia-glx-new, а затем
sudo dpkg-reconfigure -phigh xserver-xorg.

По поводу "система не стартует": система то какраз стартует, не стартуют иксы.

Оффлайн wed

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • я вас подозреваю...
    • Просмотр профиля
Re: Заменил видеокарту - система не стартует.
« Ответ #5 : 29 Апрель 2008, 10:45:44 »
При работе с Gf7600 драйвера не устанавливал, даже из репозитария.
Вот в этом то и дело, свободный драйвер не любит новые карты. Установи nvidia-glx или nvidia-glx-new, а затем
sudo dpkg-reconfigure -phigh xserver-xorg.

По поводу "система не стартует": система то какраз стартует, не стартуют иксы.

В ксорге прописал драйвер Vesa и модес 800х600. Загрузился. (логон автоматом прошел). В "Драйвера устройств" отметил драйвер NVidia. Скачались и установились пакеты. Потребовалась перезагрузка. Сделал. После лого Nvidia  - черный экран и только мышиный курсор. Комп ни на что (кроме движения мыши) не реагирует.


PS: До установки драйвера Nvidia ставил страую карточку - комп загрузился в каком-то очень большом разрешении.

PPS: Наткнулся на вот это:
http://blogs.mail.ru/bk/fdsv/147D3E4C317ECC2C.html

Может в этом проблема? (пока проверить не могу)
« Последнее редактирование: 29 Апрель 2008, 10:53:18 от wed »
А счастье было так близко....

Оффлайн teop

  • Участник
  • *
  • Сообщений: 202
    • Просмотр профиля
Re: Заменил видеокарту - система не стартует.
« Ответ #6 : 29 Апрель 2008, 10:53:44 »
Поищите в сети на тему "nvidia black screen bug". Если не ошибаюсь, бывают проблемы с некоторыми картами восьмой серии, но вроде решаемые.

Blаze

  • Гость
Re: Заменил видеокарту - система не стартует.
« Ответ #7 : 29 Апрель 2008, 11:34:36 »
В ксорге ....
1) Загружаем систему, ждем этот самый черный экран после логотипа,
2) Ctrl+Alt+F1, логинимся,
3) Пишем sudo dpkg-reconfigure -phigh xserver-xorg4) Пишем sudo /etc/init.d/gdm restart5) Если в седьмом вирт. терминале (Ctrl+Alt+F7) не появилось окно логина, то возвращаемся в первый (Ctrl+Alt+F1) и изучаем содержимое Xorg.0.log nano /var/log/Xorg.0.logВыход из редактора nanо - Ctrl+X
6) Ошибки и xorg.conf постим сюда.

Оффлайн wed

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • я вас подозреваю...
    • Просмотр профиля
Re: Заменил видеокарту - система не стартует.
« Ответ #8 : 29 Апрель 2008, 11:44:46 »
В ксорге ....
1) Загружаем систему, ждем этот самый черный экран после логотипа,
2) Ctrl+Alt+F1, логинимся,
3) Пишем sudo dpkg-reconfigure -phigh xserver-xorg4) Пишем sudo /etc/init.d/gdm restart5) Если в седьмом вирт. терминале (Ctrl+Alt+F7) не появилось окно логина, то возвращаемся в первый (Ctrl+Alt+F1) и изучаем содержимое Xorg.0.log nano /var/log/Xorg.0.logВыход из редактора nanо - Ctrl+X
6) Ошибки и xorg.conf постим сюда.

Не пойдет.
1. При черном экране комп не реагирует на клавиатуру.
2. При загрузке в безопасном режиме делал уже dpkg-reconfigure -phigh xserver-xorg - никаких изменений.
А счастье было так близко....

Оффлайн fwhr

  • Старожил
  • *
  • Сообщений: 2104
    • Просмотр профиля
Re: Заменил видеокарту - система не стартует.
« Ответ #9 : 29 Апрель 2008, 12:02:41 »
простой вопрос: а ты проверил, что alt+F2-F6 не работают с "чёрным экраном", или просто сделал вывод о неработоспособности клавиатуры по другим признакам?
Обычно люди получают не то, что заслуживают, а то, что получилось... © Доктор Хауз

Оффлайн bucker

  • Участник
  • *
  • Сообщений: 171
    • Просмотр профиля
Re: Заменил видеокарту - система не стартует.
« Ответ #10 : 29 Апрель 2008, 12:25:30 »
Отцепить клаву от Х - Alt-SysRq-R

Оффлайн wed

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • я вас подозреваю...
    • Просмотр профиля
Re: Заменил видеокарту - система не стартует.
« Ответ #11 : 29 Апрель 2008, 12:34:12 »
простой вопрос: а ты проверил, что alt+F2-F6 не работают с "чёрным экраном", или просто сделал вывод о неработоспособности клавиатуры по другим признакам?

Проверил. Комп вообще ни на что не реагирует кроме мыши. Даже по кнопке power не выключается. Только ресетом.
« Последнее редактирование: 29 Апрель 2008, 12:47:29 от wed »
А счастье было так близко....

Оффлайн wed

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • я вас подозреваю...
    • Просмотр профиля
Re: Заменил видеокарту - система не стартует.
« Ответ #12 : 29 Апрель 2008, 12:39:07 »
Отцепить клаву от Х - Alt-SysRq-R

При черном экране не работает.
А счастье было так близко....

Оффлайн bucker

  • Участник
  • *
  • Сообщений: 171
    • Просмотр профиля
Re: Заменил видеокарту - система не стартует.
« Ответ #13 : 29 Апрель 2008, 12:50:04 »
А по сети (ssh) со стороны нет возможности войти?

Оффлайн wed

  • Автор темы
  • Участник
  • *
  • Сообщений: 110
  • я вас подозреваю...
    • Просмотр профиля
Re: Заменил видеокарту - система не стартует.
« Ответ #14 : 29 Апрель 2008, 12:52:16 »
А по сети (ssh) со стороны нет возможности войти?

Нет, домашний комп.
А счастье было так близко....

 

Страница сгенерирована за 0.118 секунд. Запросов: 22.