Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Zentyal проблема - ip камеры в другой подсети  (Прочитано 1091 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nonit0

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Всем привет.
Есть проблема с получением видео потока с ip камеры в другой подсети.
Ситуация такая.
Есть шлюз на Zentyal 3.2

Есть 3 сетевых интерфейса.
3 сетевых карты

eth0-wan static

eth1-lan-192.168.1.0/24 static
192.168.1.1 шлюз

eth2(но в админке в интерфейсах он называется erh4) - 192.168.2.0/24 static
192.168.2.20 шлюз

поднят dhcp на eth1 и eth2.
Имеется правило в фаерволе для внутренних сетей разрешающее все для всех.

Настроен http прокси, прозрачный для объектов сети eth1 и eth2

Основная локалка eth1 192.168.1.0/24 в ней около 160 устройств.
Отдельно добавил сетевую карту eth2 192.168.1.20, для сети камер видео наблюдения.
Сама проблема в том, что на клиентском компьютере сети 192.168.1.0/24 нет видео потока с камеры которая в другой подсети ее адрес 192.168.2.112, в то время на шлюзе к которому все это добро подключено все в порядке камера показывает.

Камера пингуется со всех сторон, со шлюза, из сети 192.168.1.0/24, и из 192.168.2.0/24. Все компьютеры и камеры адреса получают по dhcp.
Что пробовал.

Подключал ноут в сеть eth1 он получил ip 192.168.1.50, туда же подключаю камеру она получает адрес 192.168.1.37. Проверяю работает ли камера, захожу через браузер по адресу камеры ввожу логин пароль вижу картинку с камеры. Все в порядке.
Не меняя настроек, просто отключаю камеру и включаю в сеть eth2 вижу в zentyal камера получила ip 192.168.2.112. Беру тот же ноут, он так и остался на eth1 с ip 192.168.1.37, открываю браузер ввожу новый адрес камеры открывается страница камеры с логином и паролем, ввожу их, и вижу весь интерфейс управления камерой а картинки нет черный экран и ошибка кракозябрами посередине экрана где должна быть картинка, управление камерой и настройка работает.
Причем, после открываю браузер на шлюзе захожу на камеру и вижу картинку.
Вообще со шлюза открываются все камеры где бы они не находились, хоть в 192.168.2.0/24 хоть в 192.168.1.0/24, а вот с компьютеров работают только те камеры которые в одной сети с этим компом.

Убил целый вечер так и не разобрался.
Подскажите в чем может быть проблема?

 

Страница сгенерирована за 0.057 секунд. Запросов: 24.