Форум русскоязычного сообщества Ubuntu


Автор Тема: Ubuntu 12.04 - Windows 8.1  (Прочитано 1408 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Jen94

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Ubuntu 12.04 - Windows 8.1
« : 09 Май 2015, 01:22:47 »
Здравствуйте. После установки Ubuntu она не запускается, сразу стартует Windows 8.
Использовал программу boot-repair - без результатов.
Тогда зачем-тo поставил в настройках "Ubdate GRUB to its most recent version" и нажал Apply.
Несколько раз ввел в консоли то, что предложила программа.

Но теперь при каждом запуске Boot Repair выходит ошибка: apt-error detected. Please open a terminal then type (or copy-paste) the following command:

sudo chroot "/mnt/boot-sav/sda5" apt-get -f install

Then close this window.

Результат выполнения в консоли:
ubuntu@ubuntu:~$ sudo chroot "/mnt/boot-sav/sda5" apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  x11-apps python-packagekit python-libproxy sbsigntool telepathy-indicator
  folks-common libmtp9 telepathy-logger efibootmgr libxrandr-dev
  telepathy-gabble libxdamage-dev libdmapsharing-3.0-2 rhythmbox-data
  libsane-hpaio gir1.2-gmenu-3.0 libraw5 secureboot-db libdiscid0
  libmtp-runtime libxml2-utils libgpod-common python-reportlab libxfixes-dev
  gir1.2-gnomekeyring-1.0 python-piston-mini-client libtelepathy-logger2
  ubuntu-extras-keyring libgexiv2-1 empathy-common python-egenix-mxtools
  x11proto-xinerama-dev libxi-dev libslp1 libbsd0 telepathy-salut
  apturl-common libgpod4 apache2-mpm-prefork x11proto-randr-dev
  python-renderpm libxinerama-dev x11-session-utils shim libfolks25
  python-debtagshw libatk1.0-dev libmcrypt4 x11proto-fixes-dev
  libclass-isa-perl apt-xapian-index x11-xfs-utils libgtkspell-3-0
  x11proto-damage-dev libtelepathy-farstream2 ttf-freefont xinit
  libpango1.0-dev libswitch-perl xul-ext-ubufox libfs6 gir1.2-gudev-1.0
  libplrpc-perl libexiv2-11 libmtp-common libgrail5 libpackagekit-glib2-14
  libxcomposite-dev libmission-control-plugins0 app-install-data
  media-player-info gir1.2-launchpad-integration-3.0 libart-2.0-2
  libmusicbrainz3-6 libxft-dev x11proto-composite-dev
  software-center-aptdaemon-plugins libavahi-gobject0 libgtk2.0-dev
  libfolks-telepathy25 python-egenix-mxdatetime libmemcached6 libxcursor-dev
  telepathy-mission-control-5 hplip-data python-reportlab-accel libgadu3
  libgeocode-glib0 libprotobuf-c0 p11-kit libgee-0.8-2 libzeitgeist-2.0-0
  python3-aptdaemon.gtk3widgets libbamf3-2 libgstreamer-plugins-base1.0-0
  libgstreamer1.0-0 libtotem-plparser18 gstreamer1.0-plugins-base libarchive13
  dconf-cli libdconf1 python-oauthlib libaccounts-glib0 libfarstream-0.2-2
  libsignon-glib1 libtelepathy-farstream3 libtelepathy-logger3
  gstreamer1.0-pulseaudio libcamel-1.2-49 libical1a libgweather-3-6
  libmessaging-menu0 gir1.2-gstreamer-1.0 gir1.2-gst-plugins-base-1.0
  libgexiv2-2 libgrilo-0.2-1 libibus-1.0-5 libpackagekit-glib2-16
  gstreamer1.0-plugins-good gstreamer1.0-nice gstreamer1.0-x
  libgstreamer-plugins-good1.0-0 libgphoto2-6 libgphoto2-port10 libcolumbus1
  libcolumbus1-common libexiv2-13 libglew1.10 libharfbuzz-dev libharfbuzz-icu0
  libharfbuzz-gobject0 libnux-4.0-0 libglewmx1.10 libnux-4.0-common libraw10
  libwebp5 p11-kit-modules unity-scope-home unity-scopes-master-default
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  adwaita-icon-theme apache2 apache2-bin apache2-data apache2-mpm-prefork
  apache2-utils apt aptdaemon bash-completion cgmanager compiz-core
  compiz-plugins-default console-setup console-setup-linux dconf-cli dh-php5
  dh-python dmsetup eog folks-common fontconfig foomatic-db-engine
  gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0
  gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-pango-1.0
  gir1.2-rsvg-2.0 gir1.2-vte-2.91 git git-man glib-networking
  glib-networking-common glib-networking-services gnome-desktop3-data
  gnome-power-manager gnome-screensaver gnome-settings-daemon-schemas
  gobject-introspection gsettings-desktop-schemas gstreamer1.0-nice
  gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-pulseaudio
  gstreamer1.0-x ifupdown indicator-power indicator-session
  initramfs-tools-bin initscripts install-info keyboard-configuration
  klibc-utils libaccounts-glib0 libacl1 libalgorithm-c3-perl
  libalgorithm-diff-xs-perl libapparmor1 libapr1 libaprutil1
  libaprutil1-dbd-sqlite3 libaprutil1-ldap libapt-inst1.5 libapt-pkg4.12
  libarchive-extract-perl libarchive13 libatk-bridge2.0-0 libatk1.0-0
  libatk1.0-data libatk1.0-dev libatspi2.0-0 libattr1 libaudit-common
  libaudit1 libbamf3-2 libblkid1 libboost-filesystem1.55.0
  libboost-system1.55.0 libcairo-gobject2 libcairo-script-interpreter2
  libcairo2 libcairo2-dev libcamel-1.2-49 libcgi-fast-perl libcgi-pm-perl
  libclass-c3-perl libclass-c3-xs-perl libcolord2 libcolumbus1
  libcolumbus1-common libcompizconfig0 libcpan-meta-perl libcryptsetup4
  libdata-optlist-perl libdata-section-perl libdb5.3 libdbd-mysql-perl
  libdbi-perl libdconf1 libdecoration0 libdee-1.0-4 libdevmapper1.02.1
  libedit2 libexif-dev libexif12 libexiv2-13 libfarstream-0.2-2 libfcgi-perl
  libflac-dev libflac8 libfolks-telepathy25 libfolks25 libframe6 libgadu3
  libgail-3-0 libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libgdk-pixbuf2.0-dev libgee-0.8-2 libgeis1 libgeocode-glib0 libgexiv2-2
  libgirepository-1.0-1 libglew1.10 libglewmx1.10 libglib2.0-0 libglib2.0-bin
  libglib2.0-dev libglibmm-2.4-1c2a libgnome-desktop-3-10 libgomp1
  libgphoto2-6 libgphoto2-port10 libgrail6 libgraphite2-3 libgrilo-0.2-1
  libgstreamer-plugins-base1.0-0 libgstreamer-plugins-good1.0-0
  libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libgweather-3-6
  libgweather-common libharfbuzz-dev libharfbuzz-gobject0 libharfbuzz-icu0
  libharfbuzz0b libhpmud0 libibus-1.0-5 libical1a libicu52 libido3-0.1-0
  libimobiledevice4 libjson0 libklibc libkmod2 liblcms2-2
  liblightdm-gobject-1-0 liblocale-gettext-perl liblog-message-perl
  liblog-message-simple-perl liblzo2-2 libmediaart-1.0-0 libmessaging-menu0
  libmirclient8 libmircommon3 libmirprotobuf0 libmodule-build-perl
  libmodule-pluggable-perl libmodule-signature-perl libmount1 libmpdec2
  libmro-compat-perl libnotify4 libnux-4.0-0 libnux-4.0-common liborc-0.4-0
  libpackage-constants-perl libpackagekit-glib2-16 libpam-systemd
  libpango-1.0-0 libpango1.0-0 libpango1.0-dev libpangocairo-1.0-0
  libpangoft2-1.0-0 libpangox-1.0-0 libpangoxft-1.0-0 libparams-util-perl
  libpcre3 libpcre3-dev libpcrecpp0 libperl5.20 libplist2 libplymouth4
  libpod-latex-perl libpod-readme-perl libprotobuf-c0 libprotobuf9 libproxy1
  libproxy1-plugin-gsettings libproxy1-plugin-networkmanager libpython-dev
  libpython-stdlib libpython2.7 libpython2.7-dev libpython2.7-minimal
  libpython2.7-stdlib libpython3-stdlib libpython3.4-minimal
  libpython3.4-stdlib libraw10 libregexp-common-perl librsvg2-2
  librsvg2-common librsvg2-dev libsignon-glib1 libsmartcols1 libsnmp30
  libsoftware-license-perl libsoup2.4-1 libsqlite3-0 libsub-exporter-perl
  libsub-install-perl libtelepathy-farstream3 libtelepathy-glib0
  libtelepathy-logger3 libterm-readkey-perl libterm-ui-perl
  libtext-charwidth-perl libtext-iconv-perl libtext-soundex-perl
  libtext-template-perl libtotem-plparser18 libtracker-sparql-1.0-0
  libunity-protocol-private0 libunity-scopes-json-def-desktop libunity9
  libupower-glib3 liburl-dispatcher1 libusbmuxd2 libuuid-perl libvpx1
  libvte-2.91-0 libvte-2.91-common libwacom-common libwacom2
  libwayland-client0 libwayland-cursor0 libwebp5 libx11-6 libx11-dev
  libxfixes-dev libxfixes3 libxkbcommon0 libxml2 libxml2-dev
  libzeitgeist-2.0-0 lsb-base man-db mir-client-platform-mesa2 mount nautilus
  nautilus-data netbase p11-kit p11-kit-modules perl perl-base perl-modules
  php5-cli php5-common php5-curl php5-dev php5-gd php5-json php5-ldap
  php5-mysql pkg-php-tools plymouth plymouth-label printer-driver-hpijs
  printer-driver-pxljr python python-apt python-aptdaemon
  python-aptdaemon.gtk3widgets python-dev python-gi python-gi-cairo
  python-minimal python-oauthlib python2.7 python2.7-dev python2.7-minimal
  python3 python3-apt python3-aptdaemon python3-aptdaemon.gtk3widgets
  python3-dbus python3-defer python3-gi python3-minimal python3-pkg-resources
  python3.4 python3.4-minimal rename session-migration systemd systemd-shim
  sysvinit-utils unity-greeter unity-scope-home unity-scope-musicstores
  unity-scopes-master-default upower upstart-bin usbmuxd util-linux
Suggested packages:
  apache2-doc apache2-suexec-pristine apache2-suexec-custom aptitude synaptic
  wajig apt-doc foomatic-db-gutenprint git-daemon-run git-daemon-sysvinit
  git-doc git-el git-email git-gui gitk gitweb git-arch git-cvs git-mediawiki
  git-svn rdnssd powerd unity-system-compositor lrzip libcairo2-doc
  libclone-perl libmldbm-perl libsql-statement-perl exiv2 libgd-tools
  glew-utils libglib2.0-doc gphoto2 gtkam grilo-plugins-0.2 gstreamer1.0-tools
  libusbmuxd-tools liblcms2-utils libpango1.0-doc librsvg2-doc url-dispatcher
  groff nfs-common gnome-sushi perl-doc libterm-readline-gnu-perl
  libterm-readline-perl-perl libb-lint-perl libcpanplus-dist-build-perl
  libcpanplus-perl libfile-checktree-perl libobject-accessor-perl
  php5-user-cache dh-make hplip hpijs-ppds hplip-doc python-doc python-tk
  python-apt-dbg python-vte python-apt-doc python2.7-doc binfmt-support
  python3-doc python3-tk python3-venv python3-apt-dbg python-dbus-doc
  python3-dbus-dbg python3-setuptools python3.4-venv python3.4-doc systemd-ui
  bootlogd sash lightdm-remote-session-freerdp
  lightdm-remote-session-uccsconfigure remote-login-service util-linux-locales
Recommended packages:
  lintian unity-control-center-signon gnome-control-center-signon
  python3-aptdaemon.pkcompat packagekit-system-interface packagekit
  libwacom-bin php5-readline unity-settings-daemon indicator-keyboard
The following packages will be REMOVED:
  apache2.2-bin apache2.2-common apturl compiz compiz-gnome
  compiz-plugins-main-default empathy evolution-data-server gir1.2-rb-3.0
  gir1.2-webkit-3.0 gnome-control-center gnome-online-accounts gnome-session
  gnome-settings-daemon gnome-user-guide indicator-datetime libcairo-perl
  libfolks-eds25 libglib-perl libgnome-desktop-3-2 libgoa-1.0-0 libgtk2-perl
  libmetacity-private0 libpango-perl libperl5.14 libpurple0 librhythmbox-core5
  libsnmp15 libsyncdaemon-1.0-1 libwebkitgtk-3.0-0 libyelp0 metacity
  nautilus-sendto-empathy nautilus-share php-apc php5-mcrypt php5-memcache
  php5-memcached pidgin pidgin-libnotify pidgin-ppa python-aptdaemon.pkcompat
  python-ubuntu-sso-client python-ubuntuone-control-panel rhythmbox
  rhythmbox-mozilla rhythmbox-plugin-cdrecorder rhythmbox-plugin-magnatune
  rhythmbox-plugin-zeitgeist rhythmbox-plugins rhythmbox-ubuntuone shotwell
  telepathy-haze ubuntu-docs ubuntu-sso-client ubuntu-sso-client-gtk
  ubuntuone-client ubuntuone-client-gnome ubuntuone-control-panel unity
  unity-2d unity-common unity-lens-applications xorg xserver-xorg-lts-trusty
  xserver-xorg-video-all-lts-trusty xserver-xorg-video-modesetting-lts-trusty
  yelp zenity
The following NEW packages will be installed:
  adwaita-icon-theme apache2-bin apache2-data cgmanager console-setup-linux
  dconf-cli dh-php5 dh-python gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0
  gir1.2-vte-2.91 gnome-settings-daemon-schemas gstreamer1.0-nice
  gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-pulseaudio
  gstreamer1.0-x libaccounts-glib0 libalgorithm-c3-perl libapparmor1
  libapt-inst1.5 libarchive-extract-perl libarchive13 libatk-bridge2.0-0
  libaudit-common libaudit1 libbamf3-2 libboost-filesystem1.55.0
  libboost-system1.55.0 libcamel-1.2-49 libcgi-fast-perl libcgi-pm-perl
  libclass-c3-perl libclass-c3-xs-perl libcolord2 libcolumbus1
  libcolumbus1-common libcpan-meta-perl libdata-optlist-perl
  libdata-section-perl libdb5.3 libdconf1 libexiv2-13 libfarstream-0.2-2
  libfcgi-perl libgadu3 libgd3 libgee-0.8-2 libgeocode-glib0 libgexiv2-2
  libglew1.10 libglewmx1.10 libgnome-desktop-3-10 libgphoto2-6
  libgphoto2-port10 libgrail6 libgraphite2-3 libgrilo-0.2-1
  libgstreamer-plugins-base1.0-0 libgstreamer-plugins-good1.0-0
  libgstreamer1.0-0 libgweather-3-6 libharfbuzz-dev libharfbuzz-gobject0
  libharfbuzz-icu0 libharfbuzz0b libibus-1.0-5 libical1a libicu52
  libimobiledevice4 libkmod2 liblog-message-perl liblog-message-simple-perl
  liblzo2-2 libmediaart-1.0-0 libmessaging-menu0 libmirclient8 libmircommon3
  libmirprotobuf0 libmodule-build-perl libmodule-pluggable-perl
  libmodule-signature-perl libmpdec2 libmro-compat-perl libnux-4.0-0
  libnux-4.0-common libpackage-constants-perl libpackagekit-glib2-16
  libpam-systemd libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0
  libpangox-1.0-0 libpangoxft-1.0-0 libparams-util-perl libperl5.20 libplist2
  libplymouth4 libpod-latex-perl libpod-readme-perl libprotobuf-c0
  libprotobuf9 libpython-dev libpython-stdlib libpython2.7-dev
  libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib
  libpython3.4-minimal libpython3.4-stdlib libraw10 libregexp-common-perl
  libsignon-glib1 libsmartcols1 libsnmp30 libsoftware-license-perl
  libsub-exporter-perl libsub-install-perl libtelepathy-farstream3
  libtelepathy-logger3 libterm-ui-perl libtext-soundex-perl
  libtext-template-perl libtotem-plparser18 libtracker-sparql-1.0-0
  libunity-protocol-private0 libunity-scopes-json-def-desktop libupower-glib3
  liburl-dispatcher1 libusbmuxd2 libvte-2.91-0 libvte-2.91-common
  libwayland-client0 libwayland-cursor0 libwebp5 libxkbcommon0
  libzeitgeist-2.0-0 mir-client-platform-mesa2 p11-kit p11-kit-modules
  php5-json pkg-php-tools python-oauthlib python3 python3-apt
  python3-aptdaemon python3-aptdaemon.gtk3widgets python3-dbus python3-defer
  python3-gi python3-minimal python3-pkg-resources python3.4 python3.4-minimal
  rename session-migration systemd systemd-shim unity-scope-home
  unity-scopes-master-default upstart-bin
The following packages will be upgraded:
  apache2 apache2-mpm-prefork apache2-utils apt aptdaemon bash-completion
  compiz-core compiz-plugins-default console-setup dmsetup eog folks-common
  fontconfig foomatic-db-engine gir1.2-atk-1.0 gir1.2-freedesktop
  gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-pango-1.0 gir1.2-rsvg-2.0 git
  git-man glib-networking glib-networking-common glib-networking-services
  gnome-desktop3-data gnome-power-manager gnome-screensaver
  gobject-introspection gsettings-desktop-schemas ifupdown indicator-power
  indicator-session initramfs-tools-bin initscripts install-info
  keyboard-configuration klibc-utils libacl1 libalgorithm-diff-xs-perl libapr1
  libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libapt-pkg4.12
  libatk1.0-0 libatk1.0-data libatk1.0-dev libatspi2.0-0 libattr1 libblkid1
  libcairo-gobject2 libcairo-script-interpreter2 libcairo2 libcairo2-dev
  libcompizconfig0 libcryptsetup4 libdbd-mysql-perl libdbi-perl libdecoration0
  libdee-1.0-4 libdevmapper1.02.1 libedit2 libexif-dev libexif12 libflac-dev
  libflac8 libfolks-telepathy25 libfolks25 libframe6 libgail-3-0
  libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgdk-pixbuf2.0-dev libgeis1
  libgirepository-1.0-1 libglib2.0-0 libglib2.0-bin libglib2.0-dev
  libglibmm-2.4-1c2a libgomp1 libgtk-3-0 libgtk-3-bin libgtk-3-common
  libgweather-common libhpmud0 libido3-0.1-0 libjson0 libklibc liblcms2-2
  liblightdm-gobject-1-0 liblocale-gettext-perl libmount1 libnotify4
  liborc-0.4-0 libpango1.0-0 libpango1.0-dev libpcre3 libpcre3-dev libpcrecpp0
  libproxy1 libproxy1-plugin-gsettings libproxy1-plugin-networkmanager
  libpython2.7 librsvg2-2 librsvg2-common librsvg2-dev libsoup2.4-1
  libsqlite3-0 libtelepathy-glib0 libterm-readkey-perl libtext-charwidth-perl
  libtext-iconv-perl libunity9 libuuid-perl libvpx1 libwacom-common libwacom2
  libx11-6 libx11-dev libxfixes-dev libxfixes3 libxml2 libxml2-dev lsb-base
  man-db mount nautilus nautilus-data netbase perl perl-base perl-modules
  php5-cli php5-common php5-curl php5-dev php5-gd php5-ldap php5-mysql
  plymouth plymouth-label printer-driver-hpijs printer-driver-pxljr python
  python-apt python-aptdaemon python-aptdaemon.gtk3widgets python-dev
  python-gi python-gi-cairo python-minimal python2.7 python2.7-dev
  python2.7-minimal sysvinit-utils unity-greeter unity-scope-musicstores
  upower usbmuxd util-linux
161 upgraded, 161 newly installed, 69 to remove and 1147 not upgraded.
37 not fully installed or removed.
Need to get 0 B/96.6 MB of archives.
After this operation, 11.0 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Extracting templates from packages: 100%
Preconfiguring packages ...
dpkg: dependency problems prevent configuration of install-info:
 dpkg (1.17.25ubuntu1) breaks install-info (<< 5.1.dfsg.1-3~) and is installed.
  Version of install-info to be configured is 4.13a.dfsg.1-8ubuntu2.

dpkg: error processing package install-info (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)

Как решить проблему?
Версию системы нельзя обновлять (12.04 only), рабочие приложения предназначены именно для нее.

Оффлайн nom

  • Любитель
  • *
  • Сообщений: 76
    • Просмотр профиля
Re: Ubuntu 12.04 - Windows 8.1
« Ответ #1 : 09 Май 2015, 07:06:48 »
Похоже на то что нужно просто зайти с лайв-сд затем в терминале удалить груб и потом его установить заново, хотя если система чистая и не использовалась то можно и тупо переустановить ее целиком с ручным вариантом разметки диска где можно проконтролировать на какой именно диск будет устанавлен груб.

Оффлайн Jen94

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 12.04 - Windows 8.1
« Ответ #2 : 09 Май 2015, 07:10:29 »
Небольшое дополнение: ставил систему 2 раза, после первого раза при загрузке грузилась только Windows 8.1 и это не исправлялось boot repair.
Потом переустанавтл Ubuntu, запустил boot repair и все стало работать.
Затем поставил нужные прогр
аммы под Ubuntu, и все было ОК, но ей не хватало памяти, т.к. при установке отказался от файла подкачки. Зашел с установочного диска, создал новый раздел, по инструкции сделал его Swap. Но после этого опять слетел загрузчик Grub. Нужно его восстановить, о проблемах с этим я написал выше.
Обе ОС - 64 разрядные.

Пееустанавливать совсем не желательно, т.к. потрачено много времени на установку и настройку рабочего софта

Оффлайн nom

  • Любитель
  • *
  • Сообщений: 76
    • Просмотр профиля
Re: Ubuntu 12.04 - Windows 8.1
« Ответ #3 : 09 Май 2015, 08:18:48 »
Зачем же своп да и разделы с установочного диска создавать, в Ubuntu же есть и всегда была достаточно приличная графическая утилита в комплекте не помню уже точно как она называлась в 12.04 но сейчас и уже давно она именуется "Диски" в ней же все разделы монтируются и отключаются при необходимости, да и fdisk всегда присутствует. Если создавали с установочника той же самой процедурой что используется при установке системы то вы скорее всего убили свою систему, хотя возможно и только в mbr загрузочную запись затерли. Тогда здесь инструкция - http://help.ubuntu.ru/wiki/%D0%B2%D0%BE%D1%81%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_grub

Оффлайн Jen94

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 12.04 - Windows 8.1
« Ответ #4 : 09 Май 2015, 11:01:33 »
Спасибо. Ничего не стирал, сжал системный диск и создал новый раздел Swap. А о чем говорит такой вывод?

root@ubuntu:/var/lib/dpkg/info# apt-get purge install-info
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 cups-daemon : Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is to be installed
               Recommends: cups-browsed but it is not going to be installed
               Recommends: avahi-daemon (>= 0.6.31-3~) but 0.6.30-5ubuntu2.1 is to be installed
 dpkg : Breaks: fontconfig (< 2.11.1-0ubuntu5~) but 2.8.0-3ubuntu9.1 is to be installed
        Breaks: man-db (< 2.6.3-6~) but 2.6.1-2ubuntu1 is to be installed
 foomatic-db-engine : Depends: foomatic-filters (>= 4.0)
 info : Depends: install-info but it is not going to be installed
 init-system-helpers : Depends: perl-base (>= 5.20.1-3) but 5.14.2-6ubuntu2.4 is to be installed
 initramfs-tools : Depends: initramfs-tools-bin (>= 0.103ubuntu15) but 0.99ubuntu13.5 is to be installed
                   Depends: klibc-utils (>= 2.0-1~) but 1.5.25-1ubuntu2 is to be installed
 libapache2-mod-php5 : Depends: libdb5.3 but it is not going to be installed
                       Depends: libxml2 (>= 2.9.0) but 2.7.8.dfsg-5.1ubuntu4.11 is to be installed
                       Depends: apache2-api-20120211
                       Depends: apache2 (>= 2.4)
                       Depends: php5-common (= 5.6.4+dfsg-4ubuntu6) but 5.3.10-1ubuntu3.18 is to be installed
 printer-driver-pxljr : Depends: foomatic-filters (>= 4.0.0~bzr156)
 upstart : Depends: libjson0 (>= 0.10-1.1ubuntu1) but 0.9-1ubuntu1.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Оффлайн nom

  • Любитель
  • *
  • Сообщений: 76
    • Просмотр профиля
Re: Ubuntu 12.04 - Windows 8.1
« Ответ #5 : 09 Май 2015, 12:28:51 »
Пишет про нестыковки в зависимостях пакетов. Предлагает запустить apt-get -f install для исправления

Оффлайн Jen94

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 12.04 - Windows 8.1
« Ответ #6 : 09 Май 2015, 20:01:15 »
Но sudo apt-get -f install выдает ошибку, которую  я указал в певром сообщении темы. Помогите,  пожалуйста, это исправить...

Пользователь решил продолжить мысль [time]10 Май 2015, 00:02:25[/time]:
Кажется, я разобрался с источником проблемы.
Когда в Boot-repair выбрал пункт "Ubdate GRUB to its most recent version", было выдано предупреждение, что начинается загрузка некоторых файлов из репозитория Ubuntu 15.

Сейчас при запуске команды
sudo apt-get -f installвыдает:
dpkg (1.17.25ubuntu1) breaks install-info (<< 5.1.dfsg.1-3~) and is installed.
  Version of install-info to be configured is 4.13a.dfsg.1-8ubuntu2.
То есть требуется версия 4, а стоит 5.

! ! ! Остается единственный вопрос - как установить 4 версию вместо пятой?

Попробовал:
sudo apt-get update
sudo apt-get upgrade
Без результата

Никакие установки и удаления не запускаются, просит выполнить apt-get install -f.
Соответственно, эта строка тоже не выполняется:
sudo apt-get remove install-info
Пользователь решил продолжить мысль [time]10 Май 2015, 11:14:41[/time]:
И еще вопрос: можно ли через Windows поставить какой-нибудь загрузчик (не Grub), который позволит загрузить Ubuntu?

Пользователь решил продолжить мысль 10 Май 2015, 10:16:17:
И еще вопрос: можно ли через Windows поставить какой-нибудь загрузчик (не Grub), который позволит загрузить Ubuntu?
« Последнее редактирование: 10 Май 2015, 10:16:17 от Jen94 »

Оффлайн Jen94

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 12.04 - Windows 8.1
« Ответ #7 : 10 Май 2015, 22:42:48 »
Решил проблему так:
1. Перешел в каталог с установочными файлами:
cd /var/cache/apt/archives2. Посмотрел список пакетов:
dir3. Установил те, на которые ругались установщики. Команда установки:
sudo dpkg -i DEB_PACKAGE_NAME.deb4. Запустил установки и исправления:
sudo apt-get install -f
sudo apt-get update
sudo apt-get upgrade -f

 

Страница сгенерирована за 0.098 секунд. Запросов: 24.