Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Установка curl через apt-get  (Прочитано 18184 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн Zerratul

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Установка curl через apt-get
« : 21 Май 2015, 17:28:48 »
У меня не получается установить curl, пишет что зависимости не удовлетворены.

ghost16@server16:~/web$ sudo apt-get install curl

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for ghost16:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 curl : Зависит: libcurl3 (= 7.26.0-1+wheezy13) но 7.26.0-1+wheezy2 будет установлен
 libesd0:i386 : Зависит: esound-common:i386 (= 0.2.41-10) но он не может быть установлен
 libfontconfig1:i386 : Зависит: fontconfig-config:i386 (= 2.9.0-7.1) но он не может быть установлен
 libgphoto2-2:i386 : Зависит: libgd2-xpm:i386 (>= 2.0.36~rc1~dfsg) но он не может быть установлен
                     Рекомендует: udev:i386 (>= 0.175) но он не может быть установлен
                     Рекомендует: libgphoto2-l10n:i386 (>= 2.4.14-2) но он не может быть установлен
 libopenal1:i386 : Зависит: libopenal-data:i386 (= 1:1.14-4) но он не может быть установлен
 libpam0g:i386 : Зависит: debconf:i386 (>= 0.5) но он не может быть установлен или
                                 debconf-2.0:i386 но он не может быть установлен
 libsane:i386 : Зависит: adduser:i386 (>= 3.47) но он не может быть установлен
                Зависит: libsane-common:i386 (= 1.0.22-7.4) но он не может быть установлен
                Зависит: udev:i386 (>= 0.88-1) но он не может быть установлен или
                                makedev:i386 (>= 2.3.1-58) но он не может быть установлен
                Зависит: acl:i386 (>= 2.2.49-4) но он не может быть установлен
                Рекомендует: libsane-extras:i386 (>= 1.0.22.1) но он не может быть установлен
                Рекомендует: sane-utils:i386 (>= 1.0.22-7.4) но он не может быть установлен
 libssl1.0.0:i386 : Зависит: debconf:i386 (>= 0.5) но он не может быть установлен или
                                    debconf-2.0:i386 но он не может быть установлен
 libts-0.0-0:i386 : Зависит: tsconf:i386 но он не может быть установлен
 libuuid1:i386 : Зависит: passwd:i386 но он не может быть установлен
                 Рекомендует: uuid-runtime:i386 но он не может быть установлен
 libx11-6:i386 : Зависит: libx11-data:i386 но он не может быть установлен
 odbcinst1debian2:i386 : Зависит: odbcinst:i386 но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
ghost16@server16:~/web$
Правильно ли я понимаю что нужно подключить репозиторий (то-есть прописать в файле /etc/apt/sources.list ссылку на программу curl), если да то подскажите какой именно текст туда писать. Спасибо.

symon2014

  • Гость
Re: Установка curl через apt-get
« Ответ #1 : 21 Май 2015, 17:39:37 »
Правильно нажать цифру "1" и "Enter".

Оффлайн Zerratul

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Установка curl через apt-get
« Ответ #2 : 21 Май 2015, 17:41:37 »
ghost16@server16:~$ 1
-bash: 1: команда не найдена

аспирин

  • Гость

symon2014

  • Гость
Re: Установка curl через apt-get
« Ответ #4 : 21 Май 2015, 17:47:27 »
Zerratul,
Я имел в виду не команду в терминале. В первом посте предлагалось 3 варианта ответов, там надо было нажать 1 и enter .

Оффлайн Zerratul

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Установка curl через apt-get
« Ответ #5 : 21 Май 2015, 17:53:59 »
Спасибо, в итоге curl поставился (я прописал sudo apt-get -f install)
ghost16@server16:~$ sudo apt-get -f install     
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Пакеты, которые будут УДАЛЕНЫ:
  freeglut3:i386 ia32-libs-i386:i386 lesstif2:i386 libaudio2:i386 libcurl3:i386 libdirectfb-1.2-9:i386 libesd0:i386
  libfltk1.1:i386 libfontconfig1:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386 libgphoto2-2:i386 libopenal1:i386
  libpam0g:i386 libpulse0:i386 libsane:i386 libsdl1.2debian:i386 libsm6:i386 libssl1.0.0:i386 libts-0.0-0:i386
  libuuid1:i386 libx11-6:i386 libx11-xcb1:i386 libxaw7:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386
  libxext6:i386 libxfixes3:i386 libxft2:i386 libxi6:i386 libxinerama1:i386 libxmu6:i386 libxmuu1:i386 libxp6:i386
  libxpm4:i386 libxrandr2:i386 libxrender1:i386 libxss1:i386 libxt6:i386 libxtst6:i386 libxv1:i386 libxxf86vm1:i386
  odbcinst1debian2:i386 xaw3dg:i386
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 45 пакетов, и 163 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
После данной операции, объём занятого дискового пространства уменьшится на 34,0 MB.
Хотите продолжить [Д/н]? y
(Чтение базы данных … на данный момент установлено 45525 файлов и каталогов.)
Удаляется пакет ia32-libs-i386 …
Удаляется пакет libsane:i386 …
Удаляется пакет libgphoto2-2:i386 …
Удаляется пакет freeglut3:i386 …
Удаляется пакет lesstif2:i386 …
Удаляется пакет libaudio2:i386 …
Удаляется пакет libcurl3:i386 …
Удаляется пакет libsdl1.2debian:i386 …
Удаляется пакет libdirectfb-1.2-9:i386 …
Удаляется пакет libesd0:i386 …
Удаляется пакет libfltk1.1:i386 …
Удаляется пакет libxft2:i386 …
Удаляется пакет libfontconfig1:i386 …
Удаляется пакет libglu1-mesa:i386 …
Удаляется пакет libgl1-mesa-glx:i386 …
Удаляется пакет libopenal1:i386 …
Удаляется пакет libpam0g:i386 …
Удаляется пакет libpulse0:i386 …
Удаляется пакет libxaw7:i386 …
Удаляется пакет xaw3dg:i386 …
Удаляется пакет libxmu6:i386 …
Удаляется пакет libxt6:i386 …
Удаляется пакет libsm6:i386 …
Удаляется пакет libssl1.0.0:i386 …
Удаляется пакет libts-0.0-0:i386 …
Удаляется пакет libuuid1:i386 …
Удаляется пакет libxcursor1:i386 …
Удаляется пакет libxxf86vm1:i386 …
Удаляется пакет libxtst6:i386 …
Удаляется пакет libx11-xcb1:i386 …
Удаляется пакет libxp6:i386 …
Удаляется пакет libxdamage1:i386 …
Удаляется пакет libxfixes3:i386 …
Удаляется пакет libxi6:i386 …
Удаляется пакет libxv1:i386 …
Удаляется пакет libxcomposite1:i386 …
Удаляется пакет libxrandr2:i386 …
Удаляется пакет libxpm4:i386 …
Удаляется пакет libxrender1:i386 …
Удаляется пакет libxss1:i386 …
Удаляется пакет libxinerama1:i386 …
Удаляется пакет libxext6:i386 …
Удаляется пакет libxmuu1:i386 …
Удаляется пакет libx11-6:i386 …
Удаляется пакет odbcinst1debian2:i386 …
Но он удалил какие то пакеты, и я немного волнуюсь, не сломалась ли в результате этого какай нибудь другая программа которые эти пакеты использует?

аспирин

  • Гость
Re: Установка curl через apt-get
« Ответ #6 : 21 Май 2015, 17:57:15 »
Как это вы так установили :2funny: 

symon2014

  • Гость
Re: Установка curl через apt-get
« Ответ #7 : 21 Май 2015, 18:00:22 »
аспирин,
Ни себе ф..а установка. Мне тоже интересно.

Оффлайн Zerratul

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Установка curl через apt-get
« Ответ #8 : 21 Май 2015, 18:03:57 »
ну в плане я потом sudo apt-get install curl сделал и на этот раз оно заработало

symon2014

  • Гость
Re: Установка curl через apt-get
« Ответ #9 : 21 Май 2015, 18:09:19 »
Zerratul,
Может и лишний совет, но я бы после этого выполнил 2 команды -
sudo apt-get update и sudo apt-get dist-upgrade.

Оффлайн Zerratul

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Установка curl через apt-get
« Ответ #10 : 21 Май 2015, 18:32:58 »
спасибо

 

Страница сгенерирована за 0.094 секунд. Запросов: 22.