Форум русскоязычного сообщества Ubuntu


Автор Тема: Платина: проблемы с найтройкой LAMP из исходников  (Прочитано 1202 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн n0_way

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Привет всем, радую очередной платиной, но ничего поделать не могу, так как решений именно такой ситуации как у меня нет.

Собсвтенно:
ubuntu 12.04
Была задача настроить lamp из исходников.
Так как я новичок, я что-то там навертел с апачом, поставленным с иходников и, видимо с кривыми опциями, да так, что он не то что не запсукается, так он и устанавливаться толком не хочет.

Пытаюсь запустить:
@:~/httpd-2.4.12# invoke-rc.d apache2 start
invoke-rc.d: unknown initscript, /etc/init.d/apache2 not found.

Пытаюсь установить пакет, собранный checkinstall'ом (за мейк инсталл мне обещали оторвать руки друзья). Но и он не помог.

@:~/httpd-2.4.12# dpkg --force-overwrite -i httpd_2.4.12-1_amd64.deb
(Reading database ... 67933 files and directories currently installed.)
Preparing to replace httpd 2.4.12-1 (using httpd_2.4.12-1_amd64.deb) ...
Unpacking replacement httpd ...
Setting up httpd (2.4.12-1) ...


Алсоу, папки /etc/apache2 нет.
Как мне ее восстановить? Там же все конфиги должны лежать, переустановка из сурца не помогает.
Сильно только не бейте, я четвертый день только на убунте, а работу работать надо.

Каких-то выходов найти не могу, у меня задача именно из исходников все собрать.

Или ничего, кроме как apt-get не поможет?
Тогда же вроде весь мой LAMP не будет работать, так как мускуль и nginx у меня из сурцов.




Пользователь решил продолжить мысль [time]03 Июль 2015, 13:03:43[/time]:
Нагуглил про необходимость удалить apache2.2-common.

Ищем, находим, удаляем, ничего не получаем.


@:/etc/init.d# [b]whereis apache2.2-common[/b]
apache2: /usr/lib/apache2 /usr/include/apache2 /usr/local/apache2 /usr/share/apache2
@:/etc/init.d# [b]sudo apt-get --purge remove apache2.2-common[/b]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package apache2.2-common is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
root@48788:/etc/init.d#


Видимо, только через apt-get либо aptitude можно решить мою проблему?
« Последнее редактирование: 06 Июль 2015, 14:49:27 от nowaytogetout »

Оффлайн SvMidi

  • Активист
  • *
  • Сообщений: 815
    • Просмотр профиля
Тебе с какими то флагами надо собрать или просто прихоть какая то?
Я знаю только то, что ничего не знаю, остальные не знают и этого.

Оффлайн n0_way

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Тебе с какими то флагами надо собрать или просто прихоть какая то?

Должен слушать порт 8080, использовать php как mod_php, быть сопряженным c необходимыми пакетами.
Но к флагам это, вроде, отношения не имеет, верно?

Пользователь решил продолжить мысль [time]03 Июль 2015, 13:48:25[/time]:
На всякий пожарный:

# ls /etc/httpd
conf

и

# file /etc/init.d/httpd
/etc/init.d/httpd: ERROR: cannot open `/etc/init.d/httpd' (No such file or directory)

Пользователь решил продолжить мысль 03 Июль 2015, 13:55:10:
Далее еще смешнее: Удалил мускуль, nginx, решил заново все пилить.

./configure --prefix=/usr/local/mysql --enable-assembler --with-mysqld-ldflags=-all-static

./configure: No such file or directory

WTF?
« Последнее редактирование: 03 Июль 2015, 13:55:10 от nowaytogetout »

Оффлайн SvMidi

  • Активист
  • *
  • Сообщений: 815
    • Просмотр профиля
Должен слушать порт 8080, использовать php как mod_php, быть сопряженным c необходимыми пакетами.
Но к флагам это, вроде, отношения не имеет, верно?
И какой тогда смысл собирать из исходников? Это же не FreeBSD.
/etc/init.d/apache2 not found. он говорит потому, что в пакете из репозитария лежит скрипт который создаёт пускач

# Automatically added by dh_installinit
if [ -x "/etc/init.d/apache2" ]; then
update-rc.d apache2 defaults 91 09 >/dev/null   
fi
if [ -x "/etc/init.d/apache2" ] || [ -e "/etc/init/apache2.conf" ]; then
if [ -n "$2" ]; then
_dh_action=restart
else
_dh_action=start
fi
invoke-rc.d apache2 $_dh_action || true
fi
я так понимаю, ты этого не делал, как и многое другое.
Покажи хоть, что насобирал.
« Последнее редактирование: 03 Июль 2015, 15:23:09 от SvMidi »
Я знаю только то, что ничего не знаю, остальные не знают и этого.

Оффлайн n0_way

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Спасибо за ответ!)

Решил все с нуля, по этому гайду: http://keping.me/compile-and-install-lamp-from-source-on-ubuntu-12-10/
Запоролся на установке апача,
ERROR: configure: error: Bundled APR requested but not found at ./srclib/. Download and unpack the corresponding apr and apr-util packages to ./srclib/.
Ничего из указанного тут http://keping.me/2013-3-13-2/ не помогло, и копировал APR, и распаковывал в папку scrlib, толку ноль, выдает ошибку


:/usr/local/src/httpd-2.4.4# sudo ./configure --prefix=/usr/local/apache2 --sysconfdir=/etc/httpd --with-z=/usr/local/zlib/ --with-included-apr --disable-userdir --enable-so --enable-deflate=shared --enable-expires=shared --enable-rewrite=shared --enable-static-support --with-apr
checking for chosen layout... Apache
checking for working mkdir -p... yes
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
configure:
configure: Configuring Apache Portable Runtime library...
configure:
configure: error: Bundled APR requested but not found at ./srclib/. Download and unpack the corresponding apr and apr-util packages to ./srclib/.
@:/usr/local/src/httpd-2.4.4#

Уже не знаю, что делать.


UPD:

http://qnalist.com/questions/1061227/users-httpd-unable-to-build-2-4-because-bundled-apr-not-found-freebsd-9-0 кажется помогло. пока делается ./configure, жду.
« Последнее редактирование: 06 Июль 2015, 13:19:02 от nowaytogetout »

symon2014

  • Гость
nowaytogetout, извини за вмешательство, удалить бывает сложнее чем поставить. если удалял апач - осталось папочка в наутилус - скрытых папках(.apache2), ну и всякие прибамбасы(ubuntu-tweak   - параметры пакетов). Список большой(или не очень).

Оффлайн n0_way

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Апач встал, вроде работает  8)
Да и вмешательство на моем этапе знакомства с системой мне только на пользу пойдет.

Теперь проблема с мускулем, не хочет ставиться ни в какую, вот что выдает:

Linking CXX executable mysqld
collect2: ld returned 1 exit status
make[2]: *** [sql/mysqld] Error 1
make[1]: *** [sql/CMakeFiles/mysqld.dir/all] Error 2
make: *** [all] Error 2
root@48788:/usr/local/src/mysql-5.6.10#


Пользователь решил продолжить мысль 06 Июль 2015, 16:27:10:
nowaytogetout, извини за вмешательство, удалить бывает сложнее чем поставить. если удалял апач - осталось папочка в наутилус - скрытых папках(.apache2), ну и всякие прибамбасы(ubuntu-tweak   - параметры пакетов). Список большой(или не очень).


Алсоу, кажется, все придется опять переделывать. Как правильно удалять мускуля, Apache и nginx?
Буду, короче делать, все через apt-get install, надоело мозги насиловать этой бредятиной с компилированием и тоннами ошибок, несмотря на строгое слодование мануалу.
« Последнее редактирование: 06 Июль 2015, 16:27:10 от nowaytogetout »

Оффлайн n0_way

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Пересобираю заново, создам новую тему.
При необходимости.

Просто нужно было пользоваться свежими версиями софта и головой думать
« Последнее редактирование: 07 Июль 2015, 17:49:24 от nowaytogetout »

 

Страница сгенерирована за 0.102 секунд. Запросов: 22.