Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Не работает статический IP, по dhcp работает.  (Прочитано 1441 раз)

0 Пользователей и 1 Гость просматривают эту тему.

RBV

  • Автор темы
  • Гость
Доброго времени суток!
Столкнулся с такой проблемой. Ubuntu server 14.04.2 LTS установленный на виртуалку (hyperv win2008), при настройке сетевого интерфейса для получения ip по dhcp всё работает. Как только добавляю статический адрес интернет пропадает:-( Если добавляю статику с адресом который был выдан dhcp всё работает. Куда копать незнаю...

Днс указываю как адрес роутера 192.168.1.1, 8.8.8.8 тоже не помогает. 192.168.1.1 не пингуется.
На сетевой карточке интернет есть (2008 hyperv)

/etc/network/interfaces
(Нажмите, чтобы показать/скрыть)

/etc/resolv.conf
(Нажмите, чтобы показать/скрыть)

route -n
(Нажмите, чтобы показать/скрыть)

К примеру если по dhcp получу адрес 192.168.1.224 при котором всё работает и впишу его в статический начинает работать как статика!
Где копать?

Вот еще

Когда пингую адрес роутера 192.168.1.1 получаю это

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 20 Июль 2015, 09:31:22 от RBV »

Оффлайн _art_

  • Активист
  • *
  • Сообщений: 377
    • Просмотр профиля
Как вариант решения (не факт что поможет):

1) В /etc/resolv.conf прописать первой строкой nameserver 127.0.0.1

2) В /etc/network/interfaces добавить директиву dns-search

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
RBV, а что в Вашем понимании интернет пропадает?
Дайте диагностику сети при статике и при динамике
ip a; ip r
ping -c 2 192.168.1.1
nslookup ya.ru
nslookup ya.ru 8.8.8.8
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

RBV

  • Автор темы
  • Гость
Прошу прощения :uglystupid2: Моя ошибка была в настройках гипервизора. Спасибо за ответы! Тупанул я, надо поспать!!!

 

Страница сгенерирована за 0.08 секунд. Запросов: 24.