Форум русскоязычного сообщества Ubuntu


Автор Тема: Как узнать версию программы(х32 х64) в репозитории  (Прочитано 2251 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ztm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Я хочу установить Sublime text 3 из репозитория разработчика ppa:webupd8team/sublime-text-3
У них на сайте есть 32bit и 64bit версия. Как узнать, какая версия в репозитории и возможно ли ее выбрать вручную?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13637
  • Xubuntu 18.04
    • Просмотр профиля
ztm,
Да просто зайдите на страничку репозитория и посмотрите.

https://launchpad.net/~webupd8team/+archive/ubuntu/sublime-text-3
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн ztm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
ztm,
Да просто зайдите на страничку репозитория и посмотрите.

https://launchpad.net/~webupd8team/+archive/ubuntu/sublime-text-3
Да был я там, только не увидел где там указывается 32 или 64 бита версия. Если есть обе, то как выбрать при установке через apt(в консоли)?

Оффлайн arkellyga

  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
ztm,
Да просто зайдите на страничку репозитория и посмотрите.

https://launchpad.net/~webupd8team/+archive/ubuntu/sublime-text-3
Да был я там, только не увидел где там указывается 32 или 64 бита версия. Если есть обе, то как выбрать при установке через apt(в консоли)?
Могу ошибаться,но Ubuntu должна сама подхватить нужную версию под разрядность Вашего компьютера.

Оффлайн ztm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Могу ошибаться,но Ubuntu должна сама подхватить нужную версию под разрядность Вашего компьютера.
Но, суть в том, что хотелось бы этот выбор делать мне.
ztm, для какой версии нужно?
У меня 14.04 х64. Сейчас хочу х64. Но вдруг захочу переустановить х32.
Поэтому хотел бы знать:
1 Как узнать версии в репозитории?
2 Как выбрать вручную?

Оффлайн arkellyga

  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Могу ошибаться,но Ubuntu должна сама подхватить нужную версию под разрядность Вашего компьютера.
Но, суть в том, что хотелось бы этот выбор делать мне.
ztm, для какой версии нужно?
У меня 14.04 х64. Сейчас хочу х64. Но вдруг захочу переустановить х32.
Поэтому хотел бы знать:
1 Как узнать версии в репозитории?
2 Как выбрать вручную?
Если не секрет,а зачем вам х32?

Оффлайн ztm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Если не секрет,а зачем вам х32?
Мне нужна скорее не х32, а знание как выбрать то, что мне нужно. В данном случае мне х32 не особо нужна, но, я думаю, вы сталкивались с проблемами в работе х64 версий(или 32). Например у меня была проблема с Chrome x64, ловил ошибку связанную с памятью(конкретнее уже не помню). Поэтому хочу знать как мне выбирать.
http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu/dists/trusty/main/
Спасибо огромное за ссылку, я уже даже нашел как к ней добраться. Осталось узнать, как мне выбрать версию, используя APT.

alang

  • Гость
Да был я там, только не увидел где там указывается 32 или 64 бита версия.

А там и не указывается. Там универсальный установщик sublime-text-installer_3083-1~webupd8~0_all.deb. Разрядность, скорей всего, подхватывается автоматически в процессе установки. Хочешь выбирать сам, качай непосредственно с сайта. Там, в ppa, к слову, есть ссылка. Тебе, видно, глаза чуть выше в падлу поднять.

Оффлайн ztm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Да был я там, только не увидел где там указывается 32 или 64 бита версия.

А там и не указывается. Там универсальный установщик sublime-text-installer_3083-1~webupd8~0_all.deb. Разрядность, скорей всего, подхватывается автоматически в процессе установки. Хочешь выбирать сам, качай непосредственно с сайта. Там, в ppa, к слову, есть ссылка. Тебе, видно, глаза чуть выше в падлу поднять.
Не думаю, что "в падлу" - корректное, в данном случае, высказывание, ибо если бы вам не было трудно поднять глаза выше, к моему первому сообщению, то вы, несомненно, заметили б, что я был у них на сайте и знаю об этом.
У них на сайте есть 32bit и 64bit версия.
А меня интересует вопрос о возможности ручного выбора версии из репозитория, используя APT.

alang

  • Гость
несомненно, заметили б, что я был у них на сайте и знаю об этом.

В таком случае, эта тема вообще не имеет смысла: вот сайт, вот выбор; хочешь - пирожное 32, хочешь - морожное 64. В чем вопрос-то? Установщик делает то же самое: идет на сайт и выбирает версию исходя из разрядности твоей системы. Скорей всего. Более подробно надо спрашивать у мэйнтейнера.

Оффлайн arkellyga

  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Качаете тогда с оф.сайта и устанавливаете :-\ Ибо апт скорее всего сам относительно разрядности поставит х64

Оффлайн ztm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
В таком случае, эта тема вообще не имеет смысла: вот сайт, вот выбор; хочешь - пирожное 32, хочешь - морожное 64. В чем вопрос-то? Установщик делает то же самое: идет на сайт и выбирает версию исходя из разрядности твоей системы. Скорей всего. Более подробно надо спрашивать у мэйнтейнера.
Установщик делает выбор сам, а на сайте делаю его я, а это далеко не одно и то же. Я хочу поставить нужную мне версию из репозитория и обновляться через apt, а не периодически заходить на сайт разработчика, ожидая обновлений. А если таких программ будет несколько, то мне придется периодически заходить на все их сайты.
APT, как мне кажется, мощная программа, а я с ней не знаком, поэтому и спрашиваю тут, у более осведомленных людей: смогу ли я с помощью apt получить желаемые результаты?

Оффлайн arkellyga

  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
В таком случае, эта тема вообще не имеет смысла: вот сайт, вот выбор; хочешь - пирожное 32, хочешь - морожное 64. В чем вопрос-то? Установщик делает то же самое: идет на сайт и выбирает версию исходя из разрядности твоей системы. Скорей всего. Более подробно надо спрашивать у мэйнтейнера.
Установщик делает выбор сам, а на сайте делаю его я, а это далеко не одно и то же. Я хочу поставить нужную мне версию из репозитория и обновляться через apt, а не периодически заходить на сайт разработчика, ожидая обновлений. А если таких программ будет несколько, то мне придется периодически заходить на все их сайты.
APT, как мне кажется, мощная программа, а я с ней не знаком, поэтому и спрашиваю тут, у более осведомленных людей: смогу ли я с помощью apt получить желаемые результаты?
Сам не углубленно линукс изучал.Вопрос подкину спецам на твою тему.Если установить эту программу вручную,а затем добавить в соурс.лист ссылку на репозиторий,а затем переодически выполнять команду apt-get upgrade,то будет ли команда обновлять текущую установленную 32-х битную версию,иль нет?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13637
  • Xubuntu 18.04
    • Просмотр профиля
ztm,
Цитировать
а был я там, только не увидел где там указывается 32 или 64 бита версия. Если есть обе, то как выбрать при установке через apt(в консоли)?
Выбрать просто. Надо указать после имени пакета :i386, если вам нужен 32-битный пакет на 64-битной системе.
Но причины это делать я не могу себе представить.
Я в личке не консультирую. Вопросы задавайте на форуме.


 

Страница сгенерирована за 0.099 секунд. Запросов: 22.