Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: "Обычно это означает , что ваши установленные пакеты имют нераз. зависимости"  (Прочитано 3877 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн goodcucumber

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Ну вот нужно мне было установить tor браузер, делала все по инструкции на официальном сайте tor , выдало ошибку и я забил на это дело . Через какое то время появился знак кирпича и при нажатии выдает следующее :Произошла ошибка . Пожалуйста, запустите менеджер пакетов из меню Система>Администрирование, или введите команду sude atp-get install -f в терминале , что бы увидеть , что произошло и исправить ошибку . Ошибка:BrokenCount > 0 . Обычно это означает , что ваши установленные пакеты имеют неразрешенные зависимости. При вводе команды sudo apt-get install -f выдает это:
artem@artem:~$ sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  tor
Предлагаемые пакеты:
  mixmaster xul-ext-torbutton socat tor-arm apparmor-utils
НОВЫЕ пакеты, которые будут установлены:
  tor
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 0 B/745 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 2 691 kB.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 201196 файлов и каталогов.)
Preparing to unpack …/tor_0.2.4.27-1build0.14.04.1_i386.deb ...
Unpacking tor (0.2.4.27-1build0.14.04.1) ...
dpkg: error processing archive /var/cache/apt/archives/tor_0.2.4.27-1build0.14.04.1_i386.deb (--unpack):
 попытка перезаписать «/usr/bin/tor», который уже имеется в пакете tor-browser 3.5.4
dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)
Processing triggers for ureadahead (0.100.0-16) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/tor_0.2.4.27-1build0.14.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Помогите решить проблему , не дает ни устанавливать , ни обновляться .


Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
goodcucumber,
Цитировать
делала все по инструкции на официальном сайте tor
подробней можно?( насколько я знаю там устанавливать ничего не нужно, скачал архив, распаковал, пользуешься)

Оффлайн goodcucumber

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля


You need to add the following entry in /etc/apt/sources.list or a new file in /etc/apt/sources.list.d/:

    deb http://deb.torproject.org/torproject.org lucid main
    deb-src http://deb.torproject.org/torproject.org lucid main

Then add the gpg key used to sign the packages by running the following commands at your command prompt:

    gpg --keyserver keys.gnupg.net --recv 886DDD89
    gpg --export A3C4F0F979CAA22CDBA8F512EE8CBC9E886DDD89 | sudo apt-key add -

You can install it with the following commands:

    $ apt-get update
    $ apt-get install tor deb.torproject.org-keyring

Now Tor is installed and running. Move on to step two of the "Tor on Linux/Unix" instructions.

Оффлайн orionit

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
goodcucumber,
Вот ссылка на скачку архива с браузером, ссылка с оф.сайта.
Всем добра как у бобра, а если вы и без добра добры, значит вы в душе бобры.

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
goodcucumber,
установите синаптик
sudo apt-get install synapticзапустите его, введите в строке поиска tor, в колонке слева выберите "установленные" их скрин сюда

Оффлайн orionit

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
goodcucumber,
установите синаптик
sudo apt-get install synapticзапустите его, введите в строке поиска tor, в колонке слева выберите "установленные" их скрин сюда
А что это за программа?
Всем добра как у бобра, а если вы и без добра добры, значит вы в душе бобры.

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля

Оффлайн goodcucumber

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
goodcucumber,
в synaptic нужно искать, а не в ФМ, как установить написал выше

Оффлайн goodcucumber

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 synaptic : Зависит: libept1.4.12 но он не будет установлен
            Рекомендует: libgtk2-perl (>= 1:1.130) но он не будет установлен
            Рекомендует: rarian-compat но он не будет установлен
 tor-geoipdb : Зависит: tor (>= 0.2.4.27-1build0.14.04.1) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
goodcucumber,
м-даа, а не пытались?
Цитировать
Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
sudo apt-get -f install

Оффлайн goodcucumber

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  tor
Предлагаемые пакеты:
  mixmaster xul-ext-torbutton socat tor-arm apparmor-utils
НОВЫЕ пакеты, которые будут установлены:
  tor
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 0 B/745 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 2 691 kB.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 201196 файлов и каталогов.)
Preparing to unpack …/tor_0.2.4.27-1build0.14.04.1_i386.deb ...
Unpacking tor (0.2.4.27-1build0.14.04.1) ...
dpkg: error processing archive /var/cache/apt/archives/tor_0.2.4.27-1build0.14.04.1_i386.deb (--unpack):
 попытка перезаписать «/usr/bin/tor», который уже имеется в пакете tor-browser 3.5.4
dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)
Processing triggers for ureadahead (0.100.0-16) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/tor_0.2.4.27-1build0.14.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
goodcucumber,
sudo apt-get purge tor-browser

Оффлайн goodcucumber

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 tor-geoipdb : Зависит: tor (>= 0.2.4.27-1build0.14.04.1) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
artem@artem:~$

Оффлайн svtv1

  • Забанен
  • Старожил
  • *
  • Сообщений: 2652
  • Это Я
    • Просмотр профиля
Может, что то из этого поможет
(Нажмите, чтобы показать/скрыть)

По состоянию на 16/06/2019 тема не получает никакого развития. Последняя активность ТС на форуме на данный момент времени: 28 Сентября 2015 (44 месяца назад).
Проблема с высокой долей вероятности не может быть воспроизведена на современном железе и современном ПО другими пользователями. Поэтому, дабы никого не путать, тема признается модератором подлежащей закрытию и последующей архивации. Закрыто
--zg_nico
« Последнее редактирование: 16 Июня 2019, 14:14:13 от zg_nico »
"Если достаточно долго сидеть возле реки - мимо проплывет труп твоего врага"

 

Страница сгенерирована за 0.04 секунд. Запросов: 24.