Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Necessitas  (Прочитано 862 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Max_The_Best123456

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Necessitas
« : 04 Октябрь 2015, 01:26:48 »
Здравствуйте уважаемые программисты!
Надеюсь вы слышали от такой программе Necessitas, и так же как и я сталкивались с проблемами по ее использованию. Я устанавливал эту программу, по данному видео, но я никак не могу скомпилировать и запустить даже самое простое приложение. Установилась все нормально, в android sdk, установил и обновил ВСЕ пакеты.
Когда я запускаю necessitas через терминал, то сначала он выдает такую ошибку: Unable to load library icui18n "Cannot load library icui18n: (icui18n: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога)
Потом, когда пытаюсь скомпилировать программу, пишет такие ошибки:
Object::connect: No such signal ProjectExplorer::Target::activeBuil dConfigurationChanged(BuildConfigur ation*)
Object::connect: (sender name: '{98461392-9e3a-4f4c-a15f-4c95c4f07b5c}')
Object::connect: (receiver name: 'Qt4ProjectManager__Internal__MakeS tep')

Подскажите, что делать, уже мучаюсь третий день, наверное весь гугл перегуглил.

Оффлайн Max_The_Best123456

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Necessitas
« Ответ #1 : 05 Октябрь 2015, 02:59:56 »
Неужели никто не знает???

Оффлайн iCloud

  • Участник
  • *
  • Сообщений: 109
    • Просмотр профиля
Re: Necessitas
« Ответ #2 : 05 Октябрь 2015, 04:09:46 »
Common problems and issues (Linux)

The installation program is a 32-bit binary. When installing on a 64-bit system, you need to have 32-bit libraries available, or else you will get errors about libraries not found.

After enabling Debian multi-arch support, I needed to do "apt-get install libglib2.0-0:i386 libsm6:i386 libxrender1:i386 libfontconfig:i386" before the installer would run.

Оффлайн Max_The_Best123456

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Necessitas
« Ответ #3 : 05 Октябрь 2015, 04:41:12 »
Поэтому сайту тожу устанваливал, и настройки делал как там, не помогло!!!
Все эти пакеты уже установленны!!!
Когда я пытаюсь скомпилировать программу, то necessitas виснет и все!!!
Помогоит пожалуйста, я уже не знаю, что мне делать.

 

Страница сгенерирована за 0.08 секунд. Запросов: 24.