Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Зависимости в 15.10  (Прочитано 3510 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MEJIOMAH17

  • Автор темы
  • Любитель
  • *
  • Сообщений: 87
    • Просмотр профиля
Зависимости в 15.10
« : 04 Октябрь 2015, 14:59:20 »
Стоит ubuntu 15.10 с unity решил поставить сверху KDE5. Установка прошла не успешно и я решил удалить с помощью apt-get autoremove kubuntu-desktop. apt-get ругнулся на зависимости. apt-get install -f выдает
(Нажмите, чтобы показать/скрыть)
Как можно это решить?  И правильно я пытаюсь удалить kde?

Оффлайн chrome_cat

  • Активист
  • *
  • Сообщений: 920
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #1 : 04 Октябрь 2015, 15:41:36 »
Вопросы о тестовых версиях не следует задавать в разделе для новичков. Для этого есть специальная тема - https://forum.ubuntu.ru/index.php?topic=260437.0

Ну и как обычно: тестовые версии не рекомендуются для повседневного использования.

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11315
  • Arch Linux & XMonad
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #2 : 04 Октябрь 2015, 15:50:31 »
Вопросы о тестовых версиях не следует задавать в разделе для новичков.
А вот тут Вы не правы!
Столь элементарный вопрос как раз не следует задавать в разделе "Тестирование", ему самое место тут!
А то, что ТС установил себе тестовую версию, отнюдь не прибавляет ему ни знаний ни опыта.
Как говорится ССЗБ! :)
« Последнее редактирование: 04 Октябрь 2015, 15:52:44 от Haron Prime »
sudo ls -a | grep brain > /dev/head

Оффлайн MEJIOMAH17

  • Автор темы
  • Любитель
  • *
  • Сообщений: 87
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #3 : 04 Октябрь 2015, 21:23:24 »
Версия то тестовая, только она работает лучше. В 14.04 проц работает на 97 градусах, если запускать что-то кроме браузера, 15.04  отваливается интернет каждые 3 минуты. А 15.10 работает шикарно. Если бы не стал ставить KDE и дальше бы работала. Вижу пока дурацкое решение тупо переустановить, но такой метод решения я не хочу использовать.
Haron Prime, Если знаете как решить этот элементарный вопрос, буду рад прочитать решение.
« Последнее редактирование: 04 Октябрь 2015, 21:26:23 от MEJIOMAH17 »

Оффлайн iCloud

  • Участник
  • *
  • Сообщений: 109
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #4 : 04 Октябрь 2015, 21:37:25 »
Стоит ubuntu 15.10 с unity решил поставить сверху KDE5. Установка прошла не успешно и я решил удалить с помощью apt-get autoremove kubuntu-desktop. apt-get ругнулся на зависимости. apt-get install -f выдает
(Нажмите, чтобы показать/скрыть)
Как можно это решить?  И правильно я пытаюсь удалить kde?
http://askubuntu.com/a/458347 Вот тут рекомендация как удалить kubuntu
C учетом того, что у вас Ubuntu следует выполнить следующее:
sudo apt-get install aptitude
sudo aptitude remove '?and(?and(?reverse-depends(kubuntu),?not(?reverse-depends(ubuntu-desktop))), ?not(?or(?priority(required), ?priority(important))))' ubuntu-desktop+

Оффлайн MEJIOMAH17

  • Автор темы
  • Любитель
  • *
  • Сообщений: 87
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #5 : 04 Октябрь 2015, 21:53:57 »
Я не могу ничего установить и удалить
sudo apt-get install aptitude
[sudo] пароль для mark:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия aptitude.
aptitude установлен вручную.
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 kde-telepathy-minimal : Зависит: kde-config-telepathy-accounts (>= 15.04.0) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
« Последнее редактирование: 04 Октябрь 2015, 21:55:42 от MEJIOMAH17 »

Оффлайн orionit

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #6 : 04 Октябрь 2015, 21:58:30 »
MEJIOMAH17,
Сорц лист правил?

В терменал
apt-get update
apt-get upgrade

Пользователь решил продолжить мысль 04 Октябрь 2015, 22:07:53:
Крайне опасно пользовться командой apt-get autoremove он иногда может пол системы снести за ненадобностью,
для удаления пишут
sudo apt-get purge и имя пакетаили
sudo apt-get remove и имя пакетано
sudo apt-get purgeлучше,
а для очистки от старых файлов.
sudo apt-get autoclean
« Последнее редактирование: 04 Октябрь 2015, 22:07:53 от orionit »
Всем добра как у бобра, а если вы и без добра добры, значит вы в душе бобры.

Оффлайн MEJIOMAH17

  • Автор темы
  • Любитель
  • *
  • Сообщений: 87
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #7 : 04 Октябрь 2015, 22:11:32 »
Я не могу ничего установить и удалить
сказал глупость
Выполнил команду sudo aptitude remove '?and(?and(?reverse-depends(kubuntu),?not(?reverse-depends(ubuntu-desktop))), ?not(?or(?priority(required), ?priority(important))))' ubuntu-desktop+
Теперь вообще не запускается система
Проблема так сказать решена

Оффлайн orionit

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #8 : 04 Октябрь 2015, 22:14:09 »
MEJIOMAH17,
Глупость это не есть mind, в следущий раз ставьте  Ubuntu 14.04.
« Последнее редактирование: 04 Октябрь 2015, 22:20:09 от orionit »
Всем добра как у бобра, а если вы и без добра добры, значит вы в душе бобры.

Оффлайн MEJIOMAH17

  • Автор темы
  • Любитель
  • *
  • Сообщений: 87
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #9 : 04 Октябрь 2015, 22:59:35 »
На 14.04 ноутбук ревет как вертолет

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #10 : 04 Октябрь 2015, 23:04:29 »
MEJIOMAH17,
Может надо просто задать вопрос об этом и решить проблему?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн MaxSoniX

  • Новичок
  • *
  • Сообщений: 4
  • Сибиряк
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #11 : 18 Октябрь 2015, 10:03:24 »
Та же ситуация, Ubuntu 15.04, помогло:
sudo dpkg -P unity-scope-gdrive
sudo dpkg -P account-plugin-google
sudo dpkg -P account-plugin-facebook
sudo apt-get install -f
Авось пригодиться :)
Свищу баранкой

kononvaler

  • Гость
Re: Зависимости в 15.10
« Ответ #12 : 16 Ноябрь 2015, 07:50:24 »
Та же ситуация, Ubuntu 15.04, помогло:
sudo dpkg -P unity-scope-gdrive
sudo dpkg -P account-plugin-google
sudo dpkg -P account-plugin-facebook
sudo apt-get install -f
Авось пригодиться :)
Спасибо, добрый человек за единственно правильный ответ на четко поставленный вопрос.
Та-же ситуация на уже НЕ ТЕСТОВОЙ кубунте 15.10, достаточно оказалось удалить
sudo dpkg -P unity-scope-gdrive
sudo apt-get install -f
« Последнее редактирование: 16 Ноябрь 2015, 07:52:22 от kononvaler »

Оффлайн Uncle_Pasha

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #13 : 21 Декабрь 2015, 19:39:39 »
Та же ситуация, Ubuntu 15.04, помогло:
sudo dpkg -P unity-scope-gdrive
sudo dpkg -P account-plugin-google
sudo dpkg -P account-plugin-facebook
sudo apt-get install -f
Авось пригодиться :)
Снимаю шляпу и благодарю, дружище :) мне тоже помогло

Оффлайн Александр Шапкин

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: Зависимости в 15.10
« Ответ #14 : 28 Март 2016, 19:18:22 »
Та же ситуация, Ubuntu 15.04, помогло:
sudo dpkg -P unity-scope-gdrive
sudo dpkg -P account-plugin-google
sudo dpkg -P account-plugin-facebook
sudo apt-get install -f
Авось пригодиться :)
Спасибо тебе, добрый человек!

 

Страница сгенерирована за 0.066 секунд. Запросов: 24.