Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Ubuntu 14.04.3 LTS — проблема с авто. монтированием Windows раздела  (Прочитано 2624 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн NoPainNoGain

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Приветствую всех!

После неудачного перехода на 15.10 решил последовать совету и установить Ubuntu 14.04.3 LTS. Загрузился с USB и в процессе установки настроил монтирование (снял небольшой скринкаст), но если раньше всё стартовало нормально под 15.04, то в LTS наблюдаются следующие странности: выбрав в GRUB и запустив Ubuntu — вижу чёрный экран. Нажимаю Ctrl + Alt + Delete — ПК перезапускается и после выбора Ubuntu ОС начинается загружаться, но в какой-то момент получаю уведомление о том, что не удалось смонтировать NTFS раздел с Windows (точка монтирования /media/windows).

Нажимаю S чтобы пропустить монтирование и Ubuntu загружается, но после того как авторизировался в ОС, логично, не могу получить доступ к разделу /media/windows, пишет такое:

Не удалось получить доступ к «Том 79 GB»

Error mounting system-managed device /dev/sda2: Command-line `mount "/media/windows"' exited with non-zero exit status 14: Windows is hibernated, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Windows работает корректно, но мне кажется, что Ubuntu не может смонтировать раздел с ОС Windows из-за того, что, якобы, Windows находится в режиме гибернации или не завершила свою работу полностью, но в Windows я отключил быстрый запуск, хотя сейчас полагаю, что в этом и может быть причина.

Подскажите, пожалуйста, решения для данной проблемы. Хочу подружить Ubuntu с Windows, т. к. меня больше тянет к Ubuntu, но и от Windows отказаться не могу на данный момент.

Пользователь решил продолжить мысль [time]26 Октябрь 2015, 15:47:03[/time]:
Текст ошибки мне понятен и я пробовал полностью завершать работу Windows, но я не пробовал монтировать раздел с Windows в режиме read-only, т. к. не знаю как это сделать в уже установленной Ubuntu.

Пользователь решил продолжить мысль 26 Октябрь 2015, 16:50:18:
И ещё хотел уточнить по такому вопросу: когда в BIOS я выбирал загрузиться с USB, то я выбирал не UEFI. Может лучше и правильнее было бы устанавливать ОС в режиме UEFI?
« Последнее редактирование: 26 Октябрь 2015, 16:50:18 от NoPainNoGain »

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
NoPainNoGain,
Цитировать
И ещё хотел уточнить по такому вопросу: когда в BIOS я выбирал загрузиться с USB, то я выбирал не UEFI. Может лучше и правильнее было бы устанавливать ОС в режиме UEFI?
в каком режиме винда установлена, в том и Ubuntu нужно ставить.
Цитировать
но в Windows я отключил быстрый запуск, хотя сейчас полагаю, что в этом и может быть причина.
судя по тексту ошибки, не отключил

Оффлайн NoPainNoGain

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
wajnon, Windows установлена в режиме BIOS. Только что решил установить Ubuntu в режиме UEFI (не знал, что Windows установлена в режиме BIOS) и, после установки, GRUB вроде и должен появится (по цвету экрана заметил), но сразу же начала грузиться Ubuntu. Загрузился в Ubuntu и через команду update-grub не обнаружил записи о Windows, поэтому пришлось по этому мануалу восстанавливать загрузчик Windows.

Сегодня буду ещё раз пробовать устанавливать Ubuntu 14.04.3 LTS, но уже в режиме BIOS и остался открытым вопрос: как же всё-таки монтировать раздел с Windows, если у меня быстрая загрузка в ОС Windows отключена и я полностью завершаю работу ПК перед загрузкой Ubuntu?

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
NoPainNoGain,
Цитировать
и остался открытым вопрос: как же всё-таки монтировать раздел с Windows
давай сначала установи, а потом посмотрим

Оффлайн NoPainNoGain

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Установил 14.04 в режиме BIOS. Перезапустил ПК и в GRUB выбрал для загрузки запись Ubuntu. Нажал и дальше чёрный экран. Комбинацией клавиш Ctrl + Alt + Delete отправил ПК в ребут.

Снова в GRUB выбрал Ubuntu и она начала запускаться, но в процессе запуска пишет:

Произошла ошибка при подключении /media/windows.
Нажмите кнопку «S», чтобы пропустить подключение или «M» для ручного восстановления.


В Windows я отключил быструю загрузку, хотя это, похоже, никак не помогает в решении моей проблемы.

Что можно ещё предпринять для решения описанной проблемы?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
NoPainNoGain,
Вам ерунду пишут. Биос и прочее тут ни при чем. У вас винда просто не выключена, а в гибернации. Поэтому и не монтируются виндовые разделы. Вам именно об этом ошибка выдается. Но видимо никто прочитать так и не смог.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
Pilot6,
все читаем, просто ТС многократно утверждает что отключил гибернацию

Оффлайн NoPainNoGain

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
NoPainNoGain,
Вам ерунду пишут. Биос и прочее тут ни при чем. У вас винда просто не выключена, а в гибернации. Поэтому и не монтируются виндовые разделы. Вам именно об этом ошибка выдается. Но видимо никто прочитать так и не смог.
Спасибо за ваш ответ. Содержание ошибки мне понятно и со своей стороны в ОС Windows я всё отключил, вот пруф:



Есть ещё идеи, коллеги?

Оффлайн it0r

  • Старожил
  • *
  • Сообщений: 2276
    • Просмотр профиля
так как же все таки выключаешь windows?
- физической кнопкой питания
или
- графической кнопкой пуск\завершить работу
ТУТ - это дерево. А ЗДЕСЬ - это МЕСТО.... Так что ТУТ - это не ЗДЕСЬ.

Оффлайн NoPainNoGain

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
it0r, физической кнопкой питания никогда ранее не пользовался, выключаю только через интерфейс ОС. Раньше у меня не возникало подобных проблем, когда рядом с Windows устанавливал Ubuntu. Всё, что изменилось, это Windows 8.1 была удалена и на её место стала Windows 10.

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2510
    • Просмотр профиля
Есть ещё идеи, коллеги?

NoPainNoGain, идея следующая: нужно проверить диск командой chkdsk под виндой: в командной строке Windows набираешь
chkdsk C: /F
и нажимаешь Enter. (Вместо C: должна стоять буква диска, с которым проблемы; полагаю, что таки это C:).
Тебе скажут, что диск будет проверен при следующей перезагрузке - совершаешь следующую перезагрузку в винду, дожидаешься конца проверки, затем грузишь Ubuntu и смотришь, что получилось.
Я никого не сторожил!

Оффлайн it0r

  • Старожил
  • *
  • Сообщений: 2276
    • Просмотр профиля
...
дожидаешься конца проверки...
выключаешь windows (не гибернация и т.д.)
ТУТ - это дерево. А ЗДЕСЬ - это МЕСТО.... Так что ТУТ - это не ЗДЕСЬ.

Оффлайн NoPainNoGain

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
alang, к сожалению, ошибка всё равно осталась :( Ещё не могу понять, почему когда я выключил ПК и включаю его, то сразу после выбора в GRUB записи Ubuntu я получаю в итоге чёрный экран вместо запуска ОС? Когда вижу чёрный экран, то нажимаю комбинацию клавиш Ctrl + Alt + Delete и после перезапуска ПК я выбираю в GRUB опять ту же первую запись Ubuntu и ОС начинает запускаться, правда в процессе загрузки я всё же вижу ошибку монтирования.

Может в BIOS нужно что-то поменять? Но раньше, когда у меня была установлена Win 8.1 + Ubuntu 15.04 — всё работало замечательно и не было проблем ни с монтированием, ни с запуском ОС.

Очень хочу разобраться в данной проблеме и прошу помощи у сообщества.

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2510
    • Просмотр профиля
alang, к сожалению, ошибка всё равно осталась :(

Значит, все-таки полного выключения винды не происходит.
Я никого не сторожил!

Оффлайн NoPainNoGain

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
alang, Ubuntu ещё рекомендует монтировать NTFS раздел с Windows в режиме read-only, как правильно это сделать? Может это позволит решить проблему. Мне, в принципе, раздел с Windows и не особо нужен с разрешением на запись.

 

Страница сгенерирована за 0.069 секунд. Запросов: 24.