Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: восстановление GRUB, не запускает liveUSB  (Прочитано 1328 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн caller-door

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Всем доброго времени суток.

Проблема: на ноутбуке hp-pavillion-dv6 стояла ubuntu 14.04
потребовалось установить винду7. После установки произошла стандартная проблема с загрузчиком GRUB. Однако пути решения из этой статьи[http://help.ubuntu.ru/wiki/восстановление_grub] не работают.
Если запускать компьютер в обычном режиме, выбрать для загрузки можно только винду. Если вставить флешку с liveusb (образ записан правильно, в прошлый раз линух ставился как раз с такого) выводит rescue mode. В нём у меня проблема специфическая - дело в том, что на ноутбуке не работают клавиши 0 и 9, соответственно прописать нужные команды не получается. Нашел таблицу символов ASCII, но там для ввода скобки нужно alt+40, что невыполнимо из-за неработающего нуля.
Есть ли какие-то другие пути решения этой проблемы, кроме замены клавиатуры? Ждать несколько дней не хочется. Надеюсь на Вашу изобретательность, уважаемое Ubuntu-сообщество.

Заранее извиняюсь за возможное нубство, и форум, и система для меня новые.
« Последнее редактирование: 04 Январь 2016, 22:22:54 от caller-door »

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 1842
    • Просмотр профиля
Re: восстановление GRUB, не запускает liveUSB
« Ответ #1 : 04 Январь 2016, 22:10:35 »
...пути решения из этой статьи[http://help.ubuntu.ru/wiki/%D0%B2%D0%BE%D1%81%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_grub] не работают.
А что конкретно не получается, или проблема все в тех же неработающих клавишах?..
Так воспользуйся экранной клавиатурой ::)

Оффлайн caller-door

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: восстановление GRUB, не запускает liveUSB
« Ответ #2 : 04 Январь 2016, 22:20:35 »
Что не получается написал в теме:
Цитировать
Если запускать компьютер в обычном режиме, выбрать для загрузки можно только винду. Если вставить флешку с liveusb (образ записан правильно, в прошлый раз линух ставился как раз с такого) выводит rescue mode. В нём у меня проблема специфическая - дело в том, что на ноутбуке не работают клавиши 0 и 9, соответственно прописать нужные команды не получается. Нашел таблицу символов ASCII, но там для ввода скобки нужно alt+40, что невыполнимо из-за неработающего нуля.
Т.е. я не могу запуститься с LiveUSB, по какой-то причине компьютер со вставленной флешкой-загрузчиком выдает мне rescue mode.


Пользователь решил продолжить мысль 04 Январь 2016, 22:44:17:
на всякий случай добавлю, что в БИОСе естественно стоит загрузка с USB.

Более того, тут интересный момент как раз в том, что без флешки rescue mode не запускается, а сразу идет загрузка винды. Значит на флешку с установкой он реагирует, просто почему-то предпочитает грузить Ubuntu с диска.

« Последнее редактирование: 04 Январь 2016, 22:44:17 от caller-door »

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
Re: восстановление GRUB, не запускает liveUSB
« Ответ #3 : 04 Январь 2016, 22:58:30 »
caller-door,
а флешку пробовал перезалить?

Оффлайн caller-door

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: восстановление GRUB, не запускает liveUSB
« Ответ #4 : 04 Январь 2016, 23:19:44 »
wajnon,
пробовал, результат тот же, выдает ошибку
error:
file /boot/grub/i386-pc/normal.mod
not found

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 1842
    • Просмотр профиля
Re: восстановление GRUB, не запускает liveUSB
« Ответ #5 : 05 Январь 2016, 14:40:41 »
...
Более того, тут интересный момент как раз в том, что без флешки rescue mode не запускается, а сразу идет загрузка винды. Значит на флешку с установкой он реагирует, просто почему-то предпочитает грузить Ubuntu с диска.
- а не на флешку ли установлен загрузчик?..
Т.е. в MBR жесткого диска присутствует только первая часть GRUB, которая в момент загрузки передает управление той части загрузчика, которая находится на разделе(или в каталоге) /boot, и если такового на месте не оказывается, то начинается загрузка винды, а вот когда флешка воткнута, то в силу того, что на ней по-любому имеется /boot загрузчик пытается продолжить работать, но тут уже начинаются бока с содержимым и загрузчик вываливается в rescue mode... как-то так...

Ну или вторая версия: на компе не BIOS, а EFI или UEFI ::)

Пользователь решил продолжить мысль 05 Январь 2016, 15:03:15:
Если все-таки второй вариант, то будет не лишним почитать:

http://help.ubuntu.ru/wiki/установка_дистрибутива_на_компьютер_с_efi

http://help.ubuntu.ru/wiki/руководство_по_ubuntu_desktop_14_04/особенности_установки_на_платы_с_uefi
« Последнее редактирование: 05 Январь 2016, 15:03:15 от F12 »

Оффлайн caller-door

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: восстановление GRUB, не запускает liveUSB
« Ответ #6 : 05 Январь 2016, 15:24:24 »
а не на флешку ли установлен загрузчик?..
Т.е. в MBR жесткого диска присутствует только первая часть GRUB, которая в момент загрузки передает управление той части загрузчика, которая находится на разделе(или в каталоге) /boot, и если такового на месте не оказывается, то начинается загрузка винды, а вот когда флешка воткнута, то в силу того, что на ней по-любому имеется /boot загрузчик пытается продолжить работать, но тут уже начинаются бока с содержимым и загрузчик вываливается в rescue mode... как-то так...
Не очень понял суть этого сообщения. Даже если так, это просто попытка найти причину, или есть какой-то шаг, вытекающий из этого, который можно совершить?
На флешке установлен обычный образ 14.04 с оф.сайта, записан через UNetbootin.
Ну или вторая версия: на компе не BIOS, а EFI или UEFI ::)
Нет, ноутбук достаточно старый, на такие UEFI еще не ставили. В любом случае, если я правильно понимаю, здесь проблема бы возникла еще при первой установке. Первая установка проходила нормально, с этой же флешки и этого же образа все запустилось. Единственный вариант, возможный здесь, что флешка именно сейчас вдруг прекратила работоспособность, во что мне не сильно верится.

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
Re: восстановление GRUB, не запускает liveUSB
« Ответ #7 : 05 Январь 2016, 18:37:14 »
caller-door,
Цитировать
На флешке установлен обычный образ 14.04 с оф.сайта, записан через UNetbootin.
думаю дело таки в флешке. Если есть возможность, проверь эту флешку на другом компе.

Оффлайн caller-door

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: восстановление GRUB, не запускает liveUSB
« Ответ #8 : 05 Январь 2016, 20:47:50 »
В общем, новая информация по моей проблеме. Попробовал еще порыться в загрузке через rescue mode, выяснил следующее
1)он пытается запустить систему с флешки, т.е
error:
file /boot/grub/i386-pc/normal.mod
not found
Этот файл он ищет на флешке, на ней его нет и, насколько я понял, не должно быть. Соответсвенно система не запускается.
2)насколько я понял, команды типа set root=hd1,1 выполняются и без кавычек. Поэтому я попробовал найти папку /boot/grub на всех доступных дисках. Он определяет 2 диска, на первом 1 раздел (это как раз флешка), на втором 5. Из них три первых выдают ошибку unknown system (это, видимо винда), на двух последних должна стоять ubuntu (swap и root). В обоих посмотрел(не помню порядок), в папке /boot нет папки /grub. На этом моменте перезагрузился, и пришел сюда спросить, может быть есть какие идеи или советы.

Если что, могу выложить фотку, в которой показано содержимое папок /boot этих двух дисков.



Только что понял, что те два диска, которые определяются, это как раз таки диски с виндой. Значит, юнноун систем он как раз про Ubuntu пишет

Пользователь решил продолжить мысль 06 Январь 2016, 02:09:04:
Всем ответившим большое спасибо, как я и предупреждал в начале, я честный чайник, и проблема оказалась вполне чайниковская -
флешку я форматировал в нтфс, а не в фат.
После решения вопроса с флешкой все пошло как по маслу, сейчас пишу уже со своей Ubuntu.

Так что правы были те, кто грешил на образ на флешке.
« Последнее редактирование: 06 Январь 2016, 02:09:04 от caller-door »

 

Страница сгенерирована за 0.06 секунд. Запросов: 24.