Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Не могу настроить pppoe и ethernet - соединения в systemd  (Прочитано 570 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн art85com

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Здравствуйте, хочу попросить помощи, т.к. не нашел сколько - нибудь вменяемой информации по интересующему меня вопросу.
В ubuntu  всегда настраивал интернет (PPPOE) через pppoeconf и приводил фаил /etc/network/interfaces к такому виду:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# Moya provodnaya set
iface eth0 inet dhcp
address 78.........
netmask 255........
gateway 10.........
auto eth0

# Moy McLaut
auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
provider dsl-provider

И в результате при старте ОС  и ethernet и pppoe запускались и работали одновременно. А как этого добиться в Systemd?
(Пробовал через network-manager, но он не поднял   ethernet и pppoe одновременно, да и периодически падает он)
В ubuntu 15.10  мой проверенный способ  c pppoeconf не сработал.( Хоть я даже пытался менять названия интерфейсов eth0 на enp1s0, не помогло)

Как же всё таки добиться, чтобы  ethernet и pppoe запускались и работали при старте (одновременно) в Systemd ?

Заранее спасибо за помощь.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26078
    • Просмотр профиля
Не использовать systemd…
И вообще последний LTS 14.04
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн art85com

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Вопрос был о том, что "как же всё таки добиться, чтобы ethernet и pppoe запускались и работали при старте (одновременно) в Systemd ?"
Вы знаете как?

Не использовать systemd…
И вообще последний LTS 14.04

Вопрос не про Ubuntu 14.04 (там используется upstart), вопрос о том, как настроить ethernet и pppoe в systemd.

Заранее спасибо за помощь.

shura1

  • Гость
Те, кто могут помочь - а это системные специалисты, сидят на LTS и плюются в сторону systemd. Когда придет время (не раньше лета, а то и позже гораздо), тогда и разберутся. А те, кто ставят 15.10, в большинстве случаев, даже не знают, что это такое.

Как бы так.

На форуме Федоры можно попробовать спросить. Они уже давно с этой эээ... системой... общаются плотно.

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5660
  • elementaryOS 0.4 Loki, i3wm on Debian9
    • Просмотр профиля
address 78.........
gateway 10.........
Быть такого не может!
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн art85com

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Да, не может (я просто убрал полные данные). Согласитесь это не сильно меняет суть дела. Меня интересует возможно ли автоматическое поднятие ethernet и pppoe в systemd или нет? В upstart знаю, что можно (сам делал) Меня интересует последовательность действий (алгоритм).

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.