Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Сетевой адаптер сам переключается в 10 мбитный режим  (Прочитано 1147 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн atropgeon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Здравствуйте.
Прошу помочь решить досадную проблему, начну пожалуй с самого начала.
Есть зверёк HP Compaq dc7100 USDT, решил на нем завести SMB сервер, что бы качал торренты 24/7 и служил файло-хранилищем для моей RaspberryPi, конектится для управления планировал по RDP или аналогам...
  По скольку железо достаточно старое 2004 год, я решил взять старый дистрибутив убунты, а именно 10.04, самый полюбившийся мной), накатал и вроде все отлично, но заметил что сетевая карта работает в режиме 10 мбит а не 100 мбит как мне надо, я много чего перепробовал, переключал сет. адаптер в фулл дуплекс (хотя он и так был включен) пересобирал ядро по какой то инструкции в сети, и т д.
  Решить проблему мне не удалось, я решил перейти на более новую ос Ubuntu, мало ли, на форумах нашел еще несколько подобных постов с моей сетевой картой и ядром что на 10.04, мол не работает и все.
Скачал 12.04, запустилась уже очевидно тяжелее, но тем не менее запустилась, и тут я тоже столкнулся с этой проблемой, сетевой адаптер на отрез работает только в 10 мбитном режиме.
  Была глубокая ночь, и я решил накатать Win_7, хотя для нее нету драйверов на офф сайте, вот уже месяц как стоит ос Win_7, торренты качает, файлопомойкой в локалке работает, да и вроде все ок, сетевуха заработала с коробки в 100 мбитном режиме, но я планирую еще поднять несколько сервисов на этом сервере, то есть WinOS тут никак не годится, да и драйверов то нету под нее.
 То есть я хочу настоятельно поставить Ubuntu, но я не знаю в чем проблема с сетевым адаптером, помогите выяснить.
Некоторые данные о железе, в частности сетевая карта
Intel Pentium 4 530
Broadcom NetXtreme BCM5750 Gigabit Ethernet Controller
Чипсет Intel Grantsdale-G i915GV
Видео-чип Intel GMA 900
3Gb Ram


Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Без самой Ubuntu точно никто не поможет.
Запустите хотя бы в ежиме LiveCD/USB  и покажите выхлоп команды
lshw -c network
Только, пожалуйста, без картинных галерей.
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн atropgeon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Без самой Ubuntu точно никто не поможет.
Запустите хотя бы в ежиме LiveCD/USB  и покажите выхлоп команды
lshw -c network
Только, пожалуйста, без картинных галерей.
вот вывод команды
lshw -c network
  *-network               
       description: Ethernet interface
       product: NetXtreme BCM5751 Gigabit Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:40:00.0
       logical name: eth0
       version: 01
       serial: 00:12:65:e4:4a:53
       size: 10MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.102 duplex=full firmware=5751-v3.29a ip=192.168.88.192 latency=0 link=yes multicast=yes port=twisted pair speed=10MB/s
       resources: irq:17 memory:f0400000-f040ffff


Axa-Ru

  • Гость
А попробуйте дать команду
sudo ethtool -s eth0 speed 1000 duplex full autoneg on wol dесли будет выхлоп, то покажите его.
После покажите опятьlshw -c network

Оффлайн atropgeon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Axa-Ru
После применения вашей команды настройки сети переключились на wi-fi, хотя его нету в пк.
Вывод команды lshw -c network никак не поменялся.
« Последнее редактирование: 08 Январь 2016, 02:20:54 от atropgeon »

Axa-Ru

  • Гость
Очень странно про wifi.
Попробуйте заменить патчкорд.

Оффлайн atropgeon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Очень странно про wifi.
Попробуйте заменить патчкорд.
Патчкорд заведомо заменил на 100% исправный, дело не может быть в кабеле, так как на Win_os все работает в режиме 100mbit/s
В добавку я вставлял в pci слот внешнюю сетевую карту от Intel, она тоже не работает в 100mbit/s, ну никак, что с стандартными драйверами, что с драйверами проприетарными, правда эта карта тоже гигабитная, чисто 100 мегабитной нету дома.
« Последнее редактирование: 08 Январь 2016, 02:24:24 от atropgeon »

Axa-Ru

  • Гость
Попробуйте. Хуже от этого уж точно не будет.

Оффлайн atropgeon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Попробуйте. Хуже от этого уж точно не будет.

если вы о патчкорде то я только что специально передернул с портов кабель, вытянул свой с ББ и вставил в сервер, а с сервера в свой ББ под управлением Win_os 10, и с кабелем все в порядке, а вот тот кабель что вставил в сервер с ББ ничего не поменял, все также.
да и вообще, патчкорды обжаты на заводе, не я их в подвале при плохом освещении обжимал, чего вы так к физическому уровню уделяете внимание?!
На семействе os Windows все работает с коробки, и в семействе *nix даже с бубнами никак.
проблема однозначно в программной составляющей.

« Последнее редактирование: 08 Январь 2016, 02:31:24 от atropgeon »

Axa-Ru

  • Гость
А в какое сетевое устройство подключается компьютер?

Оффлайн atropgeon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
А в какое сетевое устройство подключается компьютер?
не совсем понял вопроса? если вы о маршрутизаторе, то проверял на 2х устройствах, тоже что бы исключить фактор сетевого оборудования.
1) MikroTik RB951Ui-2HnD RouterOS v6
2) Linksys WRT150N rev_1 DD-WRT v24
« Последнее редактирование: 08 Январь 2016, 02:38:57 от atropgeon »

Axa-Ru

  • Гость
Ага, я просто понять, почему соединяется на 100 MB под виндами.

Смотрите, сейчас последний драйвер для этой карты имеет версию 3.137k. А у вас driverversion=3.102.
Не думаю, что причина в этом. Оставим драйвер напоследок.

В предыдущий раз я дал команду перевода сетевого интерфейса на скорость 1 GB.
Давайте попробуем на 100 MB:
sudo ethtool -s eth0 speed 100 duplex full autoneg
« Последнее редактирование: 08 Январь 2016, 02:46:21 от Axa-Ru »

Оффлайн atropgeon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля

не могу исполнить эту команду, выдает ошибку ethtool bad command line argumentкоманду точно правильно ввожу, даже копировал, выдает ошибку почему то
upd
для справки, я получил эту железку с freeBSD на борту, потестировал железо именно на это ос, но по скольку я не умею пользоваться freeBSD, я отформатировал винт, и накатал Ubuntu, но на freeBSD сетевой адаптер работал на скорости 100mbit/s, я в этом уверен, так как пробовал качать с рутрекера, качало при скорости 11мбайт/с
« Последнее редактирование: 08 Январь 2016, 03:07:09 от atropgeon »

Axa-Ru

  • Гость
Мой косяк.
sudo ethtool -s eth0 speed 100 duplex full autoneg on

Оффлайн atropgeon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
sudo ethtool -s eth0 speed 100 duplex full autoneg on
при использовании этой команды отваливается сеть, но вывод команды lshw -c network меняется на
lshw -c network
  *-network               
       description: Ethernet interface
       product: NetXtreme BCM5751 Gigabit Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:40:00.0
       logical name: eth0
       version: 01
       serial: 00:12:65:e4:4a:53
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.102 duplex=full firmware=5751-v3.29a ip=192.168.88.192 latency=0 link=yes multicast=yes port=twisted pair speed=10MB/s
       resources: irq:17 memory:f0400000-f040ffff

 

Страница сгенерирована за 0.063 секунд. Запросов: 26.