Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Сервер в школе.  (Прочитано 491 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн doom753

  • Автор темы
  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
Сервер в школе.
« : 08 Январь 2016, 00:37:34 »
Здравствуйте!Что посоветуете поставить в школу на ubuntu, нужен шлюз, нужно резать скорость каждому IP как входящий так и исходящий  примерно на 30 пк.Так что бы раз настроить и всё.Спасибо.


SQUID + SAMS на этом получится всё это реалезовать, если есть возможность ссылку.Спасибо
« Последнее редактирование: 08 Январь 2016, 03:19:46 от doom753 »

Оффлайн theurs

  • Активист
  • *
  • Сообщений: 457
    • Просмотр профиля
Re: Сервер в школе.
« Ответ #1 : 08 Январь 2016, 04:21:13 »
Резать скорость на сквиде, да еще в обе стороны? Это фантастика. Если нужно обеспечить справедливое деление канала так что бы у какого то конкретно клиента не было лагов когда кто то другой бродит по интернетам сквид со своими делей пулами сразу идет лесом.
Так же ничего не получится если канал медленный, скажем 2мбита на 10 одновременно лайкающий котиков и слушающих музыку  вконтакте никакой магией нормально работать не заставишь.
https://forum.ubuntu.ru/index.php?topic=33853.15 способ нарезать канал есть но он совсем не прост.

Оффлайн bukass

  • Активист
  • *
  • Сообщений: 976
    • Просмотр профиля
Re: Сервер в школе.
« Ответ #2 : 08 Январь 2016, 06:45:27 »
doom753,
Купите нормальный роутер (из прибалтики). PCQ очередями можно сделать то, что вы желаете.
Всем пора в Изумрудный город, кому за умом, кому за сердцем.

shura1

  • Гость
Re: Сервер в школе.
« Ответ #3 : 08 Январь 2016, 07:25:30 »
QoS, не ? Роутеры уже с ним часто идут. Ну и Ubuntu-сервер уже вроде ядро сконфигурировано. Правда не знаю, насколько эффективно, я дома пробовал (детей резать), толку не получил. Впрочем не сильно пробовал. И на Asus-роутере, где как-бы рельсы. На сервере можно и разные настройки попробовать, и результаты отследить.

Оффлайн bukass

  • Активист
  • *
  • Сообщений: 976
    • Просмотр профиля
Re: Сервер в школе.
« Ответ #4 : 08 Январь 2016, 13:10:31 »
Jshura,

Какие к чёрту asus. Я о mikrotik

К примеру этим правилом можно разруливать трафик в 10 мб/с не важно на сколько клиентов, делится будет поровну на тянущих/раздающих.

/queue simple
add max-limit=10/10M name=porovnu queue=pcq-upload-default/pcq-download-default \
    target=192.168.88.0/24

Всем пора в Изумрудный город, кому за умом, кому за сердцем.

shura1

  • Гость
Re: Сервер в школе.
« Ответ #5 : 08 Январь 2016, 13:18:07 »
bukass,
Да я к ТС обращался. Я вообще с сетями не дружу, работал постоянно командой, мое дело программировать. Азы знаю, умею, а до практики и нестандартных вопросов как-то руки все не доходят. Надо бы собраться да освоить, а то даже стыдно)

Оффлайн theurs

  • Активист
  • *
  • Сообщений: 457
    • Просмотр профиля
Re: Сервер в школе.
« Ответ #6 : 09 Январь 2016, 12:05:12 »
Jshura,

Какие к чёрту asus. Я о mikrotik

К примеру этим правилом можно разруливать трафик в 10 мб/с не важно на сколько клиентов, делится будет поровну на тянущих/раздающих.

/queue simple
add max-limit=10/10M name=porovnu queue=pcq-upload-default/pcq-download-default \
    target=192.168.88.0/24



Простой очередью можно справедливо поделить канал в микротике? Ничего не путаешь?

Оффлайн bukass

  • Активист
  • *
  • Сообщений: 976
    • Просмотр профиля
Re: Сервер в школе.
« Ответ #7 : 09 Январь 2016, 19:36:24 »
theurs,
Нет, попробуй.
Всем пора в Изумрудный город, кому за умом, кому за сердцем.

Оффлайн theurs

  • Активист
  • *
  • Сообщений: 457
    • Просмотр профиля
Re: Сервер в школе.
« Ответ #8 : 11 Январь 2016, 08:00:20 »
theurs,
Нет, попробуй.
pcq - Per Connection Queue, справедливо делит между соединениями но не между юзерами, один юзер с многопотоковой качалкой может сожрать весь интернет.

 

Страница сгенерирована за 0.064 секунд. Запросов: 24.