Форум русскоязычного сообщества Ubuntu


Автор Тема: Абсолютно нет звука  (Прочитано 1235 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Billy_Bones

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Абсолютно нет звука
« : 11 Январь 2016, 16:07:42 »
Добрый всем день.
Судя по запросам тема избитая, но конкретного решения не нашел.
При установке Ubuntu 14.04 LTS (32-битная) нет звука. На прошлой ОС (винда) звук был.

(Нажмите, чтобы показать/скрыть)

Прошу тапками не кидать :(

Оффлайн samson2

  • Участник
  • *
  • Сообщений: 169
    • Просмотр профиля
Re: Абсолютно нет звука
« Ответ #1 : 11 Январь 2016, 16:32:21 »
Была у меня такая звуковуха(чтоб ей), на 14.04 так и не завелась, только на 12.04.
(Ubuntu 12.04),(Linux Mint 17.3),(Ubuntu Mate 16.04) .

Оффлайн Billy_Bones

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: Абсолютно нет звука
« Ответ #2 : 11 Январь 2016, 18:50:28 »
А можно поинтересоваться как откатить версию?

Оффлайн samson2

  • Участник
  • *
  • Сообщений: 169
    • Просмотр профиля
Re: Абсолютно нет звука
« Ответ #3 : 11 Январь 2016, 18:56:56 »
Billy_Bones, Такого отката нет, попробуй LiveCD/USB c 12.04 - если в Live режиме звук будет, то тогда можно будет просто установить.
(Ubuntu 12.04),(Linux Mint 17.3),(Ubuntu Mate 16.04) .

Оффлайн lin_user

  • Старожил
  • *
  • Сообщений: 1292
    • Просмотр профиля
Re: Абсолютно нет звука
« Ответ #4 : 11 Январь 2016, 18:59:38 »
Цитировать
hdmi:CARD=NVidia
Надо отключить, потому что вывод hdmi выставляется по умолчанию. У меня Nvidia HDMI Audio почему-то всегда оказывается в приоритете и никакие переключения через alsamixer не помогают. Приходится заносить в blacklist.conf. У меня полноценная звуковуха, а встройка вообще отключена и я не проверял, но подозреваю, что если внести туда запись snd_hda_intel, то звук совсем пропадёт.

Ещё можно в конфиге пульсы прямо указать устройство.

Надо погуглить ubuntu disable hdmi audio output.

С HDA проблем быть не должно. По крайней мере, я ни разу не попадал, что встройка не давала звука в линуксе.
« Последнее редактирование: 11 Январь 2016, 19:13:41 от lin_user »

Оффлайн Billy_Bones

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: Абсолютно нет звука
« Ответ #5 : 11 Январь 2016, 20:11:34 »
lin_user,
Подскажите пожалуйста какой командой отключить CARD=NVidia?

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 1801
    • Просмотр профиля
Re: Абсолютно нет звука
« Ответ #6 : 11 Январь 2016, 20:27:10 »
Звуковую карту можно сделать 1-й приписыванием ей индекса 0
в /etc/modprobe.d/alsa-base.conf и последней назначением ей индекса -2 тм же.
Или она этим вообще запрещается, не помню.
Пётр.

Оффлайн Billy_Bones

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: Абсолютно нет звука
« Ответ #7 : 11 Январь 2016, 20:49:55 »
Peter_I,
Подскажите где именно нужно изменить? У меня там почему-то везде -2
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 11 Январь 2016, 21:00:01 от Billy_Bones »

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 1801
    • Просмотр профиля
Re: Абсолютно нет звука
« Ответ #8 : 12 Январь 2016, 09:31:16 »
Т.е. должна быть запись
options snd-hda-intel index=0Вот этот файл для случая, когда используется usb sound card:
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

alias snd-card-0 snd-usb-audio
alias sound-slot-0 snd-card-0
#alias sound-slot-0 snd-usb-audio

alias char-major-14 soundcore
alias snd-service-0-0 snd-mixer-oss
alias snd-service-0-1 snd-seq-oss
alias snd-service-0-3 snd-pcm-oss
alias snd-service-0-8 snd-seq-oss
alias snd-service-0-12 snd-pcm-oss


# Prevent abnormal drivers from grabbing index 0
options snd-usb-audio index=0
options snd-hda-intel index=1
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=2
Я сейчас не помню, можно ли в одной строке после index указывать model=<model>.
Пётр.

 

Страница сгенерирована за 0.061 секунд. Запросов: 24.