Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Как удовлетворить зависимости чтобы заработал apt-get?  (Прочитано 1963 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн WhiteLedy

  • Автор темы
  • Любитель
  • *
  • Сообщений: 88
  • https://github.com/WhiteLaedyAnn
    • Просмотр профиля
Тема отпочковалась из этой - https://forum.ubuntu.ru/index.php?topic=271927.0

Дело в том, что у меня не работает apt-get >:( из-за этих самых зависимостей

(Нажмите, чтобы показать/скрыть)

В предыдущей теме мне советивали применить  dpkg -l и сделать что-то с помечанными ашками приложениями, но у меня все пакеты были либо ii либо rc (в редких случаях по-другому, например iF) но h в этих метках нигде не присутствовало

Не помогают вот такие способы:
1)sudo apt-get --fix-broken install
(Нажмите, чтобы показать/скрыть)

2)sudo rm /var/lib/apt/lists/* -vf 
sudo apt-get update
(Нажмите, чтобы показать/скрыть)
3)sudo apt-get clean

sudo apt-get autoclean

sudo apt-get autoremove
4)
sudo dpkg --configure -a

sudo apt-get update
(Нажмите, чтобы показать/скрыть)
5)Открыла Центр приложений Ubuntu и увидела запрос на восстановление сломанных пакетов, нажала на кнопку Исправить.
Выдало:
Ошибка операции над пакетом
(Нажмите, чтобы показать/скрыть)

6) sudo apt-get -f install
(Нажмите, чтобы показать/скрыть)

 :o Вооще не представляю что с этим делать
« Последнее редактирование: 12 Январь 2016, 19:06:04 от WhiteLedy »
*/ ///______I BANGBANG   
) . /_(_)             
/__/

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1815
    • Просмотр профиля
1 закрыть все другие приложения использующие apt
2 lsof /var/cache/debconf/config.dat
3 rm /var/cache/debconf/*.dat
чистим кэш:
sudo rm -f /var/lib/apt/lists/{,partial/}* /var/cache/apt/archives/{,partial/}*  2>/dev/nullи что в sources.list
grep -v '^#\|^$' /etc/apt/sources.list{,.d/*.list}



Оффлайн WhiteLedy

  • Автор темы
  • Любитель
  • *
  • Сообщений: 88
  • https://github.com/WhiteLaedyAnn
    • Просмотр профиля
1 закрыть все другие приложения использующие apt

Вроде все закрыты

2 lsof /var/cache/debconf/config.dat
Вбила, терминал реакции не выдал

3 rm /var/cache/debconf/*.dat
чистим кэш:
sudo rm -f /var/lib/apt/lists/{,partial/}* /var/cache/apt/archives/{,partial/}*  2>/dev/nullи что в sources.list
grep -v '^#\|^$' /etc/apt/sources.list{,.d/*.list}

Везде нажала ентер
(Нажмите, чтобы показать/скрыть)
(Нажмите, чтобы показать/скрыть)
*/ ///______I BANGBANG   
) . /_(_)             
/__/

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26067
    • Просмотр профиля
ARTGALGANO, шикарно помогли, чо…
WhiteLedy, если apt говорит. что используется, значит, скорее всего - используется.
Тот же центр приложений запущен, небось.
Перезагружайте систему, жмите Esc пока не выпадет список режимов загрузки.
Выбирайте режим восстановления и вот там делайте
apt-get install -f
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн WhiteLedy

  • Автор темы
  • Любитель
  • *
  • Сообщений: 88
  • https://github.com/WhiteLaedyAnn
    • Просмотр профиля
ARTGALGANO, шикарно помогли, чо…
WhiteLedy, если apt говорит. что используется, значит, скорее всего - используется.
Тот же центр приложений запущен, небось.
Перезагружайте систему, жмите Esc пока не выпадет список режимов загрузки.
Выбирайте режим восстановления и вот там делайте
apt-get install -f
Спасибо за ответ :)
Сейчас попробую.
*/ ///______I BANGBANG   
) . /_(_)             
/__/

shura1

  • Гость
Блин. Я как-то мимо. Не ожидал. Прошу прощения у всех

16.04 (да и 15.10 по большому счету) должны устанавливать те, кто отвечают на вопросы, а не задают их.

Оффлайн WhiteLedy

  • Автор темы
  • Любитель
  • *
  • Сообщений: 88
  • https://github.com/WhiteLaedyAnn
    • Просмотр профиля
WhiteLedy, если apt говорит. что используется, значит, скорее всего - используется.
Тот же центр приложений запущен, небось.
Перезагружайте систему, жмите Esc пока не выпадет список режимов загрузки.
Выбирайте режим восстановления и вот там делайте
apt-get install -f
Выпол список режимов загрузки
Выбрала восстановление
Выпол квадрат с квадратиками внутри - видимо, квадратики были вместо букв  я выбрала самую первую надпись и дальше ubuntu загрузилась как обычно
Где там терминал, я не поняла

Пользователь решил продолжить мысль [time]12 Январь 2016, 21:43:03[/time]:
Блин. Я как-то мимо. Не ожидал. Прошу прощения у всех

16.04 (да и 15.10 по большому счету) должны устанавливать те, кто отвечают на вопросы, а не задают их.
Почему? Что не так с релизами?

Пользователь решил продолжить мысль 12 Январь 2016, 20:48:51:
Ну ладно, буду тогда ставить ниже 15.
Jshura,
AnrDaemon,
ARTGALGANO,
спасибо большое!!!)
« Последнее редактирование: 12 Январь 2016, 20:48:51 от WhiteLedy »
*/ ///______I BANGBANG   
) . /_(_)             
/__/

shura1

  • Гость
14.04 -  :coolsmiley:
15.10 -  :-\
16.04 -  :idiot2:

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 1863
    • Просмотр профиля
16.04 (да и 15.10 по большому счету) должны устанавливать те, кто отвечают на вопросы, а не задают их.
Почему? Что не так с релизами?
Я конечно понимаю что тема не в "юморе", но не удержался:


Что вы первым делом устанавливаете, после установки системы? Расскажите нам, иначе вас постигнет та же участь с вновь установленной системой.
Левые репозитории из ниоткуда взяться не могли.
Intel Core i3-3220 3.30GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, SAMSUNG_MZMPC032- Kubuntu 18.04-х64

Оффлайн WhiteLedy

  • Автор темы
  • Любитель
  • *
  • Сообщений: 88
  • https://github.com/WhiteLaedyAnn
    • Просмотр профиля
16.04 (да и 15.10 по большому счету) должны устанавливать те, кто отвечают на вопросы, а не задают их.
Почему? Что не так с релизами?
Я конечно понимаю что тема не в "юморе", но не удержался:


Что вы первым делом устанавливаете, после установки системы? Расскажите нам, иначе вас постигнет та же участь с вновь установленной системой.
Левые репозитории из ниоткуда взяться не могли.
Первым делом устанавливала? Qt, Code::Blocks, mypaint, battle for wesnoth, пару других приложений из цп и что?
В прошлый раз после усановки этих программ ничего не случалось.
Про оно само, я ничего не говорила, я говорила о том, что не делала экспериментов из под рута.
Такое впечатление что только и ждёшь случая, чтобы по теме и без покидать пакостных картиночек с какими-то левыми бабами.  Aleksandru,ты омерзителен. Мерзкий сексист. 
*/ ///______I BANGBANG   
) . /_(_)             
/__/

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11315
  • Arch Linux & XMonad
    • Просмотр профиля
Aleksandru,
WhiteLedy,
Предупреждаю обоих - выяснять отношения идите в ЛС!
sudo ls -a | grep brain > /dev/head

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26067
    • Просмотр профиля
WhiteLedy, если apt говорит. что используется, значит, скорее всего - используется.
Тот же центр приложений запущен, небось.
Перезагружайте систему, жмите Esc пока не выпадет список режимов загрузки.
Выбирайте режим восстановления и вот там делайте
apt-get install -f
Выпол список режимов загрузки
Выбрала восстановление
Выпол квадрат с квадратиками внутри - видимо, квадратики были вместо букв  я выбрала самую первую надпись и дальше ubuntu загрузилась как обычно
Где там терминал, я не поняла
Квадратики - это не есть хорошо :(

Соглашусь с предыдущим оратором, ставьте 14.04 (текущий LTS)
Вероятность нарваться на интересные особенности мышления спецов из Каноникала будет минимальна.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 1863
    • Просмотр профиля
Первым делом устанавливала? Qt,
Прошу прощения.
В Qt не могла быть причина? Что то он часто у вас под спойлерами упоминается.
Я как то Qt Creator ставил, так таких дров наломал. Очень уж эти кути, версия- зависимые.
Intel Core i3-3220 3.30GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, SAMSUNG_MZMPC032- Kubuntu 18.04-х64

 

Страница сгенерирована за 0.07 секунд. Запросов: 24.